Results 1 to 6 of 6

Thread: Trouble building OSS version server under Gentoo

  1. #1
    JonathansCornerCom's Avatar
    JonathansCornerCom is offline Intermediate Member
    Join Date
    Aug 2008
    Posts
    24
    Rep Power
    7

    Default Trouble building OSS version server under Gentoo

    I'm running Gentoo and want the Franklin server. I am presently having trouble getting p4 to download a synced version of the code (the initial command appeared not to pull everything):

    Code:
    jhayward-desktop jhayward # p4 -u public -P public1234 -c public-view sync //depot/zcs/FRANKLIN/...
    Remote depot 'depot' database access failed.
    TCP connect to localhost:2667 failed.
    connect: localhost:2667: Connection refused
    jhayward-desktop jhayward # p4 set
    P4EDITOR=vim
    P4PORT=codes.zimbra.com:2666
    jhayward-desktop jhayward # export P4PORT=depot.zimbra.com:1666
    jhayward-desktop jhayward # p4 -u public -P public1234 -c public-view sync //depot/zcs/FRANKLIN/...
    Perforce client error:
            Connect to server failed; check $P4PORT.
            TCP connect to depot.zimbra.com:1666 failed.
            connect: depot.zimbra.com:1666: Connection timed out
    jhayward-desktop jhayward #
    How can I get the source code to a good, recent version of the server that will compile under Gentoo?

    Thanks,
    Jonathan Hayward, christos.jonathan.hayward@gmail.com

    To see an award-winning website with stories, essays, artwork, games, and a four-dimensional maze, why not visit my home page? All of this is waiting for you at JonathansCorner.com.

    Would you like to curl up with one of my hardcover books? You can now get my books from CJSHayward.com.

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    you need to use sync -f. this will force a complete pull of everything from the path you specify - unfortunately p4 with a single public account doesn't seem to do diff updates like cvs/svn, which restricts it's usefullness as a cvs/svn type service. better to think of it as a 'nightly' tarball repository.

  3. #3
    JonathansCornerCom's Avatar
    JonathansCornerCom is offline Intermediate Member
    Join Date
    Aug 2008
    Posts
    24
    Rep Power
    7

    Default

    Clarification: Could you post the P4PORT value and exact command line I should be using? I've tried with P4PORT equal to "depot.zimbra.com:1666" and a command of:

    Code:
    p4 -u public -P public1234 -c public-view sync -f //depot/zcs/FRANKLIN/...
    and am not even able to connect with the host. Is this a local network issue on my end, or should I be using a different way of trying to access it?

    My goal is to download and build the server.
    Jonathan Hayward, christos.jonathan.hayward@gmail.com

    To see an award-winning website with stories, essays, artwork, games, and a four-dimensional maze, why not visit my home page? All of this is waiting for you at JonathansCorner.com.

    Would you like to curl up with one of my hardcover books? You can now get my books from CJSHayward.com.

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    try again now, the p4 cache seems to be working again.
    Last edited by dijichi2; 08-15-2008 at 10:26 AM.

  5. #5
    JonathansCornerCom's Avatar
    JonathansCornerCom is offline Intermediate Member
    Join Date
    Aug 2008
    Posts
    24
    Rep Power
    7

    Default

    I've tried from two computers and can't connect to depot.zimbra.com 1666.
    Jonathan Hayward, christos.jonathan.hayward@gmail.com

    To see an award-winning website with stories, essays, artwork, games, and a four-dimensional maze, why not visit my home page? All of this is waiting for you at JonathansCorner.com.

    Would you like to curl up with one of my hardcover books? You can now get my books from CJSHayward.com.

  6. #6
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    P4PORT=codes.zimbra.com:2666

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 10:27 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. migrate20070809-Signatures.pl?
    By j.mc in forum Installation
    Replies: 4
    Last Post: 06-11-2008, 09:52 AM
  4. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 04:47 AM
  5. Replies: 18
    Last Post: 03-20-2006, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •