Results 1 to 7 of 7

Thread: [SOLVED] Why my MTA Cross???

  1. #1
    fsloke is offline Loyal Member
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    6

    Default [SOLVED] Why my MTA Cross???

    So far I know MTA is use for sending mail...

    As the stated in Zimbra Collaboration Suite Single Server Installation - Open Source Documentation...
    ... For sending mail, the MTA uses DNS to resolve hostnames and email-routing information. To receive mail the MX record must be configured correctly to route the message to the mail server...
    If my MTA fail to install mean that I cannot send out email nor receive email...

    I follow step by step the configuration that documented inside the Zimbra Collaboration Suite Single Server Installation - Open Source
    [ http://www.zimbra.com/community/documentation.html ]

    How can I fixed it and make the Zimbra mail server works???

    This is the MTA Cross


    The log during the configuration....
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.14008]
    Saving config in /opt/zimbra/config.14008...done.
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.01001900-0000139009316.log
    Setting local config values...done.
    Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Creating SSL certificate...done.
    Installing mailboxd SSL certificates...done.
    Initializing ldap...done.
    Setting replication password...done.
    Setting Postfix password...done.
    Setting amavis password...done.
    Saving CA in ldap ...done.
    Creating server entry for server.um.edu.my...done.
    Saving SSL Certificate in ldap ...done.
    Setting spell check URL...done.
    Setting service ports on server.um.edu.my...done.
    Adding server.um.edu.my to zimbraMailHostPool in default COS...done.
    Installing skins...
    yahoo
    bones
    steel
    lemongrass
    beach
    waves
    sand
    lavender
    sky
    hotrod
    bare
    done.
    Setting zimbraFeatureIMEnabled=FALSE...done.
    Setting zimbraFeatureTasksEnabled=TRUE...done.
    Setting zimbraFeatureBriefcasesEnabled=TRUE...done.
    Setting zimbraFeatureNotebookEnabled=TRUE...done.
    Setting MTA auth host...done.
    Setting TimeZone Preference...done.
    Creating domain server.um.edu.my...done.
    Creating user admin@server.um.edu.my...done.
    Creating postmaster alias...done.
    Creating user wiki@server.um.edu.my...done.
    Creating user spam.gk0eiu4g@server.um.edu.my...done.
    Creating user ham.rtnzvme80@server.um.edu.my...done.
    Setting spam training accounts...done.
    Initializing store sql database...done.
    Setting zimbraSmtpHostname for server.um.edu.my...done.
    Initializing logger sql database...done.
    Initializing mta config...done.
    Configuring SNMP...done.
    Setting services on server.um.edu.my...done.
    Setting up syslog.conf...done.

    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Suite.
    The only information that will be transmitted is:
    The VERSION of zcs installed (5.0.7_GA_2450_UBUNTU8)
    The ADMIN EMAIL ADDRESS created (admin@server.um.edu.my)

    Notify Zimbra of your installation? [Yes]
    Notifying Zimbra of installation via http://www.zimbra.com/cgi-bin/notify...rver.um.edu.my

    Notification complete

    Starting servers...done.
    Checking for deprecated zimlets...done.
    Installing zimlets...
    com_zimbra_phone
    com_zimbra_url
    com_zimbra_local
    com_zimbra_email
    com_zimbra_ymemoticons
    com_zimbra_date
    com_zimbra_cert_manager
    done.
    Initializing Documents...done.
    Restarting mailboxd...done.
    Setting up zimbra crontab...done.


    Moving /tmp/zmsetup.01001900-0000139009316.log to /opt/zimbra/log


    Configuration complete - press return to exit
    Thank...

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    What error(s) are you getting ? You need to provide details of the actual issue(s) please.

  3. #3
    fsloke is offline Loyal Member
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    6

    Default

    This is the MTA Cross click here to view the image...

    This image is print from the Administrator Console webpage

    You will know my problem after viewing it...

    Thank you

  4. #4
    y@w's Avatar
    y@w
    y@w is offline Moderator
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    That's a very general "MTA not running" indication. It could be a variety of things. Can we get an error message of some sort? A good place to started would be /var/log/zimbra.log

  5. #5
    fsloke is offline Loyal Member
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    6

    Default

    Quote Originally Posted by y@w View Post
    That's a very general "MTA not running" indication. It could be a variety of things. Can we get an error message of some sort? A good place to started would be /var/log/zimbra.log
    The log file in the var/log/zimbra.log is show as below...

    Jul 31 08:46:51 server amavis[8185]: starting. /opt/zimbra/amavisd/sbin/amavisd at server.um.edu.my amavisd-new-2.5.4 (20080312), Unicode aware, LANG="C"
    Jul 31 08:46:51 server amavis[8185]: user=1001, EUID: 1001 (1001); group=, EGID: 1001 1002 1001 5 4 (1001 1002 1001 5 4)
    Jul 31 08:46:51 server amavis[8185]: Perl version 5.008008
    Jul 31 08:46:53 server amavis[8185]: SpamControl: init_pre_chroot done
    Jul 31 08:46:53 server amavis[8202]: Net::Server: Process Backgrounded
    Jul 31 08:46:53 server amavis[8202]: Net::Server: 2008/07/31-08:46:53 Amavis (type Net::Server::PreForkSimple) starting! pid(8202)
    Jul 31 08:46:53 server amavis[8202]: Net::Server: Binding to UNIX socket file /opt/zimbra/data/amavisd/amavisd.sock using SOCK_STREAM
    Jul 31 08:46:53 server amavis[8202]: Net::Server: Binding to TCP port 10024 on host 127.0.0.1
    Jul 31 08:46:53 server amavis[8202]: Net::Server: Group Not Defined. Defaulting to EGID '1001 1002 1001 5 4'
    Jul 31 08:46:53 server amavis[8202]: Net::Server: User Not Defined. Defaulting to EUID '1001'
    Jul 31 08:46:53 server amavis[8202]: Module Amavis::Conf 2.094
    Jul 31 08:46:53 server amavis[8202]: Module Archive::Zip 1.23
    Jul 31 08:46:53 server amavis[8202]: Module Compress::Zlib 1.42
    Jul 31 08:46:53 server amavis[8202]: Module Convert::TNEF 0.17
    Jul 31 08:46:53 server amavis[8202]: Module Convert::UUlib 1.09
    Jul 31 08:46:53 server amavis[8202]: Module DBD::mysql 4.006
    Jul 31 08:46:53 server amavis[8202]: Module DBI 1.604
    Jul 31 08:46:53 server amavis[8202]: Module DB_File 1.817
    Jul 31 08:46:53 server amavis[8202]: Module Digest::MD5 2.36
    Jul 31 08:46:53 server amavis[8202]: Module Digest::SHA 5.47
    Jul 31 08:46:53 server amavis[8202]: Module Digest::SHA1 2.11
    Jul 31 08:46:53 server amavis[8202]: Module MIME::Entity 5.423
    Jul 31 08:46:53 server amavis[8202]: Module MIME::Parser 5.423
    Jul 31 08:46:53 server amavis[8202]: Module MIME::Tools 5.423
    Jul 31 08:46:53 server amavis[8202]: Module Mail::Header 2.03
    Jul 31 08:46:53 server amavis[8202]: Module Mail::Internet 2.03
    Jul 31 08:46:53 server amavis[8202]: Module Mail::SpamAssassin 3.002004
    Jul 31 08:46:53 server amavis[8202]: Module Net:NS 0.63
    Jul 31 08:46:53 server amavis[8202]: Module Net::LDAP 0.36
    Jul 31 08:46:53 server amavis[8202]: Module Net::Server 0.97
    Jul 31 08:46:53 server amavis[8202]: Module Time::HiRes 1.9715
    Jul 31 08:46:53 server amavis[8202]: Module URI 1.36
    Jul 31 08:46:53 server amavis[8202]: Module Unix::Syslog 1.0
    Jul 31 08:46:53 server amavis[8202]: Amavis:B code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: Amavis::Cache code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: SQL base code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: SQL::Log code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: SQL::Quarantine NOT loaded
    Jul 31 08:46:53 server amavis[8202]: Lookup::SQL code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: Lookup::LDAP code loaded
    Jul 31 08:46:53 server amavis[8202]: AM.PDP-in proto code loaded
    Jul 31 08:46:53 server amavis[8202]: SMTP-in proto code loaded
    Jul 31 08:46:53 server amavis[8202]: Courier proto code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: SMTP-out proto code loaded
    Jul 31 08:46:53 server amavis[8202]: Pipe-out proto code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: BSMTP-out proto code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: Local-out proto code loaded
    Jul 31 08:46:53 server amavis[8202]: OS_Fingerprint code NOT loaded
    Jul 31 08:46:53 server amavis[8202]: ANTI-VIRUS code loaded
    Jul 31 08:46:53 server amavis[8202]: ANTI-SPAM code loaded
    Jul 31 08:46:53 server amavis[8202]: ANTI-SPAM-SA code loaded
    Jul 31 08:46:53 server amavis[8202]: Unpackers code loaded
    Jul 31 08:46:53 server amavis[8202]: Found $file at /usr/bin/file
    Jul 31 08:46:53 server amavis[8202]: No $dspam, not using it
    Jul 31 08:46:53 server amavis[8202]: No $altermime, not using it
    Jul 31 08:46:53 server amavis[8202]: Internal decoder for .mail
    Jul 31 08:46:53 server amavis[8202]: Internal decoder for .asc
    Jul 31 08:46:53 server amavis[8202]: Internal decoder for .uue
    Jul 31 08:46:53 server amavis[8202]: Internal decoder for .hqx
    Jul 31 08:46:53 server amavis[8202]: Internal decoder for .ync
    Jul 31 08:46:53 server amavis[8202]: No decoder for .F tried: unfreeze, freeze -d, melt, fcat
    Jul 31 08:46:53 server amavis[8202]: Found decoder for .Z at /bin/uncompress
    Jul 31 08:46:53 server amavis[8202]: Found decoder for .gz at /bin/gzip -d
    Jul 31 08:46:53 server amavis[8202]: Found decoder for .bz2 at /bin/bzip2 -d
    Jul 31 08:46:53 server amavis[8202]: No decoder for .lzo tried: lzop -d
    Jul 31 08:46:53 server amavis[8202]: No decoder for .rpm tried: rpm2cpio.pl, rpm2cpio
    Jul 31 08:46:53 server amavis[8202]: Found decoder for .cpio at /bin/cpio
    Jul 31 08:46:53 server amavis[8202]: Found decoder for .tar at /bin/cpio
    Jul 31 08:46:53 server amavis[8202]: Found decoder for .deb at /usr/bin/ar
    Jul 31 08:46:53 server amavis[8202]: Internal decoder for .zip
    Jul 31 08:46:53 server amavis[8202]: No decoder for .7z tried: 7zr, 7za, 7z
    Jul 31 08:46:53 server amavis[8202]: No decoder for .rar tried: rar, unrar
    Jul 31 08:46:53 server amavis[8202]: No decoder for .arj tried: arj, unarj
    Jul 31 08:46:53 server amavis[8202]: No decoder for .arc tried: nomarch, arc
    Jul 31 08:46:53 server amavis[8202]: No decoder for .zoo tried: zoo, unzoo
    Jul 31 08:46:53 server amavis[8202]: No decoder for .lha tried: lha
    Jul 31 08:46:53 server amavis[8202]: No decoder for .cab tried: cabextract
    Jul 31 08:46:53 server amavis[8202]: No decoder for .tnef tried: tnef
    Jul 31 08:46:53 server amavis[8202]: Internal decoder for .tnef
    Jul 31 08:46:53 server amavis[8202]: No decoder for .exe tried: rar, unrar; lha; arj, unarj
    Jul 31 08:46:53 server amavis[8202]: Using primary internal av scanner code for ClamAV-clamd
    Jul 31 08:46:53 server amavis[8202]: SpamControl: initializing Mail::SpamAssassin
    Jul 31 08:46:55 server amavis[8202]: SpamControl: init_pre_fork done
    Jul 31 08:46:57 server zimbramon[6444]: 6444:info: Starting antivirus via zmcontrol
    Jul 31 08:46:58 server zimbramon[8233]: 8233:info: zmmtaconfig: zmmtaconfig already running at 7044
    Jul 31 08:46:58 server clamd[8280]: clamd daemon 0.93.1 (OS: linux-gnu, ARCH: i386, CPU: i686)
    Jul 31 08:46:58 server clamd[8280]: Log file size limited to 20971520 bytes.
    Jul 31 08:46:58 server clamd[8280]: Reading databases from /opt/zimbra/data/clamav/db
    Jul 31 08:46:58 server clamd[8280]: Not loading PUA signatures.
    Jul 31 08:47:07 server clamd[8280]: Loaded 378801 signatures.
    Jul 31 08:47:07 server clamd[8280]: TCP: Bound to port 3310
    Jul 31 08:47:07 server clamd[8280]: TCP: Setting connection queue length to 15
    Jul 31 08:47:07 server clamd[8307]: Limits: Global size limit set to 104857600 bytes.
    Jul 31 08:47:07 server clamd[8307]: Limits: File size limit set to 104857600 bytes.
    Jul 31 08:47:07 server clamd[8307]: Limits: Recursion level limit set to 16.
    Jul 31 08:47:07 server clamd[8307]: Limits: Files limit set to 10000.
    Jul 31 08:47:07 server clamd[8307]: Archive support enabled.
    Jul 31 08:47:07 server clamd[8307]: Archive: Blocking encrypted archives.
    Jul 31 08:47:07 server clamd[8307]: Algorithmic detection enabled.
    Jul 31 08:47:07 server clamd[8307]: Portable Executable support enabled.
    Jul 31 08:47:07 server clamd[8307]: ELF support enabled.
    Jul 31 08:47:07 server clamd[8307]: Mail files support enabled.
    Jul 31 08:47:07 server clamd[8307]: OLE2 support enabled.
    Jul 31 08:47:07 server clamd[8307]: PDF support disabled.
    Jul 31 08:47:07 server clamd[8307]: HTML support enabled.
    Jul 31 08:47:07 server clamd[8307]: Self checking every 1800 seconds.
    Jul 31 08:47:08 server zimbramon[6444]: 6444:info: Starting snmp via zmcontrol
    Jul 31 08:47:08 server zimbramon[6444]: 6444:info: Starting spell via zmcontrol
    Jul 31 08:47:09 server zimbramon[6444]: 6444:info: Starting mta via zmcontrol
    Jul 31 08:47:09 server zimbramon[8339]: 8339:info: zmmtaconfig: zmmtaconfig already running at 7044
    Jul 31 08:47:24 server postfix/postfix-script[8761]: warning: not owned by root: /opt/zimbra/postfix-2.4.7.5z/conf/main.cf
    Jul 31 08:47:24 server postfix/postfix-script[8775]: starting the Postfix mail system
    Jul 31 08:47:24 server postfix/master[8776]: fatal: bind 0.0.0.0 port 25: Address already in use
    Jul 31 08:47:24 server saslauthd[8788]: detach_tty : master pid is: 8788
    Jul 31 08:47:24 server saslauthd[8788]: ipc_init : listening on socket: /opt/zimbra/cyrus-sasl-2.1.22.3z/state/mux
    Jul 31 08:47:24 server zimbramon[6444]: 6444:info: Starting stats via zmcontrol
    Jul 31 08:47:35 server clamd[8307]: Reading databases from /opt/zimbra/data/clamav/db
    Jul 31 08:47:53 server zmmailboxdmgr[9457]: status requested
    Jul 31 08:47:53 server zmmailboxdmgr[9457]: status OK
    Jul 31 08:47:54 server zmmailboxdmgr[9514]: status requested
    Jul 31 08:47:54 server zmmailboxdmgr[9514]: status OK
    Jul 31 08:47:56 server clamd[8307]: Database correctly reloaded (378853 signatures)
    Jul 31 08:48:00 server postfix/postqueue[9547]: fatal: Queue report unavailable - mail system is down
    Jul 31 08:48:04 server zmmailboxdmgr[9701]: status requested
    Jul 31 08:48:04 server zmmailboxdmgr[9701]: status OK
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: antispam: Running
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: antivirus: Running
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: ldap: Running
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: logger: Running
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: mailbox: Running
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: mta: Stopped
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: saslauthd: is running with pid 8788
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: snmp: Running
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: spell: Running
    Jul 31 08:48:05 server zimbramon[9561]: 9561:info: 2008-07-31 08:48:01, STATUS: server.um.edu.my: stats: Running
    Jul 31 08:48:30 server postfix/postqueue[9794]: fatal: Queue report unavailable - mail system is down
    Jul 31 08:49:00 server postfix/postqueue[9907]: fatal: Queue report unavailable - mail system is down
    Jul 31 08:49:08 server zmmailboxdmgr[10206]: status requested
    Jul 31 08:49:08 server zmmailboxdmgr[10206]: status OK
    Jul 31 08:49:09 server zmmailboxdmgr[10282]: status requested
    Jul 31 08:49:09 server zmmailboxdmgr[10282]: status OK
    Jul 31 08:49:30 server postfix/postqueue[10468]: fatal: Queue report unavailable - mail system is down
    Jul 31 08:50:00 server postfix/postqueue[10507]: fatal: Queue report unavailable - mail system is down
    Jul 31 08:50:01 server postfix/postqueue[10542]: fatal: Queue report unavailable - mail system is down
    Jul 31 08:50:01 server zimbramon[10515]: 10515:info: 2008-07-31 08:50:01, QUEUE: 0 0
    Jul 31 08:50:03 server zimbramon[10524]: 10524:info: 2008-07-31 08:50:01, DISK: server.um.edu.my: dev: /dev/sda1, mp: /, tot: 72758, avail: 65282
    Jul 31 08:50:09 server zmmailboxdmgr[10805]: status requested
    Jul 31 08:50:09 server zmmailboxdmgr[10805]: status OK
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: antispam: Running
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: antivirus: Running
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: ldap: Running
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: logger: Running
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: mailbox: Running
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: mta: Stopped
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: saslauthd: is running with pid 8788
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: snmp: Running
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: spell: Running
    Jul 31 08:50:12 server zimbramon[10527]: 10527:info: 2008-07-31 08:50:01, STATUS: server.um.edu.my: stats: Running
    Jul 31 08:50:30 server postfix/postqueue[11098]: fatal: Queue report unavailable - mail system is down
    Jul 31 08:50:32 server zmmailboxdmgr[11200]: status requested
    Jul 31 08:50:32 server zmmailboxdmgr[11200]: status OK
    Jul 31 08:50:32 server zmmailboxdmgr[11256]: status requested
    Jul 31 08:50:32 server zmmailboxdmgr[11256]: status OK
    Any idea... Can you all give me some clue to fix this problem?

    Thank

  6. #6
    fsloke is offline Loyal Member
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    6

    Default

    I still remember... during my installation

    DNS ERROR resolving MX for server.um.edu.my
    It is suggested that the domain name have an MX record configured in DNS
    Change domain name? [Yes] No
    done.
    Checking for port conflicts
    Port conflict detected: 25 (zimbra-mta)
    Port conflicts detected! - Any key to continue


    Main menu
    It is cause by the conflicts port?

    But I already try to stop the SMTP using
    chkconfig sendmail off
    service sendmail stop
    But the result is as below
    server@server:~$ chkconfig sendmail off
    bash: chkconfig: command not found
    server@server:~$ service sendmail stop
    The program 'service' can be found in the following packages:
    * debian-helper-scripts
    * sysvconfig
    Try: sudo apt-get install
    bash: service: command not found
    server@server:~$ sudo chkconfig sendmail off
    [sudo] password for server:
    sudo: chkconfig: command not found
    server@server:~$ sudo service sendmail stop
    sudo: service: command not found
    I don't that the smtp is running or not?

    It this is the cause of MTA cross?

    Or another problem?

    Thank

  7. #7
    fsloke is offline Loyal Member
    Join Date
    Jul 2008
    Posts
    91
    Rep Power
    6

    Default

    Yes, is the conflict problem...

    I uninstall the existing ZImbra then re install back the zimbra...

    This time I disable the sendmail service and fetchmail service using the

    System>Administerator>Services

    Then the Cross MTA is disappear...

    Problem solved...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. zimbra daily reports problem - mta table is empty
    By sine in forum Administrators
    Replies: 4
    Last Post: 09-25-2008, 11:32 PM
  3. Statistics Graph Generation Failing
    By 3RiversTechAdmin in forum Administrators
    Replies: 10
    Last Post: 06-11-2008, 08:35 AM
  4. Stats problems!!
    By mmike in forum Administrators
    Replies: 7
    Last Post: 03-25-2008, 09:33 PM
  5. Server Stats Cont...
    By DMRDave in forum Administrators
    Replies: 15
    Last Post: 02-16-2006, 01:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •