Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: Fresh Installation (Continued)

  1. #1
    Amin Kardan's Avatar
    Amin Kardan is offline Senior Member
    Join Date
    Jul 2008
    Location
    Richmond Hill, Ontario, Canada
    Posts
    58
    Rep Power
    7

    Default Fresh Installation (Continued)

    Excuse me for creating another thread, but I can't seem to post in my first thread. UPDATE: Nevermind, I'm an idiot and just realized it takes some time for posts to show up.

    Thanks guys. I've taken a look at the documents that have been linked. So, right now I'm trying to figure out why I can't send mail. We've setup DNS through Free DNS, Static DNS, Dynamic DNS, URL Redirection, and more from EveryDNS! The thing is though, when going through the documentation you linked, I took a look at the /var/logs/zimbra.log and found the following error:

    Code:
    Jul 14 10:37:00 mail2 postfix/postqueue[30243]: fatal: Queue report unavailable - mail system is down
    root@zimbra:~# host -t mx mail2.pdadmin.com
    mail2.pdadmin.com has no MX record
    After, I checked to see if there was an MX record, and there wasn't. We've created an MX record on our DNS, which done through Free DNS, Static DNS, Dynamic DNS, URL Redirection, and more from EveryDNS! Now, I'm wondering if I'm suppose to make an MX record on the server side, or point to the MX record that is stored on our online DNS?

    When trying to send an email from one account to another, this pops up:

    Last edited by Amin Kardan; 07-14-2008 at 10:49 AM.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    If you're behind a NAT router then you need a Split DNS and a correct /etc/hosts file.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Amin Kardan's Avatar
    Amin Kardan is offline Senior Member
    Join Date
    Jul 2008
    Location
    Richmond Hill, Ontario, Canada
    Posts
    58
    Rep Power
    7

    Default

    @tarakranjanmukherjee - please, start your own thread.

    @phoenix - I followed your guide, but it seems that I don't have a named.conf under the /etc directory. Does this mean that DNS is not installed on the box? Or, is it under another name?


  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    It's probably not installed, have a look at this info for Ubuntu: Ubuntu 6.06 Server (Dapper Drake) Beginner's Install Guide - Zimbra :: Wiki - better suited to you than the RHEL one I gave you earlier.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Amin Kardan's Avatar
    Amin Kardan is offline Senior Member
    Join Date
    Jul 2008
    Location
    Richmond Hill, Ontario, Canada
    Posts
    58
    Rep Power
    7

    Default

    So, I went through the 2nd set of instructions and did all the steps. I'm still getting the error in the picture in my first post. This is a test enviroment I'm doing this in, so none of the information is sensitive. I configured everything to what I think is correct:

    Code:
    root@zimbra:/etc/bind# cat named.conf.options
    options {
            directory "/var/cache/bind";
    
            // If there is a firewall between you and nameservers you want
            // to talk to, you might need to uncomment the query-source
            // directive below.  Previous versions of BIND always asked
            // questions using port 53, but BIND 8.1 and later use an unprivileged
            // port by default.
    
            query-source address * port 53;
    
            // If your ISP provided one or more IP addresses for stable
            // nameservers, you probably want to use them as forwarders.
            // Uncomment the following block, and insert the addresses replacing
            // the all-0's placeholder.
    
            forwarders {
                    192.168.1.1;
            // };
    
            auth-nxdomain no;    # conform to RFC1035
    
    };
    
    root@zimbra:/etc/bind# cat /etc/resolv.conf
    search pdadmin.com
    nameserver 192.168.1.4
    nameserver 192.168.1.1
    root@zimbra:/etc/bind# cat /etc/bind/named.conf.local
    //
    // Do any local configuration here
    //
    zone "mail2.pdadmin.com"        {
            type master;
            file "/etc/bind/db.mail2.pdadmin.com";
    };
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    
    root@zimbra:/etc/bind# cat /etc/bind/db.mail2.pdadmin.com
    ;
    ; BIND data file for mail2.pdadmin.com
    ;
    $TTL    604800
    @       IN      SOA     mail2.pdadmin.com. admin@mail2.pdadmin.com. (
                            070615          ; Serial
                            604800          ; Refresh
                             86400          ; Retry
                           2419200          ; Expire
                            604800 )        ; Negative Cache TTL
    ;
    @       IN      NS      mail
            IN      MX      10 mail
            IN      A       192.168.1.4
    mail    IN      A       192.168.1.4
    root@zimbra:/etc/bind# cat /etc/hosts
    127.0.0.1       localhost
    192.168.1.2     zimbra.pdadmin.com      mail2.pdadmin.com       mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    root@zimbra:/etc/bind#
    This is my named.conf file, just adding this because maybe this might be the issue:
    Code:
    root@zimbra:/etc/bind# cat named.conf
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    
    include "/etc/bind/named.conf.options";
    
    // prime the server with knowledge of the root servers
    zone "." {
            type hint;
            file "/etc/bind/db.root";
    };
    
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    
    zone "localhost" {
            type master;
            file "/etc/bind/db.local";
    };
    
    zone "127.in-addr.arpa" {
            type master;
            file "/etc/bind/db.127";
    };
    
    zone "0.in-addr.arpa" {
            type master;
            file "/etc/bind/db.0";
    };
    
    zone "255.in-addr.arpa" {
            type master;
            file "/etc/bind/db.255";
    };
    
    // zone "com" { type delegation-only; };
    // zone "net" { type delegation-only; };
    
    // From the release notes:
    //  Because many of our users are uncomfortable receiving undelegated answers
    //  from root or top level domains, other than a few for whom that behaviour
    //  has been trusted and expected for quite some length of time, we have now
    //  introduced the "root-delegations-only" feature which applies delegation-only
    //  logic to all top level domains, and to the root domain.  An exception list
    //  should be specified, including "MUSEUM" and "DE", and any other top level
    //  domains from whom undelegated responses are expected and trusted.
    // root-delegation-only exclude { "DE"; "MUSEUM"; };
    
    include "/etc/bind/named.conf.local";
    Last edited by Amin Kardan; 07-15-2008 at 08:57 AM.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    In your /etc/hosts file you give the server IP as 192.168.1.2, in the A record you have it as 192.168.1.4 - one of those is incorrect.

    You can check the hosts file and DNS with the following commands run on the zimbra server:

    Code:
    host `hostname`  < type that command exactly and use backticks not single quotes
    dig pdadmin.com mx
    dig pdadmin.com any
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Amin Kardan's Avatar
    Amin Kardan is offline Senior Member
    Join Date
    Jul 2008
    Location
    Richmond Hill, Ontario, Canada
    Posts
    58
    Rep Power
    7

    Default

    Also, I found this:

    root@zimbra:/etc/bind# host -t mx mail2.pdadmin.com
    mail2.pdadmin.com has no MX record

    I ran your dig pdadmin.com mx command and this is what came up:

    Code:
    root@zimbra:/etc# dig pdadmin.com mx
    
    ; <<>> DiG 9.3.2-P2.1 <<>> pdadmin.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26878
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;pdadmin.com.                   IN      MX
    
    ;; ANSWER SECTION:
    pdadmin.com.            3407    IN      MX      1 mail.pdadmin.com.
    pdadmin.com.            3407    IN      MX      2 mail2.pdadmin.com.
    
    ;; ADDITIONAL SECTION:
    mail.pdadmin.com.       0       IN      A       192.168.1.27
    mail2.pdadmin.com.      1608    IN      A       216.249.3.126
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.4#53(192.168.1.4)
    ;; WHEN: Tue Jul 15 12:40:46 2008
    ;; MSG SIZE  rcvd: 104
    I've corrected the A record to 192.168.1.2.
    Last edited by Amin Kardan; 07-15-2008 at 09:46 AM.

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    It seems you have a couple of configuration problems. I missed these earlier in the hosts file:

    Code:
    127.0.0.1       localhost
    should read:
    cat /etc/hosts
    Code:
    127.0.0.1       localhost.localdomain localhost

    Code:
    192.168.1.2     zimbra.pdadmin.com      mail2.pdadmin.com       mail
    This is also incorrect, it should read:
    Code:
    192.168.1.2     zimbra.pdadmin.com    zimbra
    This would depend on the hostname of your zimbra server and modify your DNS records accordingly.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Amin Kardan's Avatar
    Amin Kardan is offline Senior Member
    Join Date
    Jul 2008
    Location
    Richmond Hill, Ontario, Canada
    Posts
    58
    Rep Power
    7

    Default

    Alright, I've changed that as well:
    Code:
    root@zimbra:/etc# cat /etc/hosts
    127.0.0.1       localhost.localdomain localhost
    192.168.1.2     zimbra.pdadmin.com      zimbra
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Since all that is completed now, what could be a few reasons I'm still receiving this error:

  10. #10
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Did you modify the DNS records? Just for confirmation, run all of these commands again:
    Code:
    host `hostname`  < type that command exactly and use backticks not single quotes
    dig pdadmin.com mx
    dig pdadmin.com any
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Fresh installation on Ubuntu 6.06
    By m477au in forum Installation
    Replies: 8
    Last Post: 07-07-2008, 05:12 PM
  2. error installation on fresh Ubuntu 606
    By pieter96 in forum Installation
    Replies: 14
    Last Post: 11-27-2007, 09:16 AM
  3. Replies: 16
    Last Post: 01-05-2006, 09:55 AM
  4. Problems with fresh open source installation
    By alohrer in forum Installation
    Replies: 4
    Last Post: 11-18-2005, 11:49 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •