Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Cannot access admin console after install on Suse 10x

  1. #11
    srf21c is offline Member
    Join Date
    Mar 2006
    Posts
    11
    Rep Power
    9

    Default stuck in cvs build process

    Quote Originally Posted by marcmac
    Look at that. You're running on a 64 bit machine - not supported by zimbra, unless you build from source.
    Alright, I'm trying to build Zimbra from source using the build_cvs_howto.txt document. Hitting a few snags between these blocks of steps:

    Code:
    cd ../amavisd
    wget http://www.ijs.si/software/amavisd/amavisd-new-2.3.3.tar.gz
    tar xzf amavisd-new-2.3.3.tar.gz
    cd amavisd-new-2.3.3
    patch -p0 < ../amavisd.2.3.3.patch
    
    mkdir ../snmp
    get net-snmp-5.1.2.tar.gz
    tar xzf net-snmp-5.1.2.tar.gz
    cd net-snmp-5.1.2
    ./configure --prefix=/opt/zimbra/snmp-5.1.2
    mkdir ../snmp
    get net-snmp-5.1.2.tar.gz
    tar xzf net-snmp-5.1.2.tar.gz
    cd net-snmp-5.1.2
    ./configure --prefix=/opt/zimbra/snmp-5.1.2
    make
    First of all, what should the absolute path of the newly create "snmp" directory be? Because if you follow the cvs_build doc verbatim, it would be
    /root/main/ThirdParty/amavisd/snmp

    My hunch is that the command
    Code:
    mkdir ../snmp
    should really read
    Code:
    mkdir ../../snmp
    thus putting the new snmp directory in the same dir as the rest of the thirdparty add-ons dirs created as prescribed by the cvs_build doc.

    Secondly, the current release of net-snmp is 5.3 Wanted to verify that the older 5.1.2 release should be used.

  2. #12
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    THere should be a
    cd ../snmp
    after the mkdir

    You can use 5.3, but you'll have to find all the references to the directory and update them

  3. #13
    srf21c is offline Member
    Join Date
    Mar 2006
    Posts
    11
    Rep Power
    9

    Default

    ok, on top of that the link given to download ClamAV is bunk. That could use some updating too.

    how about: wget http://easynews.dl.sourceforge.net/s...-0.85.1.tar.gz

    Also, I'm a little confused about how to format this command for my environment. I'm running 64-bit SUSE 10x

    mkdir $(BUILD_PLATFORM) (RHEL4, FC3, FC4, MACOSX, SuSEES9, DEBIAN3.1)
    cd $(BUILD_PLATFORM)
    Last edited by srf21c; 03-06-2006 at 05:56 PM.

  4. #14
    srf21c is offline Member
    Join Date
    Mar 2006
    Posts
    11
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    THere should be a
    cd ../snmp
    after the mkdir

    You can use 5.3, but you'll have to find all the references to the directory and update them
    Regarding the creation of the snmp folder, if you leave the mkdir command as is from the build_cvs_howto doc, that's going to create the directory at an absolute path of: /root/main/ThirdParty/amavisd/snmp

    Are you sure that's correct??

    That's because the current dir when the
    Code:
    mkdir ../snmp
    command is issued would be /root/main/ThirdParty/amavisd/amavisd-new-2.3.3

    Here's a copy paste of the relevant section of the build_cvs_howto.txt doc for reference.

    Code:
    cd ../amavisd
    wget http://www.ijs.si/software/amavisd/amavisd-new-2.3.3.tar.gz
    tar xzf amavisd-new-2.3.3.tar.gz
    cd amavisd-new-2.3.3
    patch -p0 < ../amavisd.2.3.3.patch
    
    mkdir ../snmp

  5. #15
    srf21c is offline Member
    Join Date
    Mar 2006
    Posts
    11
    Rep Power
    9

    Default another problem in build_cvs_howto

    Yet another problem...Crikey Moses!! Does anyone proofread these docs before commiting to CVS? n00bs are going to have a difficult time trying to get through an error-riddled set of instructions like these, espcially if they are copy-pasting the comands.

    There is a capitalization typo for the command

    Code:
    cd ../PostFix/Postfix-2.2.3
    The second postfix word should have the f capitalized so that it reads like this
    Code:
    cd ../PostFix/PostFix-2.2.3/
    Also I believe that this string is missing the following command in order for it to work properly.

    Code:
    patch -p0 < ../patch.4.2.52.1
    patch -p0 < ../patch.4.2.52.2
    patch -p0 < ../patch.4.2.52.3
    patch -p0 < ../patch.4.2.52.4
    patch -p0 < ../BerkeleyDB42.patch
    cd ..
    mv db-4.2.52 db-4.2.52.4
    tar czf db-4.2.52.4.tar.gz db-4.2.52.4
    Last edited by srf21c; 03-06-2006 at 05:30 PM.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Silly mistake -- now cant log into admin console
    By animasana in forum Administrators
    Replies: 10
    Last Post: 07-05-2007, 04:00 AM
  2. Install on (64bit !) SUSE Linux Entreprise Server 10
    By fillide in forum Installation
    Replies: 1
    Last Post: 07-04-2007, 09:06 AM
  3. Can't Access to Admin Console
    By GameSky in forum Installation
    Replies: 32
    Last Post: 05-26-2007, 12:25 AM
  4. Access to admin only after rebooting
    By josus in forum Administrators
    Replies: 0
    Last Post: 11-03-2006, 02:06 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •