Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Zimbra 3 on FC4 having problems with zimbraMailPort and SOAP service

  1. #21
    jayda is offline Starter Member
    Join Date
    Apr 2006
    Posts
    1
    Rep Power
    8

    Default Found a workaround

    I was receiving the same problem trying to use mod_jk with https except, instead of port 80 I was getting port 443.....

    I noticed that the web.xml found at /opt/zimbra/tomcat/webapps/service/WEB-INF has values for "allowed.ports". These settings all had my two server ports, 7080, and 7443. I tried modifying the Soap entry by adding the port 443 to no aval untill I realized that this file is getting overwritten each time tomcat is started. I tracked that down to a function in /opt/zimbra/bin/tomcat called rewriteWebXml which calls the command /opt/zimbra/libexec/zmmtaconfig with the option webxml. There are two such lines in the tomcat startup script. I commented the one that rewrites the web.xml files, then added the port 443 to the web.xml file mentioned above, restarted tomcat, and tada.... It worked. I have not delved any more deeply to determine where these settings are comming from or what can be done further about it, but it does appear to be working now. I'm sure this will break something else if I ever change something and actually need the files to be rewritten......

    Kind of long winded, but hopefully this is helpful....

  2. #22
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by jayda
    I was receiving the same problem trying to use mod_jk with https except, instead of port 80 I was getting port 443.....

    I noticed that the web.xml found at /opt/zimbra/tomcat/webapps/service/WEB-INF has values for "allowed.ports". These settings all had my two server ports, 7080, and 7443. I tried modifying the Soap entry by adding the port 443 to no aval untill I realized that this file is getting overwritten each time tomcat is started. I tracked that down to a function in /opt/zimbra/bin/tomcat called rewriteWebXml which calls the command /opt/zimbra/libexec/zmmtaconfig with the option webxml. There are two such lines in the tomcat startup script. I commented the one that rewrites the web.xml files, then added the port 443 to the web.xml file mentioned above, restarted tomcat, and tada.... It worked. I have not delved any more deeply to determine where these settings are comming from or what can be done further about it, but it does appear to be working now. I'm sure this will break something else if I ever change something and actually need the files to be rewritten......

    Kind of long winded, but hopefully this is helpful....
    Thanks jayda,

    This helped me to find another workaround:

    Edit: /opt/zimbra/apache-tomcat-5.5.15/webapps/service/WEB-INF/web.xml and /opt/zimbra/apache-tomcat-5.5.15/conf/service.web.xml.in and add ports 80 and 443 mentioned in all instances where code such as following appears:

    HTML Code:
    <init-param>
          <param-name>allowed.ports</param-name>
          <param-value>80, 443, 6080, 6443, 7070, 7443, 7071</param-value>
    </init-param>
    Here's the how-to: http://wiki.zimbra.com/index.php?tit...e_using_mod_jk

    Sincerely,

    Chintan Zaveri.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •