Results 1 to 3 of 3

Thread: [SOLVED] external authentication not working

  1. #1
    veronica is offline Outstanding Member
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default [SOLVED] external authentication not working

    Hi,

    I am trying to authenticate externally. The details of my external auth setting are attached below. I can test one user authentication as is asked to me to test in admin console "configure authentication" window. Also i am able to do a ldap search from zimbra to my legacy system.The only issue is when i create a user in zimbra which already exist in my legacy LDAP, i dont get authenticated and gives me following error: -

    com.zimbra.common.service.ServiceException: system failure: Missing 'equals'
    ExceptionId:btpool0-8:1213890071022:31cb0c9ad92eec8d
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:253)
    at com.zimbra.cs.account.ldap.LdapProvisioning.extern alLdapAuth(LdapProvisioning.java:2806)
    at com.zimbra.cs.account.auth.AuthMechanism$LdapAuth. doAuth(AuthMechanism.java:163)
    at com.zimbra.cs.account.ldap.LdapProvisioning.verify PasswordInternal(LdapProvisioning.java:2856)
    at com.zimbra.cs.account.ldap.LdapProvisioning.verify Password(LdapProvisioning.java:2825)
    at com.zimbra.cs.account.ldap.LdapProvisioning.authAc count(LdapProvisioning.java:2698)
    at com.zimbra.cs.account.ldap.LdapProvisioning.authAc count(LdapProvisioning.java:2677)
    at com.zimbra.cs.service.account.Auth.handle(Auth.jav a:120)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:410)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:267)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:159)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:266)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:189)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1093)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:148)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1084)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:360)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:716)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:406)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:350)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:844)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:211)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)
    Caused by: javax.naming.directory.InvalidSearchFilterExceptio n: Missing 'equals'; remaining name 'cn=users,dc=kuniv,dc=edu,dc=kw'
    at com.sun.jndi.ldap.Filter.encodeSimpleFilter(Filter .java:305)
    at com.sun.jndi.ldap.Filter.encodeFilter(Filter.java: 151)
    at com.sun.jndi.ldap.Filter.encodeFilterString(Filter .java:55)
    at com.sun.jndi.ldap.LdapClient.search(LdapClient.jav a:520)
    at com.sun.jndi.ldap.LdapCtx.doSearch(LdapCtx.java:19 44)
    at com.sun.jndi.ldap.LdapCtx.searchAux(LdapCtx.java:1 806)
    at com.sun.jndi.ldap.LdapCtx.c_search(LdapCtx.java:17 31)
    at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_sea rch(ComponentDirContext.java:368)
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex t.search(PartialCompositeDirContext.java:338)
    at javax.naming.directory.InitialDirContext.search(In itialDirContext.java:257)
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.searc hDir(ZimbraLdapContext.java:504)
    at com.zimbra.cs.account.ldap.LdapUtil.ldapAuthentica te(LdapUtil.java:132)
    at com.zimbra.cs.account.ldap.LdapProvisioning.extern alLdapAuth(LdapProvisioning.java:2789)
    ... 36 more

    Can anyone help me in knowing what can be the issue ?
    Attached Images Attached Images

  2. #2
    p24t is offline Moderator
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    Welcome to the forums.

    For your LDAP filter, I see you only have '%u'. I don't know your naming schema, but normally for the filter you use something like 'uid=%u' or 'cn=%u', depending on how you have them named. You may try changing that. (just guessing from the "missing equals" bit)

  3. #3
    veronica is offline Outstanding Member
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    Hi,

    Thanks this works fine.. i was missing 'uid=%u' ..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. External auth / order of authentication process
    By joukom in forum Administrators
    Replies: 3
    Last Post: 05-18-2008, 12:55 AM
  3. External LDAP authentication problem
    By mchamboredon in forum Installation
    Replies: 2
    Last Post: 01-16-2008, 10:02 AM
  4. External Authentication with Active Directory via LDAPS
    By merrill in forum Administrators
    Replies: 1
    Last Post: 10-21-2007, 01:13 PM
  5. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 03:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •