Results 1 to 2 of 2

Thread: zmtlsctl and jetty.xml permission error

  1. #1
    BarefootPanda's Avatar
    BarefootPanda is offline Special Member
    Join Date
    Jun 2008
    Location
    Minneapolis, MN
    Posts
    112
    Rep Power
    6

    Default zmtlsctl and jetty.xml permission error

    I'm trying to change my login to mixed or redirect and I'm having a terrible time on my OS X 10.4.11 install.

    The code changes every time I run the command with the jetty.xml part, but the error looks like...

    Code:
    Updating /opt/zimbra/mailboxd/etc/jetty.xml.in.../opt/zimbra/bin/zmtlsctl: line 303: /opt/zimbra/mailboxd/etc/jetty.xml.in.UE7WjA: Permission denied
    failed.
    Any ideas? I've tried starting and stopping services and all kinds of other stuff like repairing permissions with zmfixperm. Ideally people stay over https, but if I can at least get logins to be https I'd be happy. Thanks guys.
    Last edited by BarefootPanda; 06-19-2008 at 05:15 PM.

  2. #2
    king0770's Avatar
    king0770 is offline Zimbra Employee
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    7

    Default Bug

    It's bug Bug 28405 – permissions wrong on jetty.xml.in and saslauthd.conf.in on macosx

    Make sure the following files have the correct permissions in order zmtlsctl to work.

    chmod 640 /opt/zimbra/jetty/etc/jetty.xml.in

    chmod 600 /opt/zimbra/cyrus-sasl/etc/saslauthd.conf.in

    And are owned by zimbra.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •