Results 1 to 3 of 3

Thread: Installation on Debian Lenny

  1. #1
    abel76 is offline Junior Member
    Join Date
    Jun 2008
    Posts
    7
    Rep Power
    6

    Default Installation on Debian Lenny

    How to install Zimbra 5.0.6 GA Release, on a Debian Lenny?

    I tried but there were many errors.
    First the installer told me: "Error: attempting to install i386 packages on a unknown OS"

    so I changed the /etc/debian_version from lenny/sid to 4.0

    This error never represented, but now I have this warning:

    perl-5.8.8...Unable to find expected perl-5.8.8. Found version 5.10.0-10 instead

    and during the installation, this error:

    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Tstack_sp_ptr

    There is a way to configure Zimbra in lenny? The previous version of Zimbra (4.5) works with lenny?
    Thanks in advance for your reply

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    Highly unlikely it will work, given the major upgrades in lenny. 4.5 certainly wouldn't work. Use an existing stable version of debian/ubuntu, or roll your own from source.

  3. #3
    alvarod is offline Starter Member
    Join Date
    Feb 2008
    Posts
    1
    Rep Power
    7

    Default about zimbra on debian lenny

    Hi dijichi2,

    Here is some hints about the install on debian lenny. Please notice that to install Zimbra and get it working you should have a DNS system, that could be at the same host as Zimbra. Also, you probably will have some Bind9 issues, c'ause you have to downgrade Perl and it requires a new version of Perl in order to get running.

    Instead of just change the "debian_version" from 5 to 4, you should perform a Perl downgrade:

    vim /etc/debian_version

    wget http://ftp.at.debian.org/debian/pool...7etch6_all.deb
    wget http://ftp.at.debian.org/debian/pool...etch6_i386.deb
    wget http://ftp.at.debian.org/debian/pool...etch6_i386.deb
    wget http://ftp.at.debian.org/debian/pool...etch6_i386.deb
    wget http://ftp.at.debian.org/debian/pool....20-8_i386.deb
    wget http://ftp.at.debian.org/debian/pool....19-1_i386.deb
    wget http://ftp.at.debian.org/debian/pool....30-3_i386.deb
    wget http://ftp.at.debian.org/debian/pool....05-1_i386.deb
    wget http://ftp.at.debian.org/debian/pool...1.4-3_i386.deb
    wget http://ftp.at.debian.org/debian/pool....04-4_i386.deb
    wget http://ftp.at.debian.org/debian/pool....30-1_i386.deb
    wget http://ftp.at.debian.org/debian/pool....07-1_i386.deb


    dpkg -i perl-modules_5.8.8-7etch6_all.deb perl-base_5.8.8-7etch6_i386.deb
    perl_5.8.8-7etch6_i386.deb libperl5.8_5.8.8-7etch6_i386.deb
    libdb4.4_4.4.20-8_i386.deb libsocket6-perl_0.19-1_i386.deb
    libterm-readkey-perl_2.30-3_i386.deb liblocale-gettext-perl_1.05-1_i386.deb
    libtext-iconv-perl_1.4-3_i386.deb libtext-charwidth-perl_0.04-4_i386.deb
    libnet-ssleay-perl_1.30-1_i386.deb libnet-libidn-perl_0.07-1_i386.deb

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Busted Debian installation causing problems
    By Dirk in forum Administrators
    Replies: 6
    Last Post: 12-08-2007, 07:59 AM
  2. Installation problem on Debian 4.0
    By gaijin in forum Installation
    Replies: 2
    Last Post: 05-23-2007, 11:23 AM
  3. Zimbra installation fails (Debian)
    By info in forum Installation
    Replies: 5
    Last Post: 01-01-2007, 04:12 AM
  4. Installation on debian
    By jordg in forum Installation
    Replies: 4
    Last Post: 08-28-2006, 04:05 PM
  5. Replies: 1
    Last Post: 02-17-2006, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •