Results 1 to 4 of 4

Thread: Failure after upgrade from M3 to 3.0.1GA

  1. #1
    bsb
    bsb is offline Member
    Join Date
    Feb 2006
    Posts
    14
    Rep Power
    9

    Default Failure after upgrade from M3 to 3.0.1GA

    Today, I tried an upgrade from the M3 beta to the latest GA release (on OS X 10.4).

    After a couple aborted attempts at re-running zmsetup.pl post-upgrade (the service stop was failing) I was able to get everything ready to go. However, now when I try to start the services (zmcontrol start) I get:

    Host mail.buddemeyer.net
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting logger...Done.
    Starting mailbox...FAILED
    getService: sasl
    getService: webxml
    getService: perdition
    Error: assertion '-x /opt/zimbra/mysql/bin/mysqld_safe' failed


    Starting mta...Done.
    Starting snmp...Done.
    Starting spell...Done.

    Any ideas where I can look to get the system back up and running would be greatly appreciated!

  2. #2
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    That's no good.

    Does the file /opt/zimbra/mysql/bin/mysqld_safe exist?

    If so, is it executable?

    If not, chmod a+x /opt/zimbra/mysql/bin/mysqld_safe

    Also, make sure that /opt/zimbra/mysql (which is a symlink) is pointing at the correct directory (mysql-apple-etc-etc-etc-powerpc)

  3. #3
    bsb
    bsb is offline Member
    Join Date
    Feb 2006
    Posts
    14
    Rep Power
    9

    Default

    /opt/zimbra/mysql/bin apparantly no longer exists. If I cd into /opt/zimbra/mysql, the only sub under there is lib

    definitely not good. any suggestions?

  4. #4
    bsb
    bsb is offline Member
    Join Date
    Feb 2006
    Posts
    14
    Rep Power
    9

    Default I'm back...

    Marc,

    Thanks for the pointer. After doing a little more digging, I found that mysql was apparantly upgraded in this install. Though a lot was apparantly removed from the old version's folder, the symlink wasn't moved to the new version's. I re-linked it and came right back.

    Thank you again for the great product and fast response!

    Brian

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  2. Zimbra 4.04 GA FC4 - Upgrade Failure
    By RJerrom in forum Installation
    Replies: 3
    Last Post: 12-08-2006, 12:10 PM
  3. Suse9 3.1.2 upgrade failure
    By DMRDave in forum Installation
    Replies: 10
    Last Post: 06-21-2006, 09:54 AM
  4. Yet another get.DirectContext issue
    By dccpark in forum Installation
    Replies: 5
    Last Post: 03-08-2006, 01:25 PM
  5. system failure: getDirectContext
    By avisser in forum Installation
    Replies: 3
    Last Post: 10-12-2005, 05:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •