Results 1 to 4 of 4

Thread: Upgrade 5.0.4 to 5.0.6 and Documents Error

  1. #1
    peter76 is offline Active Member
    Join Date
    Apr 2008
    Posts
    30
    Rep Power
    7

    Default Upgrade 5.0.4 to 5.0.6 and Documents Error

    I upgraded from 5.0.4 to 5.0.6. After the upgrade, when I click on the documents tab, this is an excerpt of what I get. What can I do to get this data back?

    HTTP ERROR: 500

    INTERNAL_SERVER_ERROR

    RequestURI=/service/home/peter/Notebook
    Caused by:

    java.lang.NullPointerException
    at com.zimbra.cs.wiki.Wiki.getChrome(Wiki.java:485)
    at com.zimbra.cs.wiki.Wiki.getChromeTemplate(Wiki.jav a:689)
    at com.zimbra.cs.wiki.Wiki.getTemplate(Wiki.java:680)
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(WikiFormatter.java:127)
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(WikiFormatter.java:113)
    at com.zimbra.cs.service.formatter.WikiFormatter.hand leWikiFolder(WikiFormatter.java:143)
    at com.zimbra.cs.service.formatter.WikiFormatter.form atCallback(WikiFormatter.java:230)
    at com.zimbra.cs.service.formatter.Formatter.format(F ormatter.java:83)
    at com.zimbra.cs.service.UserServlet.doAuthGet(UserSe rvlet.java:444)
    at com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:350)

  2. #2
    oliver2uk is offline Senior Member
    Join Date
    Nov 2007
    Posts
    53
    Rep Power
    7

    Default

    Hi Peter,

    I am experiencing very simillar issue. First time when I click on the documents, I can see the list, but I am not able to see any notebooks.

    When I go out from the documents, I am not able to get in by clicking on the Documents link again.

    Anybody help?

    Many thanks.

    Oliver
    Oliver's personal blog

  3. #3
    dennydgl1 is offline Junior Member
    Join Date
    Oct 2007
    Posts
    6
    Rep Power
    7

    Default Same behaviour in Zimbra 5.0.7 GA clicking document tab

    Hi all,
    I'm experiencig the same error with Zimbra 5.0.7 GA deployed from scratch (not any migration occured). If I click on the Documents tab the following error (and stack trace) appears.
    Have anyone found the root cause and, even better, developed an hotfix?

    Best regards,
    Denis Maggiorotto

    HTTP ERROR: 500

    INTERNAL_SERVER_ERROR

    RequestURI=/service/home/denis.maggiorotto@sunnyvale.dynalias.net/Notebook
    Caused by:

    java.lang.NullPointerException
    at com.zimbra.cs.wiki.Wiki.getChrome(Wiki.java:490)
    at com.zimbra.cs.wiki.Wiki.getChromeTemplate(Wiki.jav a:694)
    at com.zimbra.cs.wiki.Wiki.getTemplate(Wiki.java:685)
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(WikiFormatter.java:127)
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(WikiFormatter.java:113)
    at com.zimbra.cs.service.formatter.WikiFormatter.hand leWikiFolder(WikiFormatter.java:143)
    at com.zimbra.cs.service.formatter.WikiFormatter.form atCallback(WikiFormatter.java:230)
    at com.zimbra.cs.service.formatter.Formatter.format(F ormatter.java:83)
    at com.zimbra.cs.service.UserServlet.doAuthGet(UserSe rvlet.java:435)
    at com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:347)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:707)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:188)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1093)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1084)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:360)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:716)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:406)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:350)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.he aderComplete(HttpConnection.java:830)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:514)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:205)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)

    Powered by Jetty://

  4. #4
    dennydgl1 is offline Junior Member
    Join Date
    Oct 2007
    Posts
    6
    Rep Power
    7

    Default Documents tab working

    Hi,
    finally I found a way to make documents tab work properly.
    After Zimbra installation and Zimbra user creation, typing the following command zimbra will initialize Documents for a specific user:

    /opt/zimbra/bin/zmprov in name.surname@domain.com

    where in stands for initialize and name.surname@domain.com is the user login followed by user domain.

    Hope this helps who will face my problem in the future.
    Regards,

    Denis Maggiorotto

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade to Zimbra 5: documents not working
    By jooray in forum Administrators
    Replies: 0
    Last Post: 01-21-2008, 09:43 PM
  2. Documents tab gives "HTTP ERROR: 500"
    By dowdle in forum Administrators
    Replies: 2
    Last Post: 01-02-2008, 05:59 PM
  3. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  5. 4.0 RC1 Documents initialization failed on upgrade
    By neilmc in forum Administrators
    Replies: 13
    Last Post: 10-05-2006, 02:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •