Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 53

Thread: Fresh Install Of Zimbra On SuSE 10

  1. #21
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    dns isn't controlled by the hosts file - DNS comes from your dns server, both A records and MX records (which is what we're trying to verify).

    I thought in one of your earlier posts, you said you had a DNS server running?

    What do you get from:
    host mail.freeos.co.uk
    host -t mx mail.freeos.co.uk

  2. #22
    yogiman is offline Senior Member
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    Hi

    Yes I do have DNS running on the same box.

    I just received an odd return mail from yahoo daemon which said it could not contact:

    admin@mail.freeos.co.uk

    should this not be admin@freeos.co.uk

    The answer to your question is:

    host mail.freeos.co.uk

    Gives: mail.freeos.co.uk has address (external address here)


    host -t mx mail.freeos.co.uk

    Gives: Nothing (just returns to the next line)


  3. #23
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    What domain are you planning on hosting mail for? That's the domain you want to create in zimbra. The hostname doesn't really matter, as long as it's resolvable.

    Once you've chosen a domain, set up an MX record pointing to the IP address of the host that's handling mail for that domain.

  4. #24
    yogiman is offline Senior Member
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    Sorry but I was under the impression that mx and a records were setup at who ever forward mail/web requests to me in my case zoneedit.com

    If not can you tell me where I set these up?

    Thank you for your continued help!

  5. #25
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    No, I can't tell you where to set them up, since I'm not running your DNS - but if you know who is, you need to contact them.

  6. #26
    yogiman is offline Senior Member
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    My A and MX record which I believe is what point people or mail to me is already setup at zoneedit.

    I these are the people you mean then it is done.

    If this is not what you mean then please explain. I have not had to do this on previous mail server installations so why this one?

    If I take the zimbra server offline and put my other mail server online mail works inbound and outbound

  7. #27
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    host mail.freeos.co.uk
    mail.freeos.co.uk has address 81.153.186.1

    host -x mx mail.freeos.co.uk
    no response

    Your DNS is not completely set up, since there's no MX record for your domain.

  8. #28
    yogiman is offline Senior Member
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    host mail.freeos.co.uk
    mail.freeos.co.uk has address 81.153.186.1

    host -x mx mail.freeos.co.uk
    no response

    Your DNS is not completely set up, since there's no MX record for your domain.
    Marcmac

    the domain is freeos.co.uk
    the zimbra server is called mail
    if I goto dnstuff and to an mxrecord check on freeos.co.uk it is fine.

    Why are you checking mail.freeos.co.uk

    command:

    host mail.freeos.co.uk returns my external address
    host -t mx freeos.co.uk returns:

    freeos.co.uk is handled by 0 mail.freeos.co.uk

    So mx records exist for my domain

    they would not exist for mail.freeos.co.uk because mail is the server name not the domain name the domain name is freeos.co.uk

    Does this help?

  9. #29
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    Ok, then you're fine.

    When you install, and it says "no mx for domain whatever" change it to the domain you want to route mail for.

  10. #30
    yogiman is offline Senior Member
    Join Date
    Feb 2006
    Posts
    59
    Rep Power
    9

    Default

    This is the problem

    the zimbra installer thinks my domain is called mail.freeos.co.uk when actually my domain is called freeos.co.uk the machine that zimbra is install on is called mail.

    The hostname files says

    mail.freeos.co.uk

    the hosts files says

    address mail.freeos.co.uk mail

    so where is the zimbra installer getting the domain mail.freeos.co.uk and not freeos.co.uk

    Is there an error in the installer or on my system, if its on my system where does it look for this information?

Page 3 of 6 FirstFirst 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 06:29 PM
  2. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 12:11 PM
  3. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 11:59 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  5. Logger
    By jholder in forum Installation
    Replies: 24
    Last Post: 03-31-2006, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •