Results 1 to 8 of 8

Thread: [SOLVED] IMAP/SSL,Plain Login

  1. #1
    jon.langland is offline New Member
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Default [SOLVED] IMAP/SSL,Plain Login

    Hello -

    I recently upgraded from version 5.0.2 to version 5.0.5.

    After doing this all of my Thunderbird IMAP connections that were not set to TLS were unable to connect to receive mail.

    Changing those to accept TLS was easy. It makes sense as this will connect to the server securely.

    However, we have a Windows Mobile device that was using a clear text/plain login through imap. No matter what I set for the Global or Server settings (SSL on/off, clear text enabled or not with restarting the server between each setting) it will not accept the imap in clear text.

    If I telnet to the imap proxy port 143 it says LOGINDISABLED (plus some other stuff). When I telnet to imap port 7143 it gives me the option for AUTH=PLAIN plus a number of other options (a lot more than 143).

    My current settings are, under the GUI server tab, are set to: Enable IMAP service [checked], Enable SSL for IMAP service [checked] <-- (tried both on and off) and Enable clear text login [checked].

    I also tried typing in zmprov ms mail.domainname.com zimbraImapCleartextLoginEnabled TRUE... which didn't work

    I must be missing something, but can't seem to find it - any help would be appreciated.

    BTW - I have tried to change the port for the Windows Mobile device to 7143 but I can't seem to get to function correctly so that is why I am back to working on the imap port 143.

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Welcome to the forums,
    Could you post the output of:
    zmprov gs server.domain.com | grep Imap

  3. #3
    jon.langland is offline New Member
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Default

    Sorry about that...

    root@mail:~# su - zimbra
    zimbra@mail:~$ zmprov gs server.domain.com |grep Imap
    zimbraImapBindOnStartup: TRUE
    zimbraImapBindPort: 7143
    zimbraImapCleartextLoginEnabled: TRUE
    zimbraImapNumThreads: 200
    zimbraImapProxyBindPort: 143
    zimbraImapSSLBindOnStartup: TRUE
    zimbraImapSSLBindPort: 7993
    zimbraImapSSLProxyBindPort: 993
    zimbraImapSSLServerEnabled: TRUE
    zimbraImapSaslGssapiEnabled: FALSE
    zimbraImapServerEnabled: TRUE
    zimbraReverseProxyImapSaslGssapiEnabled: FALSE
    zimbraReverseProxyImapStartTlsMode: only
    Last edited by jon.langland; 05-05-2008 at 05:01 PM. Reason: Removed domain from server listing

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    If this is a single server install (& therefore shouldn't be running imap/pop proxy) run the following all on one line:
    zmprov -l ms server.domain.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    Your putting a 7 in front of anything with proxy in it & correcting the ports (lowercase ell L at the front provisions via ldap).
    Then:
    zmcontrol stop
    zmcontrol start

  5. #5
    jon.langland is offline New Member
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Default

    mmorse -

    Thank you for helping on this! Would you suspect there could be something in my configuration to cause this to happen, or something I missed during the upgrade? I am just looking to make sure it isn't/wasn't something in my config that caused this to happen...

    I was curious on the proxy information... but didn't want to change them because I did not remember intentionally setting them in either the GUI or command line.

    Thanks again!
    Last edited by jon.langland; 05-05-2008 at 06:57 PM.

  6. #6
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    All working now? (Don't forget to change the ports back to 143 or 993 on your thick-clients.)
    I doubt it's anything you did, I seem to remember a bug somewhere - what was your global config set to? (zmprov gacf | grep Imap) Once you set server it overrides global anyways so it's a moot point, but just curious.

  7. #7
    jon.langland is offline New Member
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Default

    It is all working yes... For what it is worth - in Thunderbird I only had to change the Security Settings section of the Server Settings from "Never" to "TLS if available" (which I had thought I was selcecting when I setup the machines, but obviously not) and did not have to change port settings. The rest are either web clients or Outlook. The only reason it really became an issue was because of our Windows Mobile phone (the Blackberry's worked fine with their BIS package)

    I ran the command you gave to list the global settings and it is showing this:

    zimbra@mail:~$ zmprov gacf | grep Imap
    zimbraImapBindOnStartup: TRUE
    zimbraImapBindPort: 7143
    zimbraImapCleartextLoginEnabled: TRUE
    zimbraImapNumThreads: 200
    zimbraImapProxyBindPort: 143
    zimbraImapSSLBindOnStartup: TRUE
    zimbraImapSSLBindPort: 7993
    zimbraImapSSLProxyBindPort: 993
    zimbraImapSSLServerEnabled: TRUE
    zimbraImapSaslGssapiEnabled: FALSE
    zimbraImapServerEnabled: TRUE
    zimbraReverseProxyImapPortAttribute: zimbraImapBindPort
    zimbraReverseProxyImapSSLPortAttribute: zimbraImapSSLBindPort
    zimbraReverseProxyImapSaslGssapiEnabled: FALSE
    zimbraReverseProxyImapStartTlsMode: only
    zimbraReverseProxySendImapId: TRUE

    I see that I need to change those also - I will do that.

    Thanks again for your help - I still don't have the hang of all the zmprov options.

  8. #8
    holbor is offline Member
    Join Date
    Jan 2008
    Location
    Ashland, Oregon
    Posts
    14
    Rep Power
    7

    Default NO cleartext logins disabled - error with imapsync

    This resolved the above error with imapsync also on ZCS 5.08 on Fedora 7 - new install. Noted here to help someone else with same issue.

    /rh

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2nd server redirects to the master on login
    By gilran in forum Administrators
    Replies: 6
    Last Post: 01-14-2013, 08:23 PM
  2. User login hangs up on Loading screen
    By marinew in forum Administrators
    Replies: 9
    Last Post: 07-14-2011, 08:53 PM
  3. imapsync and scalix
    By deugenin in forum Migration
    Replies: 3
    Last Post: 02-11-2008, 08:45 PM
  4. Replies: 4
    Last Post: 12-13-2007, 10:18 AM
  5. problem while building perl
    By ravinder in forum Developers
    Replies: 7
    Last Post: 05-29-2006, 09:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •