Results 1 to 9 of 9

Thread: How to change web access port?

  1. #1
    hootjr29 is offline Active Member
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default How to change web access port?

    I installed ZCS 3.0 on Fedora Core 4. It worked great and I installed everything with defaults. The only thing I changed was the domain name from server.domain.com to domain.com so that the MX resolve correctly.

    The one thing that I'm having an issue with right now is the port that the web client is on -- port 80.

    I would like to have it listen on another port, such as 8888.

    I've searched through the forums and found a couple documents on modifying the server.xml file for tomcat. When I do that and change the port to 8888, use zmcontrol to stop the servers, and then zmcontrol to start the servers again, something seems to modify server.xml and change its port back to port 80. I've also attempted to modify the /opt/zimbra/httpd/conf/httpd.conf file's port. But that's doesn't seem to have much affect.

    I've installed tomcat on my own a couple of years ago but haven't touched it since.

    Can anyone help point me in the right direction to getting the web client to listen on port 8888?
    Last edited by hootjr29; 02-15-2006 at 07:14 AM.

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    hootjr29 is offline Active Member
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    OK. I just tried that. Tomcat is now responding on port 8888. However, when I attempt to login I get the following error in the login box:

    An unknown application error has occurred. Please correct any errors and retry. If the problem persists, please contact your System Aministrator. (AjxException.INVALID_PARAM)

    The exact command that I ran was:


    $ zmprov
    prov> ms myserver.domain.com zimbraMailPort 8888 zimbraMailSSLPort 8889
    tomcat stop
    tomcat start

    After getting the error above, I then tried zmcontrol stop and zmcontrol start.

    I went back into zmprov and ran GetConfig zimbraMailPort
    This returned that it was still using 80. I'm not sure if maybe "zmprov GetConfig" reads a saved copy of the config or not, but in any case I tried to change it again:

    zmprov ms myserver.domain.com zimbraMailPort 8888
    zmprov GetConfig zimbraMailPort still returns port 80. I then reviewed the /opt/zimbra/tomcat/conf/server.xml and verified that although the zmprov didn't see to show me the correct zimbraMailPort, that the server.xml was actually changing. So in there it changed to port 8888 and redirect to SSL port 8889.

    After I did all of the above stuff, I tried hitting http://myserver.domain.com:8888. I just get the apache test page.

    Do I need to use zmprov in addition to doing some other steps?

    Thanks for the quick reply, btw.
    Last edited by hootjr29; 02-15-2006 at 07:16 AM.

  4. #4
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    the admin should still work, since you haven't changed the admin port (still 7071).

    You say "when you log in" - do you get the login screen?

    What is set for zimbraMailMode?

  5. #5
    hootjr29 is offline Active Member
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    When I first ran through the install, when I was done, I logged in to both the zimbraAdmin via https://servername:7071/zimbraAdmin. I also logged in successfully via http://servername. After I changed the ports with zmprov ms..etc..etc. and then restarted tomcat, I was able to go to http://servername:8888 and get the login screen for zimbra. I attempted to login with username@domainname.com and the correct password. This is when I received an error. I then tried with a different web browser on my same workstation. I got the same error. I did startx from the zimbra server and launched firefox and tried again. Still the same error. I then tried logging into the admin interface via https://servername:8889/zimbraAdmin (because this is what I was thinking the zimbraMailSSLPort was changing). That didn't work (I forget at this point if apache answered or not). After that I tried port 7071 and I think apache actually responded but said something like page unavailable. I then changed the port back to 80 via zmprov, and now I can login successfully again via http://servername and https://servername:7071/zimbraAdmin.

    I don't seem to have a zimbraMailMode attribute available. The only thing related to zimbraMailMode is the following:
    zimbraServerInheritedAttr: zimbraMailMode
    Last edited by hootjr29; 02-15-2006 at 09:07 AM.

  6. #6
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default mail mode

    I'd set the mode with zmtlsctl and try restarting tomcat, that could be the problem.

    After you login - are you getting redirected to the old port, or just a failure?

  7. #7
    hootjr29 is offline Active Member
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    that was it! I reconfigured zmprov back to be port 8888 for http and 8889 for SSL. I then ran zmtlsctl https, tomcat stop, tomcat start. Now everything works as expected!

    Thanks again for getting back to me so quickly.

    With regards to zmprov, does zmprov store all data in openldap, mysql, or a config file someplace?

    When I execute zmprov, does it automatically save this new config information or do I have to manually run something else to save it so that I don't have to run these commands again after I might reboot the server?
    Last edited by hootjr29; 02-15-2006 at 10:31 AM.

  8. #8
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    hmm after zmtlsctl https you shouldn't be able to access via http (port 8888) .

    zmprov accesses configuration data stored in ldap. you should only need to execute a command once, though it may be necessary to restart tomcat or whatever uses the particular parameter for the change to take effect.

  9. #9
    hootjr29 is offline Active Member
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    oops. Yup... I changed it with zmprov, but didn't enable it with zmtlsctl. I only used zmtlsctl https.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 10:27 AM
  2. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  4. Change Default Web UI Port
    By yang in forum Administrators
    Replies: 4
    Last Post: 12-12-2005, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •