Results 1 to 1 of 1

Thread: Reboot & zmmailboxdctl is not running

  1. #1
    SamTzu's Avatar
    SamTzu is offline Loyal Member
    Join Date
    Jan 2006
    Location
    Finland
    Posts
    83
    Rep Power
    9

    Default Reboot & zmmailboxdctl is not running

    Hi all. here is my sad song. Hope it helps you.
    Lets start with the obvious.
    VM = VMware 1.0.4 server-linux on PCLinuxOS2007
    OS = Ubuntu 6.06 LTS (Installed with the instructions from zimbra wiki pages.)
    Zimbra = 5.04 OpenSource

    These threads were no help....
    zmmailboxdctl is not running
    Zimbra network test install issues on CentOS 5.x
    zmmailboxdctl is stopped frequently..

    After installation server was rebooted to make sure everything was up and running properly. It was. After a few days of testing server went to production. It was Live for a week when it was decided to take a full backup of the VirtualMachine. Server was stopped (at night of course) and copied and restarted. Thats when the hell started.

    zmmailboxdctl is not running
    All the other services were fine.
    Luckyly port 25 was open and receiving mail.
    All other mail ports were dead.

    Here are some of the symptoms I tried to solve to no avail...

    CompilerOracle: exclude com/zimbra/cs/session/SessionMap.putAndPrune
    0 INFO [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    934 WARN [main] log - EXCEPTION
    java.io.UTFDataFormatException: Invalid byte 2 of 2-byte UTF-8 sequence.

    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException


    So what to do.
    I started from the logical place.
    OS.
    Ubuntu threads here gave no clue.
    I saw similar sob stories even in Fedora threads but no solution.

    Update and reinstallation did not help.
    Upgrade and reinstallation did not help.

    I even tried these to no avail.
    Bug 23782 - zmmtaconfig can shutdown services if zmprov gs crashes
    [RESOLVED] Authen::PAM is not installed [Archive] - Forums :: Trustix Secure Linux
    How do I download and install a Perl module? - LinuxQuestions.org
    apt-get … Segmentation Faulty Tree (You need this after Upgrading.)
    (Forget this one... no use.)
    zmmailboxdctl is not running - Google-haku


    Slowly I started to suspect the problem was not with the OS or Zimbra in it self (or rather it was only after a fashion.)

    I started using Webmin (...all hail webmin!)
    In webmins Perl modules I started updating all the available Perl modules.
    And hit several problems. Inconsistancies in Perl dependencies.
    Especially in here....
    Installation of Test::Warn failed.

    Array::Compare
    Authen::PAM

    More and more it started to look like my problems were with Authen::PAM Perl Module.

    Every time Webmin asked me if I wanted to "Fetch Missing Pre-Requisites" I said yes, lets do that. And so my Perl Module update went, time and again.

    I started with 5or6 Perl modules in webmin and ended up with 15.
    -------------------------------------------------------------------------
    Module Submodules Description Version Installed on
    Array::Compare 0 Perl extension for comparing arrays. 1.15 12/Apr/2008 16:13
    Authen::PAM 0 Perl interface to PAM library 0.16 12/Apr/2008 15:39
    FreeTypeWrapper 1
    1.2-15 12/Apr/2008 15:39
    IO::Pty 2 Pseudo TTY object class 1.02 12/Apr/2008 15:39
    Locale::gettext 0 message handling functions 1.05 12/Apr/2008 15:39
    MD5 0 Perl interface to the MD5 Message-Digest Algorithm 2.03 12/Apr/2008 15:39
    Net::SSLeay 1 Perl extension for using OpenSSL 1.25 12/Apr/2008 15:39
    Sub::Uplevel 0 apparently run a function in a higher stack frame
    12/Apr/2008 16:16
    Test::Builder::Tester 1 test testsuites that have been built with Test::Builder 1.01 12/Apr/2008 15:39
    Test::Exception 0 Test exception based code 0.20 12/Apr/2008 15:39
    Test::Warn 0 Perl extension to test methods for warnings 0.08 12/Apr/2008 15:39
    Text::CharWidth 0 Get number of occupied columns of a string on terminal 0.04 12/Apr/2008 15:39
    Text::Iconv 0 Perl interface to iconv() codeset conversion function 1.4 12/Apr/2008 15:39
    Text::WrapI18N 0 Line wrapping module with support for multibyte, fullwidth, and combining characters and languages without whitespaces between words 0.06 12/Apr/2008 15:39
    Tree:AG_Node 0 (super)class for representing nodes in a tree 1.06 12/Apr/2008 16:19
    --------------------------------------------------------------------------

    After a while I had installed gcj, perl-docs, cc, make - but still I could not fix the inconsistancies in Authen::PAM perl module. So I removed it. (Also had to remove Webmin at the same time.) After reinstalling webmin that I had just downloaded everything was easy. Perl modules updated with no problem from the webmin. I down loaded the .torrent version of the Ubuntu Zimbra and reinstalled that and voilá.

    So children what have we learned after 3hours of sleep and lot of cursing?
    Before rebooting your Zimbra mail server - pray!
    I'm not kidding. Its clear to me that there is something the setup misses.
    After only one weeks use Zimbra wants something that it did not want right after installation and reboot. (Some Perl module for maintenance perhaps?)

    For our next reboot I'm going to have a newly made Zimbra mail server with identical settings on standby "just in case."

    You can start laughing now.
    Last edited by SamTzu; 04-12-2008 at 09:07 AM.
    SamTzu
    -----------------------------------------------
    "I keep hitting the esc key, why am I still here?"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  2. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM
  3. Replies: 4
    Last Post: 11-14-2007, 02:19 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •