Results 1 to 4 of 4

Thread: Postfix not starting on Network Edition 5.0.4 on CentOS 5.1 (RHEL5.1)

  1. #1
    kitekid is offline Starter Member
    Join Date
    Apr 2008
    Posts
    2
    Rep Power
    7

    Question Postfix not starting on Network Edition 5.0.4 on CentOS 5.1 (RHEL5.1)

    Hi

    Just completed a fresh install of Network Edition RHEL64bit v5.0.4 on CentOS 5.1 x86_64. All gone very well except the MTA will not start, it shows as stopped when I do a zmcontrol status command. It says postfix is not running so I issued the following command:

    [zimbra@chailey-com1 /]$ sh -x /opt/zimbra/bin/zmmtactl status

    which returned the following:

    + BASE=/opt/zimbra
    + SCRIPTS='zmmtaconfigctl postfix zmsaslauthdctl'
    + case "$1" in
    + STATUS=0
    + for i in '$SCRIPTS'
    + /opt/zimbra/bin/zmmtaconfigctl status
    + R=0
    + '[' 0 -ne 0 ']'
    + for i in '$SCRIPTS'
    + /opt/zimbra/bin/postfix status
    + R=1
    + '[' 1 -ne 0 ']'
    + echo 'postfix is not running'
    postfix is not running
    + STATUS=1
    + for i in '$SCRIPTS'
    + /opt/zimbra/bin/zmsaslauthdctl status
    saslauthd is running with pid 3566
    + R=0
    + '[' 0 -ne 0 ']'
    + exit 1
    [zimbra@chailey-com1 /]$

    There was nothing listening on port 25 before installation and I have read the forums about that error so I don't think this is related. My question is how do I fix Postfix and get my MTA up and running?

    Thanks

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    First thing support will ask is that you have NE running on a supported platform and the list is here http://www.zimbra.com/products/downloads.html

    Right down to the problem, are there any error message in /var/log/zimbra.log ?

  3. #3
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Did you stop/remove/reconfigure sendmail ?

  4. #4
    kitekid is offline Starter Member
    Join Date
    Apr 2008
    Posts
    2
    Rep Power
    7

    Default Error log and sendmail response

    Hi and thanks for the quick response, below is the error log, I thought the owner warning strange as I have already tried using zmfixperms which ran ok.

    Also, regarding stopping and reconfiguring sendmail, what process does this involve? I did read about this and stopped the system postfix and sendmail running as discussed elsewhere in the forums to prevent anything listening on port 25 prior to zimbra installation - should I have set one of the processes to run and if so how should this be done?

    Thanks


    /var/log/zimbra.log follows

    Apr 10 18:05:20 chailey-com1 postfix/postfix-script[5193]: warning: not owned by root: /opt/zimbra/postfix-2.4.3.4z/conf/main.cf

    Apr 10 18:05:20 chailey-com1 postfix/postfix-script[5207]: starting the Postfix mail system

    Apr 10 18:05:20 chailey-com1 postfix/master[5208]: fatal: 0.0.0.0:smtp: Servname not supported for ai_socktype

    Apr 10 18:05:20 chailey-com1 saslauthd[5224]: detach_tty : master pid is: 5 224

    Apr 10 18:05:20 chailey-com1 saslauthd[5224]: ipc_init : listening on soc ket: /opt/zimbra/cyrus-sasl-2.1.22.3z/state/mux

    Apr 10 18:05:20 chailey-com1 zimbramon[3490]: 3490:info: Starting stats

    Apr 10 17:05:30 chailey-com1 postfix/postqueue[5595]: fatal: Queue report unavai lable - mail system is down

    Apr 10 17:06:00 chailey-com1 postfix/postqueue[5629]: fatal: Queue report unavai lable - mail system is down

    (log clipped to relevant items for clarity)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 03:02 PM
  2. upgrading to network edition
    By zzzzsg in forum Installation
    Replies: 11
    Last Post: 03-06-2008, 10:58 PM
  3. postfix stopped
    By riegersteve in forum Administrators
    Replies: 1
    Last Post: 05-15-2007, 03:25 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •