Results 1 to 9 of 9

Thread: LDAP error code 49 - invalid credentials

  1. #1
    fieze is offline Junior Member
    Join Date
    Apr 2008
    Posts
    6
    Rep Power
    7

    Default LDAP error code 49 - invalid credentials

    I am doing a test installation of ZCS 5.0.2_GA_1775_F7. This is my first installation of zimbra . On running install.sh at a stage I got a message Initializing ldap - failed (28416) .

    The last part of the zmsetup.log is below

    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 160.
    failed. (28416)
    ERROR
    Configuration failed
    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Line 160 of /opt/zimbra/libexec/zmldapinit is

    my $ldap = Net::LDAP->new("$ldap_master_url") or die "$@";

    I removed 'or die "$@"" from the line 160 and ran zmsetup.pl

    I was able to complete setup but ldap is not initialized and I can not log on to the admin console.
    The following results was obtained with zmcontrol

    [zimbra@mypc ~]$ zmcontrol status
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist

    Please offer me solutions on how to resolve the problem.

    A display of startup.log is below

    [zimbra@mypc log]$ cat startup.log
    Host mypc.macsonia.local.
    Starting ldap...Done.
    FAILED
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    Failed to start slapd. Attempting debug start to determine error.

    A part of the zmsetup.log is displayed below to help you in proffering solutions.
    Thanks.

    a previous configuration appears to have failed to complete

    Saving config in /opt/zimbra/config.9281...
    done.
    Operations logged to /tmp/zmsetup.04072008-153703.log
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    done.
    Setting replication password...
    *** Running as zimbra user: /opt/zimbra/bin/zmldappasswd -l ObbAM5jVo
    Updating local config and directory
    done.
    Setting Postfix password...
    *** Running as zimbra user: /opt/zimbra/bin/zmldappasswd -p ObbAM5jVo
    Updating local config and directory
    done.
    Setting amavis password...
    *** Running as zimbra user: /opt/zimbra/bin/zmldappasswd -a ObbAM5jVo
    :Updating local config and directory
    done.
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    Setting local config zimbra_zmprov_default_to_ldap to FALSE
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_zmp
    rov_default_to_ldap='FALSE' 2> /dev/null
    Deploying CA to /opt/zimbra/conf/ca ...
    *** Running as root user: /opt/zimbra/bin/zmcertmgr deployca
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.
    ** Saving CA in ldap...ERROR: service.FAILURE (system failure: getDirectCo
    ntext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 -
    Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.na
    ming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    done.

    checking isEnabled zimbra-store
    zimbra-store is enabled
    Setting spell check URL...
    *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms mypc.macsonia.loc
    al. zimbraSpellCheckURL http://mypc.macsonia.local.:7780/aspell.php
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.na
    ming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    done.
    Setting service ports on mypc.macsonia.local....
    *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms mypc.macsonia.loc
    al. zimbraImapBindPort 7143 zimbraImapSSLBindPort 7993 zimbraImapProxyBind
    Port 143 zimbraImapSSLProxyBindPort 993
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.na
    ming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms mypc.macsonia.loc
    al. zimbraPop3BindPort 7110 zimbraPop3SSLBindPort 7995 zimbraPop3ProxyBind
    Port 110 zimbraPop3SSLProxyBindPort 995
    :ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.na
    ming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms mypc.macsonia.loc
    al. zimbraPop3BindPort 7110 zimbraPop3SSLBindPort 7995 zimbraPop3ProxyBind
    Port 110 zimbraPop3SSLProxyBindPort 995
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.na
    ming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms mypc.macsonia.loc
    al. zimbraMailPort 80 zimbraMailSSLPort 443 zimbraMailMode http
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.na
    ming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    done.
    Adding mypc.macsonia.local. to zimbraMailHostPool in default COS...
    usage: modifyCos(mc) {name|id} [attr1 value1 [attr2 value2...]]

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Welcome to the forums

    What O/S are you running on ? Are you behind a firewall ? If so have you followed setting up Split DNS?

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    visudo
    comment out:
    #Defaults requiretty

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Quote Originally Posted by fieze View Post
    I am doing a test installation of ZCS 5.0.2_GA_1775_F7. This is my first installation of zimbra .

    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 160. failed. (28416)

    [zimbra@mypc log]$ cat startup.log
    Host mypc.macsonia.local.
    Starting ldap...Done.
    FAILED
    /opt/zimbra/bin/ldap: line 57: kill: (16016) - No such process
    sudo: sorry, you must have a tty to run sudo
    ie: Type visudo to edit /etc/sudoers rather than another text editor (vi, nano, nedit, gedit, etc). Visudo provides basic sanity checks, looks for parse errors, and locks the sudoers file against multiple simultaneous edits (say you we're in a multi-admin environment).

    If requiretty is set sudo will only run when the user is logged in to a real tty. Requiring it disallows things like 'rsh somehost sudo ls' since rsh does not allocate a tty, etc, etc. Here we're turning it off because it's saying "you must have a tty to run sudo".

  5. #5
    fieze is offline Junior Member
    Join Date
    Apr 2008
    Posts
    6
    Rep Power
    7

    Default

    I am running fedora core 7 . The server has 2 network interface cards, eth0 is used for the local system with 192.168.9.1 and this was used to setup a local dns server while eth1 receives ip from a windows xp dhcp server on 192.168.0.0/24 network . The windows xp server is the is running a firewall and is the network gateway .

    To answer your question I have not done the split dns
    Last edited by fieze; 04-10-2008 at 07:32 AM.

  6. #6
    fieze is offline Junior Member
    Join Date
    Apr 2008
    Posts
    6
    Rep Power
    7

    Default

    I have done the
    visudo
    comment out:
    #Defaults requiretty

  7. #7
    fieze is offline Junior Member
    Join Date
    Apr 2008
    Posts
    6
    Rep Power
    7

    Smile Successful install

    I did the
    comment out:
    #Defaults requiretty, for sudoers and created a split dns as suggested to me .
    I uninstalled zimbra and did a fresh install without any hitch. No invalid credentials message .
    The only anomaly was that postfix , antispam, and antivirus was not started automatically.
    I can log into the admin console. Thanks for your suggestions.

    Please I need suggestions on how to stop /sbin/dhclient-script and NetworkManager from changing my entries in /etc/resolv.conf file.
    I have disabled dhcdbd. I am running a fedora core 7 with two network interface card, eth1 receives ip address from the network while eth0 uses a static ip address with which I configured a local dns server for the zimbra server.

  8. #8
    jadjei is offline New Member
    Join Date
    May 2007
    Location
    Coventry, UK
    Posts
    4
    Rep Power
    7

    Default

    add the following to /etc/sysconfig/network-scripts/ifcfg-ethX .. where X is the number of the ethernet card. Not sure what happens when you have 2 cards.. perhaps need to add this to both files?

    Code:
    PEERDNS=no

  9. #9
    fieze is offline Junior Member
    Join Date
    Apr 2008
    Posts
    6
    Rep Power
    7

    Default Disabled NetworkManager

    Thanks jadjei, I did the
    peerdns=no
    for both interface cards.
    But the NetworkManager reverts to the network dns service.
    Hence I shut the NetworkManager, with that I'm able to use my local dns server.
    The only thing that I miss with that is the NetworkManager icon on my deasktop.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. LDAP: error code 49 - Invalid Credentials
    By olibite in forum Installation
    Replies: 0
    Last Post: 03-28-2008, 07:46 AM
  2. Problem with Mail Server - Need help!
    By joeleo in forum Installation
    Replies: 2
    Last Post: 03-04-2008, 12:03 PM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  4. LDAP Invalid Credentials on install
    By rory_d in forum Installation
    Replies: 1
    Last Post: 09-30-2005, 08:51 AM
  5. Replies: 6
    Last Post: 09-13-2005, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •