Results 1 to 9 of 9

Thread: Zimbra failed to install on Debian Etch: FQHN problem

  1. #1
    nahmsath is offline Active Member
    Join Date
    Apr 2008
    Location
    Lomé/Togo
    Posts
    34
    Rep Power
    7

    Default Zimbra failed to install on Debian Etch: FQHN problem

    Hi all,
    I'm trying to install Zimbra 5.0.4 on Debian Etch.
    But i get this error while launching the install.sh script:

    ERROR: Installation can not proceeed. Please fix your /etc/hosts file to contain:
    IP FQHN HN


    I've set up a local DNS and a domain name says: collab-sidik.tg

    my /etc/hosts file contains:
    192.168.200.222 zimbra.collab-sidik.tg zimbra

    and my /etc/hostname:
    zimbra

    When i ping zimbra.collab-sidik.tg, i get a response like: PING zimbra (192.168.200.222) 56(84) bytes of data.... which means my FQHN is OK. (I hope!)


    So, how can i fix this? Is there something wrong with my FQHN?
    thanks.
    Last edited by nahmsath; 04-04-2008 at 11:52 AM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Your hosts file is incorrect if that's all there is in it. Check the details in the Quick Start Installation Guide for hosts file requirements and you'll also need DNS A & MX record using a Split DNS set-up as you're behind a NAT router. Fix those problems, disable any firewall or SElinux and try the install again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    nahmsath is offline Active Member
    Join Date
    Apr 2008
    Location
    Lomé/Togo
    Posts
    34
    Rep Power
    7

    Default

    This is my /etc/hosts file:

    127.0.0.1 localhost zimbra
    192.168.200.222 zimbra.collab-sidik.tg zimbra

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    127.0.1.1 zimbra


    And this is my collab-sidik.tg zone file:

    ;
    ;BIND data file for collab-sidik.tg
    ;
    $TTL 604800
    @ IN SOA collab-sidik.tg. info.sidik.tg. (
    2008040201 ; Serial
    7200 ; Refresh
    120 ; Retry
    2419200 ; Expire
    604800) ; Default TTL
    ;
    @ IN NS ns1.collab-sidik.tg.
    @ IN NS ns2.collab-sidik.tg.
    collab-sidik.tg. IN MX 10 mail.collab-sidik.tg.
    collab-sidik.tg. IN A 192.168.200.222

    This DNS is working coz others nodes from my network are able to use it to surf the Internet.

    And finally this is my /etc/resolv.conf

    # generated by NetworkManager, do not edit!


    search collab-sidik.tg
    nameserver 192.168.200.222
    #nameserver 41.207.186.38
    #nameserver 41.207.186.37

    Do i still need an external DNS?
    Or my /etc/hosts is still wrong?
    Thanks for your advice.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Your hosts file is incorrect. This line needs changing:

    Code:
    127.0.0.1 localhost zimbra
    to this:
    Code:
    127.0.0.1 localhost.localdomain localhost
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    nahmsath is offline Active Member
    Join Date
    Apr 2008
    Location
    Lomé/Togo
    Posts
    34
    Rep Power
    7

    Default

    My new /etc/hosts file.

    Code:
    127.0.0.1 localhost.localdomain localhost
    192.168.200.222 zimbra.collab-sptintra.tg zimbra
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    127.0.1.1 zimbra
    But nothing change. Still got the "Fix your /etc/hosts file" error during install.
    Regards,

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Remove the last line in your /etc/hosts
    Code:
    127.0.1.1 zimbra

  7. #7
    nahmsath is offline Active Member
    Join Date
    Apr 2008
    Location
    Lomé/Togo
    Posts
    34
    Rep Power
    7

    Default

    Many Tx uxbod!
    Removing that line make the install roll on...

    Will feed u back asap about the overall progress of this, install.

  8. #8
    nahmsath is offline Active Member
    Join Date
    Apr 2008
    Location
    Lomé/Togo
    Posts
    34
    Rep Power
    7

    Default

    My Zimbra works fine now on Debian Etch!

    I just had a small error on startup saying mailbox is stopped.
    After checking the log, i've discovered that there was a staled mailboxd pid file in /opt/zimbra/log/zmmailboxd.pid. I removed this file, stop all services through zmcontrol, restart them again and everything roll on...

    Thanks a lot to all of you guys.

  9. #9
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Excellent One last thing though http://www.zimbra.com/forums/announc...r-profile.html please

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  2. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  3. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  4. Replies: 8
    Last Post: 02-27-2007, 04:10 AM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •