Results 1 to 6 of 6

Thread: Upgrade 4.5.11 -> 5.0.4 : Imapproxy fails

  1. #1
    rajahd is offline Special Member
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default Upgrade 4.5.11 -> 5.0.4 : Imapproxy fails

    Upgrade went smooth until the final part where it was starting the services...
    Starting ldap...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting imapproxy...FAILED
    bind(): Address already in use
    failed to listen
    nginx is running
    memcached is not running


    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.
    I can access Zimbra and Zimbra Admin UI's via a web browser. Sending and receiving mail works. The mail queues area on the admin site were erroring out till I ran the "zmsshkeygen" / "zmupdateauthkeys" scripts and restarted Zimbra.

    Any ideas why Imapproxy wouldn't be starting? I can't find any log entries that would tell me what port it thinks is already in use.

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    are you running ZCS on a single server ? have you always used IMAPPROXY ? what does the following command show :-

    Code:
    su - zimbra
    zmproxyctl status

  3. #3
    rajahd is offline Special Member
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    I managed to get it figured out.

    In my quest to get imapproxy working after declining imapproxy during the initial upgrade I had installed memcached under Ubuntu (apt-get install memcached) and followed instructions in another thread to assign it a port. Then when I reran the upgrade script and said yes to install Zimbra proxy it installed memcached (along with nginx) under Zimbra itself. Since the other memcached was still a process in memory the port was used.

    Killing the non-Zimbra memcached process and restarting Zimbra appears to have solved the problem. I still have to test it across a server reboot to ensure the non-Zimbra memcached is not being auto started.

    Thanks for the help. Note to other people who are getting ready to upgrade: choose "yes" when it asks you to install Zimbra Proxy It's easy to disable after the fact from the admin UI but a pain to install later!

  4. #4
    rajahd is offline Special Member
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    On a side note, I'm not going to upgrade any of my other servers to FOSS 5.0.x. I can't believe Zimbra has 4 minor revs out and still has so many serious (IMO) UI issues. This seems more like beta-ware than a production quality system.

    While I feel bad bitching about free software and have been very happy with Zimbra's effort to support an open source system, the 5.0.x product is just not up to par (again IMO) with the stability and usability of the 4.5.x product. I would downgrade the server I just upgraded if I could somehow preserve the new e-mails but I'm guessing that's an undertaking not worth the effort.

    For the record the issues that are the most annoying:

    * Make the different views work. Not everyone wants conversation view style and preview panes but that's the only view combination that has any stability. How can we be on .4 and this is still not usable??

    * Pop up message windows without all the message handling features (reply, forward, delete, etc) are useless.

    * Get rid of the darn Yahoo search thing. I don't care that it's in there or on by default but not having an easy way to disable it drives me nuts. I've edited it out of the skin files but these get overwritten on each upgrade.

    One of my beefs with Zimbra since the beginning is it's attempt to force me to use e-mail in a specific way (i.e., heavy on search, light on organization) instead of conforming to the way I want to use e-mail. I see this getting worse in 5.x instead of better.

    Disclaimer: Don't take these criticisms personally. Zimbra is a fine product and these are issues for my specific needs and may not represent the majority of users.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by rajahd View Post
    On a side note, I'm not going to upgrade any of my other servers to FOSS 5.0.x. I can't believe Zimbra has 4 minor revs out and still has so many serious (IMO) UI issues. This seems more like beta-ware than a production quality system.
    I assume you've filed bug reports on the problems that you're having? Some links to them might help.

    BTW, there's a very simple method of turning off the Yahoo search bar and you'll never see it again even after an upgrade - there's an entry in bugzilla about it and there are a couple of threads in the forums with a solution.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    rajahd is offline Special Member
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    Quote Originally Posted by rajahd View Post
    * Make the different views work. Not everyone wants conversation view style and preview panes but that's the only view combination that has any stability.
    * Pop up message windows without all the message handling features (reply, forward, delete, etc) are useless.
    Bug 24774 - double click the msg for pop up window, the msg is never displayed and always in "loading" state
    Bug 16130 - Reply/Forward buttons missing for Email opened in Separate Window
    This happens frequently to me. I do not like preview panes but these 2 issues combined make Zimbra 5.x nearly unusable except with the preview pane on. As a side note, when Conversation mode is disabled (via account or CoS) the "View" button appears to do nothing. If this is truly the desired behavior why not just hide the button altogether?

    Quote Originally Posted by rajahd View Post
    * Get rid of the darn Yahoo search thing. I don't care that it's in there or on by default but not having an easy way to disable it drives me nuts. I've edited it out of the skin files but these get overwritten on each upgrade.
    You're right, I didn't do a (very good) search of the forums as I see there is now a command line parameter to disable it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FOSS upgrade fails
    By buraglio in forum Administrators
    Replies: 13
    Last Post: 03-09-2008, 08:53 PM
  2. Upgrade ZCS 4.5.11 GA to 5.0.1
    By aerojasc in forum Migration
    Replies: 1
    Last Post: 02-21-2008, 09:43 AM
  3. 4.5.10 -> 5.0 upgrade fails
    By InternetGuy in forum Administrators
    Replies: 3
    Last Post: 01-12-2008, 03:44 PM
  4. Replies: 27
    Last Post: 01-07-2008, 09:07 AM
  5. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 10:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •