Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 32

Thread: [SOLVED] Remote Manager, Port 22 issue

  1. #21
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Are you logging into the server as root or another user prior to performing the 'su' ?

  2. #22
    sefs is offline Junior Member
    Join Date
    Jul 2009
    Posts
    7
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    Are you logging into the server as root or another user prior to performing the 'su' ?
    I had to go
    Code:
    sudo -i u zimbra
    because I am on ubuntu.

  3. #23
    sefs is offline Junior Member
    Join Date
    Jul 2009
    Posts
    7
    Rep Power
    6

    Default

    Ok I have my ssh server set up on port 22.

    I can log in as a regular user and the results would be
    Code:
    fshlampserver@mail:~/.ssh$ ssh -v -i ~/.ssh/ssh_host_rsa_key fshlampserver@mail.fshzimbra.lan -p 22
    OpenSSH_4.7p1 Debian-8ubuntu1.2, OpenSSL 0.9.8g 19 Oct 2007
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to mail.fshzimbra.lan [192.168.1.60] port 22.
    debug1: Connection established.
    debug1: identity file /home/fshlampserver/.ssh/ssh_host_rsa_key type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: match: OpenSSH_4.7p1 Debian-8ubuntu1.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'mail.fshzimbra.lan' is known and matches the RSA host key.
    debug1: Found key in /home/fshlampserver/.ssh/known_hosts:1
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey
    debug1: Next authentication method: publickey
    debug1: Trying private key: /home/fshlampserver/.ssh/ssh_host_rsa_key
    debug1: read PEM private key done: type RSA
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Fri Jul  3 06:12:54 2009 from mail.fshzimbra.lan
    fshlampserver@mail:~$ exit
    So I know that the ssh server i installed prior to installing zimbra is up and working.

    However no matter what I try which were
    1) generating keys (dsa by default) via the zimbra user commands as mention earlier in this thread
    2) generating keys the normal way (both dsa and rsa)

    I cant get the test connection done by the zimbra user. The ssh server that I am using looks for authorized_keys2 as opposed to authorized_keys so I change that file name in /opt/zimbra/.ssh and all should have been good I think...

    But this is how the connection goes
    Code:
    zimbra@mail:~/.ssh$ ssh -v -i ~/.ssh/zimbra_identity zimbra@mail.fshzimbra.lan -p 22 
    OpenSSH_4.7p1 Debian-8ubuntu1.2, OpenSSL 0.9.8g 19 Oct 2007
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to mail.fshzimbra.lan [192.168.1.60] port 22.
    debug1: Connection established.
    debug1: identity file /opt/zimbra/.ssh/zimbra_identity type 2
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: match: OpenSSH_4.7p1 Debian-8ubuntu1.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'mail.fshzimbra.lan' is known and matches the RSA host key.
    debug1: Found key in /opt/zimbra/.ssh/known_hosts:1
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey
    debug1: Next authentication method: publickey
    debug1: Offering public key: /opt/zimbra/.ssh/zimbra_identity
    debug1: Authentications that can continue: publickey
    debug1: No more authentication methods to try.
    Permission denied (publickey).

    UPDATE: on checking my auth log while running the connect command I see this appear
    "Jul 3 08:08:14 mail sshd[6310]: User zimbra not allowed because account is locked"

    Why is it locked and should it be unlocked (and how is this done) so that we can connect and get rid of the error in the zimbra web interface. I'm on ubuntu 8.04

    Thanks.


    UPDATE 1:
    Ok from the post Mail Queue ssh error I was able to unlock the zimbra user and now everyting is honky dory for now.
    Last edited by sefs; 07-03-2009 at 05:27 AM.

  4. #24
    mfinkler is offline Junior Member
    Join Date
    Feb 2009
    Posts
    7
    Rep Power
    6

    Default Still not working :(

    Hi everyone,

    I found this post because I got the same problems and can't solve them.

    zimbra@ZimbraX1:~$ ssh -vi .ssh/zimbra_identity -o strictHostKeyChecking=no zimbraY2.domain.com -p 22
    OpenSSH_4.7p1 Debian-8ubuntu1.2, OpenSSL 0.9.8g 19 Oct 2007
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to zimbraY2.domain.com [x.x.x.x] port 22.
    debug1: Connection established.
    debug1: identity file .ssh/zimbra_identity type 2
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: match: OpenSSH_4.7p1 Debian-8ubuntu1.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'zimbraY2.domain.com' is known and matches the RSA host key.
    debug1: Found key in /opt/zimbra/.ssh/known_hosts:3
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password
    debug1: Next authentication method: publickey
    debug1: Offering public key: .ssh/zimbra_identity
    debug1: Remote: Forced command: /opt/zimbra/libexec/zmrcd
    debug1: Server accepts key: pkalg ssh-dss blen 434
    debug1: read PEM private key done: type DSA
    debug1: Remote: Forced command: /opt/zimbra/libexec/zmrcd
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = de_DE.UTF-8

    debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
    debug1: channel 0: free: client-session, nchannels 1
    Connection to zimbral2.zimboo.de closed.
    debug1: Transferred: stdin 0, stdout 0, stderr 42 bytes in 4.4 seconds
    debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 9.6
    debug1: Exit status 0
    In this case it works!

    The next one:

    zimbra@ZimbraX1:~$ ssh -vi .ssh/zimbra_identity -o strictHostKeyChecking=no zimbraY1.domain.com -p 22
    OpenSSH_4.7p1 Debian-8ubuntu1.2, OpenSSL 0.9.8g 19 Oct 2007
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to zimbraY1.domain.com [xx.xx.xx.xx] port 22.
    debug1: Connection established.
    debug1: identity file .ssh/zimbra_identity type 2
    ssh_exchange_identification: Connection closed by remote host
    zimbra@ZimbraX1:~$
    Any Ideas?

    Thank You!

  5. #25
    fulltears is offline Junior Member
    Join Date
    Nov 2009
    Posts
    9
    Rep Power
    5

    Default

    good~ now I can fix part of my problem. Thanks

  6. #26
    nahuelon is offline Starter Member
    Join Date
    Jun 2010
    Posts
    2
    Rep Power
    5

    Smile solution for me

    Hi everybody. I had the same problem and I fix it disabling the SElinux on my Fedora. Thanks phoenix!!!

  7. #27
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by nahuelon View Post
    Hi everybody. I had the same problem and I fix it disabling the SElinux on my Fedora. Thanks phoenix!!!
    You're welcome.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #28
    mailman.33's Avatar
    mailman.33 is offline Loyal Member
    Join Date
    Jun 2010
    Location
    India
    Posts
    82
    Rep Power
    5

    Default Thanks!

    mmorse,

    I had issues with mailqueue and certs broken in zimbraAdmin console, those steps worked perfectly! Thanks mmorse!! You are a pal.

  9. #29
    BLuesTime's Avatar
    BLuesTime is offline New Member
    Join Date
    Apr 2009
    Location
    Canada
    Posts
    3
    Rep Power
    6

    Thumbs up M. Morse procedure + zmfixperms = solved

    Just to let you know that we had the same problem,

    I did the procedure from M. Morse " thanks " but alone did not solve all my problems. The last step I did is that I ran as root "/opt/zimbra/libexec/zmfixperms --verbose --extended" and no errors anymore.

    Thanks to the Community!

  10. #30
    nosebreaker is offline Active Member
    Join Date
    Aug 2010
    Posts
    39
    Rep Power
    5

    Default

    Just a FYI, for anybody that has this problem and has AllowUsers enabled in their sshd_config, you need to add the zimbra users to the this line!

    I was receiving this error whenever I clicked on "Mail Queues" or other pages, and it went away as soon as I allowed zimbra to the AllowUsers line.

    I want to add that I have Zimbra working (I think) with SELinux so far! (disregard, no I don't)
    Last edited by nosebreaker; 08-23-2010 at 11:31 AM.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 09:10 AM
  2. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  3. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  4. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM
  5. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •