Results 1 to 5 of 5

Thread: [SOLVED] ham and spam training broken after hostname change

  1. #1
    oayfer is offline Active Member
    Join Date
    Mar 2008
    Posts
    31
    Rep Power
    7

    Default [SOLVED] ham and spam training broken after hostname change

    Hello,

    After changing the hostname of the Zimbra server according to:

    ZmSetServerName - Zimbra :: Wiki

    I am seeing deferred messages in the queue trying to get delivered to the ham and spam training accounts created for the old hostname. There are also these entries in the spamtrain.log file:

    [] ERROR: can not find account spam.aghertyo@old.hostname.com
    [] ERROR: can not find account ham.pz4yj7dx@old.hostname.com

    as those accounts are now updated with the new hostname.

    We are running ZCS NE 5.0.2, RHEL 5.

    Where do I need to update those so training still works?

    Thanks for your help.

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    zmprov gacf | grep SpamAccount

  3. #3
    oayfer is offline Active Member
    Join Date
    Mar 2008
    Posts
    31
    Rep Power
    7

    Default

    Thank you. I set those two to the new domain equivalents.

    In case others wish to know, the two params are:

    zimbraSpamIsSpamAccount
    zimbraSpamIsNotSpamAccount

    Perhaps this could be added to the list of things 'zmsetservername' does?

    Thanks again.

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Well there's several possibilities like:
    A) Either it was spam@server.domain.com and you just changed server's so it was spam@server2.domain.com
    B) It was spam@domainA.com but you changed domain names completely to spam@domainB.com
    C) It's simply spam@domain.com where the primary domain doesn't have the hostname in it.
    Not everyone has the same use case, but it'd probably be good to note in the wiki article: ZmSetServerName - Zimbra :: Wiki

  5. #5
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Added it to the "Notes on what people have had to change manually after zmsetservername:" section.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trying to understand Zimbra's anti-spam system
    By TaskMaster in forum Users
    Replies: 11
    Last Post: 01-25-2008, 09:59 AM
  2. Spam being scored with BAYES_00
    By flyerguybham in forum Administrators
    Replies: 6
    Last Post: 04-24-2007, 12:07 PM
  3. Spam vs Ham
    By tallboy755 in forum Administrators
    Replies: 8
    Last Post: 02-22-2007, 10:53 AM
  4. Training spam and ham
    By Justin in forum Developers
    Replies: 2
    Last Post: 10-31-2006, 03:39 PM
  5. Spam training has no cron job
    By richard-hdd in forum Administrators
    Replies: 3
    Last Post: 09-13-2006, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •