Results 1 to 9 of 9

Thread: change domain/server name

  1. #1
    jpbuse is offline Loyal Member
    Join Date
    Jan 2008
    Location
    San Diego, CA
    Posts
    88
    Rep Power
    7

    Cool [SOLVED] change domain/server name

    We're getting really close to deploying Zimbra FOSS here, I'm excited!

    Right now I am running ZCS on a specific host (zcs.mydomain.com). I have an alias setup on our current email server which redirects mail for me@mydomain.com to me@zcs.mydomain.com. All good. My reply to address is me@mydomain.com, but in the recipient's email it does show from: me@zcs.mydomain.com. How can I change it so its just @mydomain.com? Keep in mind I can't just change the host name because then sent mail will resolve to the zcs server and not the current email server. Make sense?

    Thx
    Last edited by jpbuse; 03-19-2008 at 06:58 AM. Reason: Figured it out!

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Within the Admin UI have you added a domain alias to the server zcs.mydomain.com ? If so you should then be able to set within your email Preferences->Accounts to send from user@domain.com.

  3. #3
    jpbuse is offline Loyal Member
    Join Date
    Jan 2008
    Location
    San Diego, CA
    Posts
    88
    Rep Power
    7

    Default

    Is an alias the same as setting a virtual host under Domains > zcs.mydomain.com > Virtual Host ? I don't know where in the GUI to set an alias. I do this cli command:

    Code:
    zmprov cd example.com zimbraDomainType alias zimbraMailCatchAllAddress @example.com zimbraMailCatchAllForwardingAddress @domain.com
    ManagingDomains - Zimbra :: Wiki

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Yep that is correct. So when you created the user was it in the zcs.domain.com or domain.com ? If the first then go into your web client and under Preferences->Accounts->Primary Account-Settings in the dropdown boxes for From and ReplyTo are you able to select user@domain.com ?

  5. #5
    jpbuse is offline Loyal Member
    Join Date
    Jan 2008
    Location
    San Diego, CA
    Posts
    88
    Rep Power
    7

    Default

    Quote Originally Posted by uxbod View Post
    Yep that is correct. So when you created the user was it in the zcs.domain.com or domain.com ? If the first then go into your web client and under Preferences->Accounts->Primary Account-Settings in the dropdown boxes for From and ReplyTo are you able to select user@domain.com ?
    When I created the user it was part of zcs.mydomain.com by default. I added a virtual host (just now) but it does not show under my user prefs. Wonder if I need to restart the mailbox? (It says I need to restart upon deletion of a virtual host).

  6. #6
    jpbuse is offline Loyal Member
    Join Date
    Jan 2008
    Location
    San Diego, CA
    Posts
    88
    Rep Power
    7

    Default

    I created the virtual host of mydomain.com, restarted zcs and mydomain.com still does not show as an option for my in my user prefs.

  7. #7
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    From the Admin GUI if you create a alias on the email account user@zcs.domain.com and user@domain.com does it then show up in the user preferences ? I am on a similar setup myself, but when I created the account it was straight after I added the virtual domain, therefore could create the account as user@domain.com.

  8. #8
    jpbuse is offline Loyal Member
    Join Date
    Jan 2008
    Location
    San Diego, CA
    Posts
    88
    Rep Power
    7

    Default

    I can only create aliases that end in @ zcs.mydomain.com and not @mydomain.com. I tried creating a new user now that the virtual host is setup but still I only have the option of @zcs.mydomain.com.

    Just so I am 100% clear, all I did was add a virtual host. I don't see anywhere in the GUI for a virtual domain. Perhaps on your setup you ran the zmprov cli command above at some point which basically enabled the virtual domain for you?
    Last edited by jpbuse; 03-18-2008 at 09:08 AM.

  9. #9
    jpbuse is offline Loyal Member
    Join Date
    Jan 2008
    Location
    San Diego, CA
    Posts
    88
    Rep Power
    7

    Default

    I think this did the trick. Testing now...

    Code:
    zmprov md zcs.mydomain.com zimbraMailCatchAllAddress @zcs.mydomain.com zimbraMailCatchAllCanonicalAddress @mydomain.com
    Yup, this works perfectly. In the GUI it still shows as @zcs.mydomain.com, however when I send emails out they are from @mydomain.com. Once we migrate our current email system over to Zimbra then I can run a quick command to change the domain to @mydomain.com. If I do that now then I won't be routing emails correctly to users on our current (non ZCS) email server.
    Last edited by jpbuse; 03-19-2008 at 07:00 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 12-13-2007, 10:18 AM
  2. Change Install Admin Email Address
    By soxfan in forum Administrators
    Replies: 4
    Last Post: 11-01-2007, 04:10 AM
  3. Outlook 03 - Connector Issue
    By Sonny Ali in forum Zimbra Connector for Outlook
    Replies: 9
    Last Post: 09-06-2007, 10:35 AM
  4. Replies: 0
    Last Post: 01-03-2007, 11:45 AM
  5. "Must change password" still doest work
    By graffiti in forum Users
    Replies: 5
    Last Post: 12-05-2005, 09:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •