Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Initializing ldap...failed. (28416) on RHEL 5

  1. #1
    Nicrad's Avatar
    Nicrad is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Unhappy Initializing ldap...failed. (28416) on RHEL 5

    Hello All,

    Just installing a brand new Zimbra 5.0.2 on to a RHEL 5 server and have hit a brick wall, below is the error I'm getting when it comes to the final stages of configuring Zimbra.
    Code:
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 160.
    failed. (28416)
    Does any one have any items as to how to over come this problem ?

    Tim

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Do you have SELinux or iptables on?
    Also, what does your hosts file look like. It can't bind.

    Try ldap start
    and see what happens.

  3. #3
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    Or slapd isn't running.

    As root, try running:

    Code:
    /opt/zimbra/openldap/libexec/slapd -d -1 -f /opt/zimbra/conf/slapd.conf -u zimbra
    And (assuming that fails), provide the output.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #4
    Nicrad's Avatar
    Nicrad is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Unhappy

    jholder,

    Answer to your first question, no; either of them are on.

    The hostfile looks like this
    Code:
    192.168.1.25    mail.appsescrow.com     mail    ipms    localhost       localhost.localdomain
    when running "ldap start" it returns this
    Code:
    Failed to start slapd.  Attempting debug start to determine error.
    TLS: error:0200A002:system library:opendir:No such file or directory ssl_cert.c:816
    TLS: error:140D7002:SSL routines:SSL_add_dir_cert_subjects_to_stack:system lib ssl_cert.c:818
    main: TLS init def ctx failed: -1
    Tim

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Please read and follow the guide here:
    http://www.zimbra.com/docs/os/latest...stall/#1057019

  6. #6
    Nicrad's Avatar
    Nicrad is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Unhappy

    jholder,

    OK, I've read the section about configuration for RHEL, and as far as I can see I'm setup up correctly; Looking over the error I posted last, it seems that 'slapd' cant start ! Also I cant find the info about zmcreatecert in Appendix A in the Admin guide. Is there a way I can confirm that my hostname is being accepted by Zimbra as a FQDN ?

    Tim

  7. #7
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Cool!

    Can we see your hosts file again?

  8. #8
    Nicrad's Avatar
    Nicrad is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Default

    Code:
    [root@mail etc]# cat hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    
    192.168.1.25    mail.appsescrow.com     mail    ipms    localhost       localhost.localdomain

  9. #9
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    The hosts file isn't correct. That's probably not the only problem here, but that's the first step to fix it.

    Per the quick setup guide:
    Important: Make sure that FQDN entry in /etc/hosts appears before the hostnames. If this is missing, the creation of the Zimbra certificate fails. The FQDN entry should look like this example. See zmcreatecert in the Administratorís Guide, Appendix A: Command-Line Utilities.

    127.0.0.1 localhost.localdomain localhost
    your.ip.address FQDN yourhostname

  10. #10
    Nicrad's Avatar
    Nicrad is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Default

    ok, new host file

    Code:
    [root@mail etc]# cat hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    
    127.0.0.1       localhost.localdomain   localhost
    192.168.1.25    mail.appsescrow.com     mail    ipms
    And still get the following

    Code:
    [root@mail etc]# /opt/zimbra/libexec/zmsetup.pl
    Operations logged to /tmp/zmsetup.02152008-104924.log
    Setting defaults...     MX: mail.appsescrow.com (192.168.1.25)
    
            Interface: 192.168.1.25
            Interface: 127.0.0.1
                    192.168.1.25
    done.
    Checking for port conflicts
    
    
    Note
    
    The previous configuration appears to have failed to complete
    
    Attempt to complete configuration now? [yes]
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.4658]
    Saving config in /opt/zimbra/config.4658...done.
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.02152008-104924.log
    Initializing ldap...failed. (28416)
    
    
    ERROR
    
    
    
    Configuration failed
    
    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.
    
    Errors have been logged to /tmp/zmsetup.02152008-104924.log
    Here is that log file as well

    Code:
    [root@mail etc]# cat /tmp/zmsetup.02152008-104924.log
    Operations logged to /tmp/zmsetup.02152008-104924.log
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    Enabling zimbra-store
    Enabling zimbra-mta
    Enabling zimbra-snmp
    Enabling zimbra-logger
    Enabling zimbra-apache
    Enabling zimbra-spell
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java' 2> /dev/null
    checking isEnabled zimbra-cluster
    zimbra-cluster not in enabled cache
    enabled packages zimbra-logger zimbra-store zimbra-mta zimbra-core zimbra-apache zimbra-snmp zimbra-ldap zimbra-spell
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    Enabling zimbra-store
    Enabling zimbra-mta
    Enabling zimbra-snmp
    Enabling zimbra-logger
    Enabling zimbra-apache
    Enabling zimbra-spell
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
            MX: mail.appsescrow.com (192.168.1.25)
    
            Interface: 192.168.1.25
            Interface: 127.0.0.1
    done.
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    Checking for port conflicts
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-logger
    zimbra-logger is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    
    
    Note
    
    The previous configuration appears to have failed to complete
    
    Saving config in /opt/zimbra/config.4658...
    done.
    Operations logged to /tmp/zmsetup.02152008-104924.log
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    ldap_master_url=ldap://mail.appsescrow.com:389
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 163.
    failed. (28416)
    
    
    ERROR
    
    
    
    Configuration failed
    
    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.
    
    Errors have been logged to /tmp/zmsetup.02152008-104924.log

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  2. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  5. Replies: 4
    Last Post: 11-15-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •