Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] RHEL 4 ES /usr/lib/libstdc++.so.5 missing

  1. #1
    alexz is offline Active Member
    Join Date
    Oct 2005
    Posts
    46
    Rep Power
    9

    Unhappy [SOLVED] RHEL 4 ES /usr/lib/libstdc++.so.5 missing

    I tried doing a search but found this issue to be with FC4.

    I'm using RHEL 4. I did all the updates (RHN) except the Kernel. When I try to install Zimbra it bombs out the point below. Essentially, I have /usr/lib/libstdc++.so.6 installed but Zimbra requires so.5. Is there a way around this? I called Red Hat and they told me that so.5 is an ES 3 package.


    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.7p5-30.1
    sudo-1.6.7p5-30.1.3
    libidn...FOUND libidn-0.5.6-1
    curl...FOUND curl-7.12.1-3
    curl-7.12.1-8
    fetchmail...FOUND fetchmail-6.2.5-6
    fetchmail-6.2.5-6
    gmp...FOUND gmp-4.1.4-3
    /usr/lib/libstdc++.so.5...MISSING
    Sincerely,

    Alex

  2. #2
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default missing package

    [root@build ~]# rpm -qf !$
    rpm -qf /usr/lib/libstdc++.so.5
    compat-libstdc++-33-3.2.3-47.3


    Install the compat-libstdc++-33 package.

  3. #3
    alexz is offline Active Member
    Join Date
    Oct 2005
    Posts
    46
    Rep Power
    9

    Default

    Thanks, Marc. That was great! I logged into RHN and found the file:
    compat-libstdc++-33-3.2.3-47.3.i386.rpm

    I downloaded and installed it on the Red Hat box and got past the error!

    AZ
    Sincerely,

    Alex

  4. #4
    jeg1972 is offline Active Member
    Join Date
    Jan 2006
    Location
    UK
    Posts
    37
    Rep Power
    9

    Default

    libstdc++.so.5 is also missing on Fedora Core 4, but using installing using Yum sorts this out.

  5. #5
    bakurih is offline Starter Member
    Join Date
    Feb 2006
    Posts
    1
    Rep Power
    9

    Default

    Fedora FC4:

    #yum install compat-libstdc++-33


  6. #6
    gaspode is offline Member
    Join Date
    Sep 2006
    Posts
    12
    Rep Power
    8

    Default

    If running the 64-bit version of RHEL 4 I also get the following even after installing compat-libstdc++-33 while trying to install 4.0.5 RC2:

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.7p5-30.1.3
    libidn...FOUND libidn-0.5.6-1
    curl...FOUND curl-7.12.1-8
    fetchmail...FOUND fetchmail-6.2.5-6
    gmp...FOUND gmp-4.1.4-3
    compat-libstdc++-296...FOUND compat-libstdc++-296-2.96-132.7.2
    compat-libstdc++-33...FOUND compat-libstdc++-33-3.2.3-47.3
    /usr/lib/libstdc++.so.5...MISSING
    /usr/lib64/libstdc++.so.5...FOUND

    I assume it is a bug, things seems to work if I create a symbolic link from /usr/lib64/libstdc++.so.5 to /usr/lib/libstdc++.so.5

  7. #7
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    9

    Default

    Symlinking 64bit library to the 32bit file is wrong thing to do. You'll need to install the 32bit version of the library, that's why it's called a prerequisite.

  8. #8
    jiekjoke is offline New Member
    Join Date
    Jun 2007
    Location
    I live at Bali
    Posts
    4
    Rep Power
    7

    Default JiekJoek

    Dear Marc,

    I already download and install the file:
    compat-libstdc++-33-3.2.3-47.3.i386.rpm
    but I still got a poblem with the installation, when I try to install i found the error message :
    compat-libstdc++-296...MISSING
    Can assist me with this problem...??
    Many Thanks

  9. #9
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Welcome to the forums,
    '296' (which it says your missing) is a separate package than '33', you need to download & install it as well.
    Last edited by mmorse; 06-21-2007 at 12:11 AM.

  10. #10
    scalper is offline Partner (VAR/HSP)
    Join Date
    Jul 2006
    Location
    KL, Malaysia
    Posts
    123
    Rep Power
    8

    Default

    i know it's an old thread... just in case somebody would find this helpful..

    for centos or yum'ed rhel...

    just run 'yum -y install compat-libstdc++*'

    all the related packages will be installed and zimbra installer will fly free as a bird! cheers..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Xen Debian Etch libgmp3...MISSING libxml2...MISSING
    By unclecameron in forum Installation
    Replies: 6
    Last Post: 07-29-2008, 12:37 PM
  2. Missing blobs - from id to file location?
    By stateless in forum Administrators
    Replies: 1
    Last Post: 04-23-2007, 06:15 PM
  3. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 11:13 AM
  4. Missing Prerequisites on Debian
    By WD_40 in forum Installation
    Replies: 2
    Last Post: 01-16-2007, 09:38 AM
  5. Replies: 0
    Last Post: 04-14-2006, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •