Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: General Config questions

  1. #21
    neocrypter is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    Ok, somewhere there's a config disconnect.

    ps auxww | grep slapd - what's returned?

    zmprov gas - what's returned?

    zmhostname - what's returned?

    ok here is what I get


    Code:
    [root@mail Neocrypter]# ps auxww | grep slapd
    zimbra    2052  0.0  0.6  12040  3320 ?        Ssl  14:11   0:00 /opt/zimbra/openldap/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldaps:// ldap://:389/ -f /opt/zimbra/conf/slapd.conf
    root      2661  0.0  0.1   3764   692 pts/2    S+   14:15   0:00 grep slapd
    
    [zimbra@mail Neocrypter]$ zmprov gas
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.C               ommunicationException kckanar.com:389)
    
    
    [zimbra@mail Neocrypter]$ zmhostname
    kckanar.com

  2. #22
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default Dns

    looks like you can't resolve the name of your ldap host (kcanar.com).

    what does
    host kcanar.com return?

    Is that an IP on your server?

    Is it accessible on port 389?

    Is your firewall running?

  3. #23
    neocrypter is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    looks like you can't resolve the name of your ldap host (kcanar.com).

    what does
    host kcanar.com return?

    Is that an IP on your server?

    Is it accessible on port 389?

    Is your firewall running?
    kckanar.com points to a diffrent network at the moment, is that where my problem lies? no firewall on this box and because of all the difficulties I was haveing I temporarly set it up as DMZ, the way im tryiing to set this up is I have my website hosted on one network, and hosting the mail server on an other, I know its not the best way to do things but its my only option at this moment.

  4. #24
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default problem

    Yes - setting your LDAP HOST to a hostname that resolves to A DIFFERENT BOX is definitely going to be a problem.

    When you get that fixed, you should reinstall.

  5. #25
    neocrypter is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default

    would it just be better to set the ldap to local host?

  6. #26
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default nope

    probably not, since your box can't resolve it's own hostname correctly.

    WHich has been covered elsewhere in the forums.

  7. #27
    neocrypter is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default

    Ok I am up and running, but when I go to the admin section via 7071 it just gives me a blank grey screen
    Last edited by neocrypter; 01-31-2006 at 04:43 PM.

  8. #28
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default Search The Forums

    Neo - the answer to your question is in the forums. Please search for it.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. Replies: 13
    Last Post: 05-15-2007, 06:41 AM
  3. Zimbra not listening on port 7071
    By carllerche in forum Installation
    Replies: 10
    Last Post: 04-03-2007, 09:23 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. M2 -> M3 upgrade
    By gutzeit in forum Installation
    Replies: 26
    Last Post: 01-12-2006, 10:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •