Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [SOLVED] Just upgraded to 5.0.1 from 4.5.10 - Multiple Problems

  1. #1
    ray.perea is offline Member
    Join Date
    Jan 2008
    Posts
    14
    Rep Power
    7

    Thumbs down [SOLVED] Just upgraded to 5.0.1 from 4.5.10 - Multiple Problems

    I just upgraded to 5.0.1 from 4.5.10 and I am having multiple problems.
    Not sure how to fix them....

    First Problem....
    Mail wouldn't work at all. It would just hang on the MAIL FROM: command when testing from telnet. I got that fixed by regenerating a self signed certificate, by searching these forums.

    Second Problem....
    The admin interface, I try to go to "Servers" -> 'My Server' And I get an error:
    message: this._toolbar has no properties fileName: https://zimbra.mysite.com:7071/servi..._zimbra_hsm.js lineNumber: 355 stack: ([object Object])@https://zimbra.mysite.com:7071/service/zimlet/com_zimbra_hsm/com_zimbra_hsm.js:355 call([object Object],[object Object])@:0...

    Third Problem.....
    The admin interface, I try to go to "Mail Queues" and I get:
    Message: system failure: exception during auth {RemoteManager: zimbra.mysite.com->zimbra@zimbra.mysite.com:22} Error code: service.FAILURE Method: GetMailQueueInfoRequest Details:soap:Receiver

    Fourth Problem...
    When I go to certificates and click on the certificate that is there, I get:
    Message: system failure: exception during auth {RemoteManager: zimbra.mysite.com->zimbra@zimbra.mysite.com:22} Error code: service.FAILURE Method: GetCertRequest Details:soap:Receiver

    Fifth Problem...
    When I go to certificates and click "Install Certificate", choosing any of the options and clicking next generates the following error:
    Message: system failure: exception during auth {RemoteManager: zimbra.mysite.com->zimbra@zimbra.mysite.com:22} Error code: service.FAILURE Method: GetCSRRequest Details:soap:Receiver

    Sixth Problem.....
    I have a user who is periodically unable to receive mail. (I changed the domain name to theirdomain.com for privacy reasons)
    When I tail the mailbox.log file I get the following whenever someone tries to send to an email to him. Also, when he tries to send an email from the webmail interface, he gets the same message about "number of deletes (54) exceeds max doc (2) for segment _285w". The only way to fix it is to restart zimbra (zmcontrol stop; zmcontrol start; ) And it works for a while, but it comes back after a couple of hours.
    2008-01-15 15:25:17,247 INFO [LmtpServer-264] [name=pvigil@theirdomain.com;mid=23;] lmtp - try again for message pvigil@theirdomain.com: exception occurred
    java.lang.IllegalStateException: number of deletes (54) exceeds max doc (2) for segment _285w
    at org.apache.lucene.index.SegmentReader.initialize(S egmentReader.java:175)
    at org.apache.lucene.index.SegmentReader.get(SegmentR eader.java:140)
    at org.apache.lucene.index.SegmentReader.get(SegmentR eader.java:121)
    at org.apache.lucene.index.IndexWriter.maybeApplyDele tes(IndexWriter.java:1665)
    at org.apache.lucene.index.IndexWriter.mergeSegments( IndexWriter.java:1521)
    at org.apache.lucene.index.IndexWriter.flushRamSegmen ts(IndexWriter.java:1351)
    at org.apache.lucene.index.IndexWriter.maybeFlushRamS egments(IndexWriter.java:1344)
    at org.apache.lucene.index.IndexWriter.addDocument(In dexWriter.java:697)
    at org.apache.lucene.index.IndexWriter.addDocument(In dexWriter.java:680)
    at com.zimbra.cs.index.LuceneIndex.addDocument(Lucene Index.java:225)
    at com.zimbra.cs.index.MailboxIndex.indexMessage(Mail boxIndex.java:557)
    at com.zimbra.cs.mailbox.Message.reindex(Message.java :521)
    at com.zimbra.cs.mailbox.Mailbox.endTransaction(Mailb ox.java:5716)
    at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(M ailbox.java:4047)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:3750)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:3710)
    at com.zimbra.cs.filter.ZimbraMailAdapter.addMessage( ZimbraMailAdapter.java:348)
    at com.zimbra.cs.filter.ZimbraMailAdapter.executeActi ons(ZimbraMailAdapter.java:253)
    at org.apache.jsieve.SieveFactory.evaluate(SieveFacto ry.java:159)
    at com.zimbra.cs.filter.RuleManager.applyRules(RuleMa nager.java:185)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:446 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:140)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processMessag eData(LmtpHandler.java:375)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.continueDA TA(TcpLmtpHandler.java:67)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:364)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:174)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.processCom mand(TcpLmtpHandler.java:61)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:160)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:128)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:619)
    Last edited by ray.perea; 01-15-2008 at 04:15 PM.

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Welcome to the forums,
    2) See if this solution works for you:
    su - zimbra
    zmcontrol stop
    rm -rf /opt/zimbra/jetty/work/*
    zmcontrol start
    (& clear your browser cache before visiting admin console)

    ----

    3-5) Try this:
    a. Check /etc/sshd_config and be sure it's set to 22
    Code:
    port 22
    b. stop/start/restart sshd
    Code:
    /etc/init.d/ssh restart
    c. su - zimbra
    d. Be sure zimbra's ssh port is set to 22
    Code:
    zmprov ms server.domain.com zimbraRemoteManagementPort 22
    e. Generate new ssh keys
    Code:
    cd /opt/zimbra/bin/
    ./zmsshkeygen
    f. Deploy the keys
    Code:
    ./zmupdateauthkeys
    To test this, you can run the following command:
    Code:
    ssh -i .ssh/zimbra_identity -o strictHostKeyChecking=no zimbra@server.domain.com -p 22
    -Shouldn't prompt you for a password at this point...then check the admin console mail queues area.
    If you continue to get that error please see this doc for some more ideas Mail Queue Monitoring - Zimbra :: Wiki

  3. #3
    ray.perea is offline Member
    Join Date
    Jan 2008
    Posts
    14
    Rep Power
    7

    Default

    When I run the command:
    zmprov ms server.domain.com zimbraRemoteManagementPort 22
    I get:
    Code:
    ERROR: service.INVALID_REQUEST (invalid request: port 993 conflict between zimbraImapSSLBindPort and zimbraImapSSLProxyBindPort on server server.domain.com)
    I even tried to change the port in sshd to a different port other than 22 and then tried to set the zimbraRemoteManagementPort to that modified port and got the same error.... No idea why port 993 is conflicting with anything....
    Please advise.

  4. #4
    ray.perea is offline Member
    Join Date
    Jan 2008
    Posts
    14
    Rep Power
    7

    Default

    OK, I seemed to have fixed the problem (at least with the server / mail queue / certificates admin console problems)

    I ran the following commands
    Code:
    su zimbra;
    
    zmperditionctl stop;
    
    zmprov ms server.domain.com -zimbraServiceEnabled imapproxy;
    
    zmprov ms vmail.vsourceweb.com zimbraPop3BindPort 110 zimbraImapBindPort 143 zimbraPop3SSLBindPort 995 zimbraImapSSLBindPort 993 zimbraPop3ProxyBindPort 111 zimbraImapProxyBindPort 144 zimbraPop3SSLProxyBindPort 996 zimbraImapSSLProxyBindPort 994;
    
    zmcontrol stop; zmcontrol start;
    
    cd /opt/zimbra/bin/;
    
    ./zmsshkeygen;
    
    ./zmupdateauthkeys;
    
    cd;
    
    ssh -i .ssh/zimbra_identity -o strictHostKeyChecking=no zimbra@server.domain.com -p 22;
    It still didn't work at this point... So I checked the .ssh folder (/opt/zimbra/.ssh) and modified the authorized_keys file. Since I regenerated the keys, there were 2 keys in the authorized keys file. So I took out the old key and tried it again.... Still didn't work....

    Then I noticed that the key that I still had in the authorized_keys file started with a "command=" So I decided to simply take the pub file and regenerate the authorized_keys file.
    Code:
    cd; echo '' > .ssh/authorized_keys; cat .ssh/zimbra_identity.pub > .ssh/authorized_keys; chmod 700 .ssh; chmod 600 .ssh/authorized_keys;
    Now I tried my command again.
    Code:
    ssh -i .ssh/zimbra_identity -o strictHostKeyChecking=no zimbra@server.domain.com -p 22;
    And I got a command prompt without a password prompt. I then tried my mailqueue, server, certificate functions again in the admin panel and all is good again.
    NOTE: All these commands were run as zimbra
    Last edited by ray.perea; 01-16-2008 at 06:15 AM.

  5. #5
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

  6. #6
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    If so, you might try re-indexing the account in question as a first step.

    http://www.zimbra.com/forums/announc...r-profile.html

  7. #7
    ray.perea is offline Member
    Join Date
    Jan 2008
    Posts
    14
    Rep Power
    7

    Default

    Yes, number 6 is still an issue. And only with the same account. I thought it was fixed but about 6 hours into the day, it happened again.....
    I am going to try re-indexing and let you know if that solves the issue.

  8. #8
    ray.perea is offline Member
    Join Date
    Jan 2008
    Posts
    14
    Rep Power
    7

    Default

    Alright, I reindexed the account. Time will tell if it works.

  9. #9
    ray.perea is offline Member
    Join Date
    Jan 2008
    Posts
    14
    Rep Power
    7

    Default

    Since reindexing, I haven't had any more problems. Actually, the same thing has happened to a couple other accounts and reindexing has fixed it. So, over the course of a couple of days, I have re-indexed all the accounts and haven't had the problem again.

    My question is this: Is there a way to script re-indexing accounts. I took a look at the wiki and found a command line option for reindexing an account, but I couldn't figure out how to use it...

    zmprov rim ???

    Can someone provide an example of how to use this command line utility?

  10. #10
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    The older method was a script in this thread.
    The newer much safer method after Bug 15348 - zmprov should be able to control reindexing from the command line is:
    zmprov reIndexMailbox(rim) {name@domain|id} {action} [{reindex-by} {value1} [value2...]]
    So like:
    zmprov rim user@domain.com start
    zmprov rim user@domain.com status

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem to upgrade 4.5.10 to 5.0.1
    By aguerrave in forum Installation
    Replies: 2
    Last Post: 01-15-2008, 06:08 AM
  2. Replies: 10
    Last Post: 12-10-2007, 02:35 AM
  3. Chartset problems still remains in 4.5.10
    By chinpero in forum Administrators
    Replies: 3
    Last Post: 11-25-2007, 09:44 AM
  4. Installation on FC3 under Xen
    By andreground in forum Installation
    Replies: 9
    Last Post: 11-14-2005, 10:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •