Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: /var/log/zimbra.log is empty: why?

  1. #1
    Dude's Avatar
    Dude is offline Member
    Join Date
    Jan 2006
    Posts
    13
    Rep Power
    9

    Default /var/log/zimbra.log is empty: why?

    I installed the zimbra development version 3.0/M3 for Suse10

    All went well, no errors in zmsetup.log.
    Zimbra service Mysql/postfix etc running.
    Zimbra admin is running on port 7071, the client op port 7070

    So far so good.

    My problem: I can see messages arriving in /opt/zimbra/store but
    they are not visible in my client.

    I checked the /var/log/zimbra.log but it stays empty.
    Any reason why, it doesn't help me debugging!
    regards

    Hans

  2. #2
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default syslog.conf

    syslog.conf may be incorrectly configured. /var/log/maillog will probably have postfix logs

  3. #3
    Dude's Avatar
    Dude is offline Member
    Join Date
    Jan 2006
    Posts
    13
    Rep Power
    9

    Question This the current content of syslogd.conf is it ok?

    Quote Originally Posted by marcmac
    syslog.conf may be incorrectly configured. /var/log/maillog will probably have postfix logs
    So back home again, time to check the settings:

    This the current content of /etc/syslog.conf:
    local0.* -/var/log/zimbra.log
    mail.* -/var/log/zimbra.log

    This looks like the default from zimbra, is it complete?
    Last edited by Dude; 01-19-2006 at 11:46 AM.
    regards

    Hans

  4. #4
    Dude's Avatar
    Dude is offline Member
    Join Date
    Jan 2006
    Posts
    13
    Rep Power
    9

    Talking Zimbra is sending and receiving mail but /var/log/zimbra.log is still empty

    OK, receiving mail problem resolved.

    Setting the dns check off worked.

    But the zimbra messages get scattered around
    /var/log/mail /var/log/messages etc

    See my post about my syslog.conf: what is wrong?
    Last edited by Dude; 01-19-2006 at 12:50 PM.
    regards

    Hans

  5. #5
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default syslog

    Have you tried restarting syslogd? Does /var/log/zimbra.log exist? Have you read the syslog man page?

  6. #6
    Dude's Avatar
    Dude is offline Member
    Join Date
    Jan 2006
    Posts
    13
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    Have you tried restarting syslogd? Does /var/log/zimbra.log exist? Have you read the syslog man page?
    1. Executed once more:
    /etc/init.d/syslog restart:

    2. zmcontrol stop and then start

    3. ls -la /var/log/zimbra.log:
    -rw-r--r-- 1 zimbra zimbra 0 Jan 19 06:20 /var/log/zimbra.log

    Still no entries.
    I was hoping to skip the manpage step.
    But if it is needed, is this Suse 10 related or just a config issue?
    regards

    Hans

  7. #7
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default sylog client

    my box (not suse) has the logger command:

    logger -p mail.err "test message"
    will syslog a message at the mail.err level.

    Could be a suse issue - try dropping the '-' before the filenames in syslog.conf - could be they don't support async syslog (which would be sub-optimal, imho)

  8. #8
    Dude's Avatar
    Dude is offline Member
    Join Date
    Jan 2006
    Posts
    13
    Rep Power
    9

    Default logger util works, removing the dash not

    Puzzling:

    1. logger -p mail.err "test"
    Works! message shows up in the /var/log/mail.err

    2. logger -p zimbra.log "test message"
    Results in the message
    logger: unknown facility name: zimbra.

    **Edit**
    Found the source of the problem:
    syslog.conf is not used at all!
    syslog-ng is installed by default

    Will do a manual study and come back or switch to syslog

    thx for the suggestions!
    Last edited by Dude; 01-19-2006 at 01:10 PM.
    regards

    Hans

  9. #9
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default syslog facilities

    zimbra isn't a legal facility. We log under two facilities: mail, and LOCAL0.

    Is zimbra running? Does anything show up in /var/log/maillog, postfix related? Could just be local0 that's choking.

  10. #10
    Dude's Avatar
    Dude is offline Member
    Join Date
    Jan 2006
    Posts
    13
    Rep Power
    9

    Default My solution for using syslog-ng

    For those who will encounter this problem, this what I have changed to get logging in zimbra.log for syslog-ng (used a.o. in SuSe 10):

    1. edit /etc/syslog-ng/syslog-ng.conf
    2. change the following line:
    Code:
    destination mail { file("/var/log/zimbra.log"); };
        log { source(src); filter(f_mail); destination(mail); };
    3. Add these lines at the bottom:
    Code:
    # Zimbra
    destination local0 { file("/var/log/zimbra.log"); };
    log { source(src); destination(local0); };
    Note: could be that I have to do some fine-tuning but it works for now
    Last edited by Dude; 01-19-2006 at 01:57 PM. Reason: wrong file mentioned!
    regards

    Hans

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Disable Empty Trash?
    By jdanda in forum Users
    Replies: 2
    Last Post: 07-20-2007, 04:47 AM
  2. saved search folders empty via imap
    By tyco in forum Administrators
    Replies: 1
    Last Post: 05-20-2007, 08:27 PM
  3. Replies: 8
    Last Post: 04-29-2007, 07:05 PM
  4. /var/log/zimbra.log is empty
    By Dirk in forum Installation
    Replies: 3
    Last Post: 07-20-2006, 05:45 AM
  5. Empty trash confirmation in GA
    By meikka in forum I18N/L10N - Translations
    Replies: 6
    Last Post: 02-23-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •