Results 1 to 2 of 2

Thread: MySQL doesn't start during Upgrade

  1. #1
    Metha is offline Starter Member
    Join Date
    Jan 2008
    Posts
    2
    Rep Power
    7

    Default MySQL doesn't start during Upgrade


    Hi,

    I was Upgrading Zimbra from 4.5.6_GA_1044 to 4.5.10_GA_1575 and in the beggining the installation script worked fine... here it is:


    ...
    Removing deployed webapp directories
    Installing packages

    zimbra-core......zimbra-core_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done
    zimbra-ldap......zimbra-ldap_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done
    zimbra-logger......zimbra-logger_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done
    zimbra-mta......zimbra-mta_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done
    zimbra-snmp......zimbra-snmp_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done
    zimbra-store......zimbra-store_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done
    zimbra-apache......zimbra-apache_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done
    zimbra-spell......zimbra-spell_4.5.10_GA_1575.DEBIAN3.1_i386.deb...done

    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    HOSTNAME=zeus.iscbrazil.com
    LDAPHOST=zeus.iscbrazil.com
    LDAPPORT=389
    SNMPTRAPHOST=zeus.iscbrazil.com
    SMTPSOURCE=admin@zeus.iscbrazil.com
    SMTPDEST=admin@zeus.iscbrazil.com
    SNMPNOTIFY=yes
    SMTPNOTIFY=yes
    LDAPROOTPW=zimbra
    LDAPZIMBRAPW=zimbra
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.log.10996
    Checking ldap status
    Starting ldap
    Checking ldap status
    Setting defaults...Done
    Setting defaults from existing config...Upgrading from 4.5.6_GA_1044 to 4.5.10_GA_1575
    Stopping zimbra services
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql
    UPGRADE FAILED - exiting
    then I run

    Code:
    zimbra@zeus:~$ zmcontrol status
    Host zeus.iscbrazil.com
            antispam               Running
            imapproxy              Running
            ldap                      Running
            logger                   Running
            mailbox                 Stopped
                    mysql.server is not running
                    tomcat is not running
            mta                      Running
            snmp                    Running
            spell                     Running
    zimbra@zeus:~$
    
    However, mysql.server is running!!!!
    
    zimbra@zeus:~$ mysql.server status
    mysql is running with pid 12120
    zimbra@zeus:~$ 
    
    But when I try to connet I get this:
    
    zimbra@zeus:~$ mysql
    ERROR 1045 (28000): Access denied for user 'zimbra'@'localhost' (using password: YES)
    zimbra@zeus:~$

    Any Ideia?

  2. #2
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Sounds like your mysql passwords are out of sync. If you attempted the upgrade more then once you need to restore /opt/zimbra/conf/localconfig.xml from backup before proceeding. Search the forums and you'll find many threads covering how to do this.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 02:27 PM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 09:35 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Can't start MySQL to init db - Gentoo
    By fak3r in forum Installation
    Replies: 3
    Last Post: 10-10-2005, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •