Results 1 to 3 of 3

Thread: [SOLVED] Upgrade to zcs-NETWORK-5.0.0_GA_1869.UBUNTU6.20071218190150 gives error

  1. #1
    timwiel is offline Active Member
    Join Date
    Mar 2007
    Posts
    39
    Rep Power
    8

    Default [SOLVED] Upgrade to zcs-NETWORK-5.0.0_GA_1869.UBUNTU6.20071218190150 gives error

    I am upgrading a client running opensource zimbra 4.5 and have rsync'd backed up there existing install like it says on wiki

    The problem is on the upgrade, running the install script works fine then gives the following message then returns to command line (I am logged in as root):
    Code:
    5 is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30,  line 21.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 970,  line 21.
    I have exported the following directives at commandline and installed cpan doing the following:
    Code:
    PERLLIB=/opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi:/opt/zimbra/zimbramon/lib:/opt/zimbra/zimbramon/lib/i386-linux-thread-multi:/opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi:/opt/zimbra/zimbramon/lib/i586-linux-thread-multi:/opt/zimbra/zimbramon/lib/darwin-thread-multi-2level
     export PERLLIB
    PERL5LIB=$PERLLIB
    export PERL5LIB
    
    cpan
    force install Scalar::Util
    I have followed the following threads but since I am running ubuntu not sure they apply fully to me:

    Code:
    http://www.zimbra.com/forums/installation/13918-upgrade-5-0-4-5-9-fails-2.html
    http://www.zimbra.com/forums/installation/13811-centos4-upgrade-5-0-errors.html#post71102
    http://www.bytebot.net/blog/archives/2008/01/04/zimbra-zcs-50-ga-is-it-really-a-ga-release
    http://bugzilla.zimbra.com/show_bug.cgi?id=22466

    Help is required asap thanks

  2. #2
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,276
    Rep Power
    10

    Default

    The issue here was a local installation of Scalar::Util without XS support. Removing the bad local install and using the system Scalar::Util resolved the issue.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    timwiel is offline Active Member
    Join Date
    Mar 2007
    Posts
    39
    Rep Power
    8

    Default

    thanks heaps to you and john for your help with this

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 05:24 AM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-14-2005, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •