Results 1 to 9 of 9

Thread: Installation of 5.0

  1. #1
    bseybolt is offline New Member
    Join Date
    Jan 2008
    Posts
    3
    Rep Power
    7

    Default Installation of 5.0

    I'm trying out Zimbra in a test environment at our offices. We're running it on a Mac OSX (Leopard ) server. Each time I run zmsetup.pl, I get the following:

    Can't load '/opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/IO/IO.bundle' for module IO: dlopen(/opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/IO/IO.bundle, 1): no suitable image found. Did find:
    /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/IO/IO.bundle: mach-o, but wrong architecture at /System/Library/Perl/5.8.8/darwin-thread-multi-2level/XSLoader.pm line 70.
    at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO.pm line 11
    Compilation failed in require at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Handle.pm line 263.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Handle.pm line 263.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Socket.pm line 11.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Socket.pm line 11.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
    Compilation failed in require at ./zmsetup.pl line 22.
    BEGIN failed--compilation aborted at ./zmsetup.pl line 22.


    I've uninstalled and reinstalled the pkg to no avail. Any advice would be welcomed. Thanks.

  2. #2
    Xao
    Xao is offline Active Member
    Join Date
    Nov 2006
    Posts
    31
    Rep Power
    8

    Default

    You might want to make sure you have the perl IO subsystem install....

    Try:

    perl -MCPAN -e shell;
    install IO::ALL

  3. #3
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    The MACOSXx86 build is currently only supports Mac OSX 10.4 (Tiger) only. Sorry no Leopard support yet.

    You can vote for
    Bug 21441 - Requesting Apple-Server (10.5, leopard) support for ZCS
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #4
    bseybolt is offline New Member
    Join Date
    Jan 2008
    Posts
    3
    Rep Power
    7

    Default Rats

    Any ETA on deploying for Leopard?

  5. #5
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    No scheduled release date as of yet.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    bseybolt is offline New Member
    Join Date
    Jan 2008
    Posts
    3
    Rep Power
    7

    Default Now on Tiger

    I grabbed a new workstation in the back running Mac OS X (10.4.11). After installing and running the pkg, I am getting the same error message.

    Can't load '/opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/IO/IO.bundle' for module IO: dlopen(/opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/IO/IO.bundle, 1): no suitable image found. Did find:
    /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/auto/IO/IO.bundle: mach-o, but wrong architecture at /System/Library/Perl/5.8.6/darwin-thread-multi-2level/XSLoader.pm line 68.
    at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO.pm line 11
    Compilation failed in require at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Handle.pm line 263.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Handle.pm line 263.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Socket.pm line 11.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/darwin-thread-multi-2level/IO/Socket.pm line 11.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
    Compilation failed in require at ./zmsetup.pl line 22.
    BEGIN failed--compilation aborted at ./zmsetup.pl line 22.


    I tried the perl subsystem install and run into an issue the make install. Any suggestions?

  7. #7
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Intel vs PPC issue perhaps? What's the architecture of the workstation verses the version of ZCS you installed?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #8
    steven_ganz is offline Starter Member
    Join Date
    Jan 2011
    Posts
    1
    Rep Power
    4

    Default

    Is ZCS OSE available for OS X 10.4 PPC? I only see x86 binaries online.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Quote Originally Posted by steven_ganz View Post
    Is ZCS OSE available for OS X 10.4 PPC?
    No, there's no ppc version available.

    Quote Originally Posted by steven_ganz View Post
    I only see x86 binaries online.
    That's the only supported architecture and platforms on the Downloads page.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Outlook 2007 Beta Overview
    By GregA in forum Zimbra Connector for Outlook
    Replies: 19
    Last Post: 03-03-2008, 04:24 PM
  2. Installation Issues - SLES 10_Zimbra 5.0 Beta 3
    By rhartman in forum Installation
    Replies: 3
    Last Post: 01-14-2008, 07:18 AM
  3. ZCS 5.0 FOSS is Released!!!
    By jholder in forum Announcements
    Replies: 1
    Last Post: 12-21-2007, 12:21 PM
  4. Slow SMTP Requests on distributed Zimbra 5.0 Installation
    By gil.fernandes in forum Installation
    Replies: 2
    Last Post: 12-19-2007, 04:04 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •