Results 1 to 4 of 4

Thread: Jetty Errors with 4.5.9 / 4.5.10

  1. #1
    blakekrone is offline Junior Member
    Join Date
    Dec 2006
    Location
    Chaska, MN
    Posts
    6
    Rep Power
    8

    Default Jetty Errors with 4.5.9 / 4.5.10

    I had my Zimbra server running fine on FC5 for months and over the weekend I lost power. When the system came back up I can no longer get the admin or client pages to load. When I go to the client pages I get the following error:

    Code:
    Error 404 - Not Found.
    No context on this server matched or handled this request.
    Contexts known to this server are:
    
        * /http-bind ---> org.mortbay.jetty.handler.ContextHandler@1b7818b{/http-bind,null}
    When I do a zmcontrol status all services are running. I also tried using 4.5.10 thinking maybe an upgrade would fix whatever was broken, but it did not fix the issue.

    Mail still flows in and I can get it via IMAP clients, I just can't seem to get the webmail portion to work. As far as I can tell I also don't see any errors in the catalina.out log nor do I see any MySQL errors in its log file.

    Any ideas?

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Very Very weird.

    We don't even use Jetty in 4.x. It's only in 5.0

    Can you try doing a software only install?

    ./install.sh -s
    That should overwrite any damaged config files. Please note customized skins and zimlets will be lost.

    Be sure to back those up

  3. #3
    blakekrone is offline Junior Member
    Join Date
    Dec 2006
    Location
    Chaska, MN
    Posts
    6
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    Very Very weird.

    We don't even use Jetty in 4.x. It's only in 5.0

    Can you try doing a software only install?

    ./install.sh -s
    That should overwrite any damaged config files. Please note customized skins and zimlets will be lost.

    Be sure to back those up
    Just gave that a try and the same thing happens. Another odd thing that I found is that now I have two folders under /opt for Zimbra: /opt/zimbra and /opt/zimbra_base

    Did my install get hosed? I have all my calendar/contact data that can easily be put back in, not too worried about email messages, only that I don't want to lose is my Zimbra Documents.

  4. #4
    blakekrone is offline Junior Member
    Join Date
    Dec 2006
    Location
    Chaska, MN
    Posts
    6
    Rep Power
    8

    Default

    well a few reboots and power cycle of my Clark Connect router and no more Jetty errors.

    However, I still have that strange zimbra_base folder along with the zimbra folder, is this normal in the latest versions of Zimbra?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Make jetty bind to a specific ip
    By carnold in forum Administrators
    Replies: 9
    Last Post: 04-23-2008, 05:15 PM
  2. Replies: 5
    Last Post: 12-27-2007, 07:52 AM
  3. Replies: 7
    Last Post: 11-28-2007, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •