Results 1 to 3 of 3

Thread: SMTP authentication problems continue

  1. #1
    EdMartin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Plantation, FL
    Posts
    59
    Rep Power
    7

    Default SMTP authentication problems continue

    ZCS 4.5.9_GA_1454.UBUNTU6 (OS) on Ubuntu 7.10

    I'm still trying to set things up so that authenticated users (that is, users who can log in via the Zimbra web interface without problem) can send emails via the Zimbra mail server using Thunderbird or Outlook from an outside-the-network location to an outside-the-network address.

    On the Zimbra Web Admin I have the following settings:

    Servers | mail.imacs.org | MTA
    X Enable authentication
    X TLS authentication only

    Servers | mail.imacs.org | IMAP
    X Enable IMAP service; IMAP port number: 143
    X Enable SSL for IMAP service; IMAP SSL port number: 993
    [Unchecked] Enable clear test login

    Global Settings | MTA
    X Enable authentication
    X TLS authentication only

    Protocol checks:
    X Hostname in greeting violates RFC
    [Unchecked] Client must greet with a fully qualified hostname
    X Sender address must be fully qualified

    Global Settings | IMAP
    X Enable IMAP service
    X Enable SSL for IMAP service

    Following the advice at SMTP Auth Problems - Zimbra :: Wiki produces the following results:

    $ zmprov gs mail.imacs.org | grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: mail.imacs.org
    zimbraMtaAuthURL: http://mail.imacs.org/service/soap/
    zimbraMtaTlsAuthOnly: TRUE

    $ zmprov gs mail.imacs.org | grep Mode
    zimbraMailMode: http

    With Thunderbird configured for an IMAP connection to the Zimbra server using TLS for both incoming mail and SMTP outgoing, Thunderbird generates the following error message:

    An error occurred sending mail: Unable to connect to SMTP server mail.imacs.org via STARTTLS since it doesn't offer STARTTLS In EHLO response. Please verify that your Mail/News account settings are correct and try again.

    and this is what appears in zimbra.log:

    Nov 25 13:44:25 mail postfix/smtpd[31318]: warning: cannot get certificate from file /opt/zimbra/conf/smtpd.crt
    Nov 25 13:44:25 mail postfix/smtpd[31318]: warning: TLS library problem: 31318:error:02001002:system library:fopen:No such file or directory:bss_file.c:352:fopen('/opt/zimbra/conf/smtpd.crt','r'):
    Nov 25 13:44:25 mail postfix/smtpd[31318]: warning: TLS library problem: 31318:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:354:
    Nov 25 13:44:25 mail postfix/smtpd[31318]: warning: TLS library problem: 31318:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:720:
    Nov 25 13:44:25 mail postfix/smtpd[31318]: cannot load RSA certificate and key data
    Nov 25 13:44:25 mail postfix/smtpd[31318]: connect from c-65-34-211-65.hsd1.fl.comcast.net[65.34.211.65]
    Nov 25 13:44:26 mail postfix/smtpd[31318]: disconnect from c-65-34-211-65.hsd1.fl.comcast.net[65.34.211.65]

    Note that, sure enough, there is NO smtpd.crt in /opt/zimbra/conf. Is that the key to the problem? How do I rectify the situation?

    With Thunderbird set for SSL for both incoming and outgoing, it generates the following error message:

    The message could not be sent because connecting to SMTP server mail.imacs.org failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server setting is correct and try again, or else contact your network administrator.

    and this is what appears in zimbra.log:

    Nov 25 13:35:03 mail postfix/smtpd[29818]: connect from c-65-34-211-65.hsd1.fl.comcast.net[65.34.211.65]
    Nov 25 13:35:03 mail postfix/smtpd[29818]: setting up TLS connection from c-65-34-211-65.hsd1.fl.comcast.net[65.34.211.65]
    Nov 25 13:35:03 mail postfix/smtpd[29818]: Could not allocate 'TLScontext->con' with SSL_new()
    Nov 25 13:35:03 mail postfix/smtpd[29818]: warning: TLS library problem: 29818:error:140BA0C3:SSL routines:SSL_new:null ssl ctx:ssl_lib.c:244:
    Nov 25 13:35:03 mail postfix/smtpd[29818]: lost connection after CONNECT from c-65-34-211-65.hsd1.fl.comcast.net[65.34.211.65]
    Nov 25 13:35:03 mail postfix/smtpd[29818]: disconnect from c-65-34-211-65.hsd1.fl.comcast.net[65.34.211.65]

    Any advice would be most welcome. I really must get this working very soon. (So much else to do ... so little time!)

    Thanks in advance.

  2. #2
    uscell's Avatar
    uscell is offline Senior Member
    Join Date
    Nov 2007
    Location
    INDIA
    Posts
    65
    Rep Power
    7

    Default

    check with clear text password..

    THanks,
    Yukari !!!
    Yukari !!!!
    +91 982 503 9118
    -----------------------------
    Release 6.0.2_GA_1912.RHEL5_64_20091020161509RHEL5_64 FOSS edition.

  3. #3
    firefox32 is offline Junior Member
    Join Date
    Nov 2007
    Posts
    7
    Rep Power
    7

    Default

    Hi at all.
    i've got the same problem in the same configuration of
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthURL: http://****/service/soap/
    zimbraMtaTlsAuthOnly: TRUE
    zimbraMailMode: http
    And i'm not able to send email outside of the lan (from my pda with 3g connection for example).
    Any suggestion?
    because of i do not understand uscell answer
    tnx in advance

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 06-18-2010, 09:41 AM
  2. SMTP Authentication
    By ferra in forum Installation
    Replies: 13
    Last Post: 06-26-2008, 07:25 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Replies: 2
    Last Post: 10-10-2006, 12:45 AM
  5. SMTP SASL authentication failure
    By igeorg in forum Developers
    Replies: 5
    Last Post: 10-10-2005, 01:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •