Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] Install Fails on CentOS 4.5

  1. #1
    hspcd is offline Loyal Member
    Join Date
    Nov 2007
    Location
    HSP NC
    Posts
    77
    Rep Power
    7

    Default [SOLVED] Install Fails on CentOS 4.5

    When trying to install the latest ZCS I get the following error in the install log. I've tried it on CentOS 5 too and get the same failure associated with LDAP.


    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    FAILED (1)


    ERROR



    Configuration failed

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Welcome to the forums.

    Do you have a correct /etc/hosts file and DNS A & MX records pointing to the Zimbra server? You'll need all of those correct to install Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    hspcd is offline Loyal Member
    Join Date
    Nov 2007
    Location
    HSP NC
    Posts
    77
    Rep Power
    7

    Default

    I believe that the DNS information is correct. The ZCS installer doesn't complain about it and lookups work properly. Here's the error message:

    Initializing ldap...Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://mail1.rpszimbra.com:389

    FAILED (1)


    ERROR


    I don't have any other daemon listening on 389.

    Thank you!

    Clayton Dillard

  4. #4
    hspcd is offline Loyal Member
    Join Date
    Nov 2007
    Location
    HSP NC
    Posts
    77
    Rep Power
    7

    Default

    Here is the install log:
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    Enabling zimbra-store
    Enabling zimbra-mta
    Enabling zimbra-snmp
    Enabling zimbra-logger
    Enabling zimbra-apache
    Enabling zimbra-spell
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java'
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    MX: zimbra1.rpszimbra.com (1.2.3.4)

    Interface: 1.2.3.4
    Interface: 127.0.0.1
    Done
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    Checking for port conflicts
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-logger
    zimbra-logger is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    Global config attribute retrieved from ldap: zimbraSpamIsSpamAccount=
    Global config attribute retrieved from ldap: zimbraSpamIsNotSpamAccount=
    Global config attribute retrieved from ldap: zimbraNotebookAccount=
    *** Running as zimbra user: zmlicense -c
    Error: exception occurred: system failure: getDirectContext
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-snmp
    zimbra-snmp is enabled
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    *** Running as zimbra user: zmlicense -c
    Error: exception occurred: system failure: getDirectContext
    checking isEnabled zimbra-store
    zimbra-store is enabled
    *** Running as zimbra user: zmlicense -c
    Error: exception occurred: system failure: getDirectContext
    checking isEnabled zimbra-store
    zimbra-store is enabled
    *** Running as zimbra user: zmlicense -c
    Error: exception occurred: system failure: getDirectContext
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-snmp
    zimbra-snmp is enabled
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    Saving config in /opt/zimbra/config.3416...
    Done
    Operations logged to /tmp/zmsetup.log.3416
    Setting local config values...
    Setting local config zimbra_server_hostname to mail1.rpszimbra.com
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_server_hostname='mail1.rpszimbra.com'
    Setting local config ldap_master_url to ldap://mail1.rpszimbra.com:389
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_master_url='ldap://mail1.rpszimbra.com:389'
    Setting local config ldap_url to ldap://mail1.rpszimbra.com:389
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_url='ldap://mail1.rpszimbra.com:389'
    Setting local config ldap_port to 389
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_port='389'
    Setting local config ldap_host to mail1.rpszimbra.com
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_host='mail1.rpszimbra.com'
    Setting local config zimbra_uid to 500
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_uid='500'
    Setting local config zimbra_gid to 500
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_gid='500'
    Setting local config zimbra_user to zimbra
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_user='zimbra'
    Setting local config tomcat_truststore_password to changeit
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e tomcat_truststore_password='changeit'
    Setting local config tomcat_keystore_password to 5h_zhJJN
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e tomcat_keystore_password='5h_zhJJN'
    Setting local config av_notify_user to admin@mail1.rpszimbra.com
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e av_notify_user='admin@mail1.rpszimbra.com'
    Setting local config ssl_allow_untrusted_certs to TRUE
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs='TRUE'
    Setting local config mysql_memory_percent to 30
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e mysql_memory_percent='30'
    Setting local config tomcat_java_heap_memory_percent to 40
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e tomcat_java_heap_memory_percent='40'
    Done
    Setting up CA...
    *** Running as zimbra user: cd /opt/zimbra; zmcreateca
    ** Creating CA private key

    Generating a 1024 bit RSA private key
    ..++++++
    .............++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'
    -----
    ** Creating CA cert

    Signature ok
    subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    Getting Private key
    unable to write 'random state'
    Done
    Creating SSL certificate...
    checking isEnabled zimbra-store
    zimbra-store is enabled
    *** Running as zimbra user: cd /opt/zimbra; zmcreatecert
    ** Importing CA

    Certificate was added to keystore
    ** Creating keystore

    ** Creating server cert request

    Generating a 1024 bit RSA private key
    ........................++++++
    ...................................++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/server/server.key'
    -----
    ** Signing cert request

    Using configuration from /opt/zimbra/ssl/ssl/zmssl.cnf
    Check that the request matches the signature
    Signature ok
    Certificate Details:
    Serial Number:
    11:94:97:31:04
    Validity
    Not Before: Nov 13 16:58:26 2007 GMT
    Not After : Nov 12 16:58:26 2008 GMT
    Subject:
    countryName = US
    stateOrProvinceName = N/A
    organizationName = Zimbra Collaboration Suite
    commonName = mail1.rpszimbra.com
    X509v3 extensions:
    X509v3 Basic Constraints:
    CA:FALSE
    Netscape Comment:
    OpenSSL Generated Certificate
    X509v3 Subject Key Identifier:
    7F:0E:94:58:92:AF:23:F1:62:F7:2A:0E:13:F9:64:39:9E :A1:1A:EE
    X509v3 Authority Key Identifier:
    DirName:/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    serial:00

    X509v3 Key Usage:
    Digital Signature, Non Repudiation, Key Encipherment
    Certificate is to be certified until Nov 12 16:58:26 2008 GMT (365 days)

    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=mail1.rpszimbra.com
    Getting CA Private Key
    unable to write 'random state'
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    *** Running as zimbra user: cd /opt/zimbra; zmcreatecert
    ** Importing CA

    Certificate was added to keystore
    ** Creating keystore

    ** Creating server cert request

    Generating a 1024 bit RSA private key
    .++++++
    ........++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/server/server.key'
    -----
    ** Signing cert request

    Using configuration from /opt/zimbra/ssl/ssl/zmssl.cnf
    Check that the request matches the signature
    Signature ok
    Certificate Details:
    Serial Number:
    11:94:97:31:07
    Validity
    Not Before: Nov 13 16:58:28 2007 GMT
    Not After : Nov 12 16:58:28 2008 GMT
    Subject:
    countryName = US
    stateOrProvinceName = N/A
    organizationName = Zimbra Collaboration Suite
    commonName = mail1.rpszimbra.com
    X509v3 extensions:
    X509v3 Basic Constraints:
    CA:FALSE
    Netscape Comment:
    OpenSSL Generated Certificate
    X509v3 Subject Key Identifier:
    D1:41:60:75:68:0D:AD:9C:55:ED:48:A1:0D:5F:63:93:B6 :119:FD
    X509v3 Authority Key Identifier:
    DirName:/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    serial:00

    X509v3 Key Usage:
    Digital Signature, Non Repudiation, Key Encipherment
    Certificate is to be certified until Nov 12 16:58:28 2008 GMT (365 days)

    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=mail1.rpszimbra.com
    Getting CA Private Key
    unable to write 'random state'
    Done
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    FAILED (1)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Errors have been logged to /tmp/zmsetup.log.3416

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    You either have something listening on port 389 or there's a problem with your DNS. First make sure you have disable the firewall, SElinux and ipv6 on the server. Next, do the following and post the output:

    Code:
    host `hostname`  <-- type as-is with backticks not single quotes
    dig yourdomain.com mx
    dig yourdomain.com any
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    hspcd is offline Loyal Member
    Join Date
    Nov 2007
    Location
    HSP NC
    Posts
    77
    Rep Power
    7

    Default

    Actually, now that I'm looking... like you asked.

    My hosts file was incorrect. I'm going to try it again.

  7. #7
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    What's your /etc/hosts file look like?

  8. #8
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Seems you got one in before me

  9. #9
    hspcd is offline Loyal Member
    Join Date
    Nov 2007
    Location
    HSP NC
    Posts
    77
    Rep Power
    7

    Default DNS & Hosts File fixed it

    Thank you!

  10. #10
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    All good now? (As in can I mark this thread resolved for you?)

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 02-23-2014, 01:08 PM
  2. fresh install (both OS and Zimbra) but zimbra-spell fails
    By xtremetoonz in forum Installation
    Replies: 14
    Last Post: 09-09-2007, 12:34 AM
  3. INSTALLATION PROBLEM ON Centos 4.3 x_86-64Bit.
    By jawad@cogilent.com in forum Installation
    Replies: 11
    Last Post: 07-09-2007, 08:09 AM
  4. Zimbra startup hangs after install CentOS 4.2
    By eger in forum Installation
    Replies: 4
    Last Post: 02-10-2006, 11:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •