Results 1 to 3 of 3

Thread: Troubles in setting the domain name

  1. #1
    Nacef is offline Junior Member
    Join Date
    May 2007
    Location
    Tunisia
    Posts
    6
    Rep Power
    8

    Default Troubles in setting the domain name

    Hi all,

    I have installed Zimbra sucessfully but my problem is in the naming.

    Let's assume that I have set my /etc/hosts like this :
    127.0.0.1 localhost.localdomain localhost
    my_ip_address myhost.mydomain.com myhost

    After successfully installing the domain name for my emails is by default :
    myemail@myhost.mydomain.com

    The result I was expecting is : myemail@mydomain.com

    So actually the trick was to create another virtual domain in my Zimbra configuration and name it mydomain.com

    Is there any way to get this done normally when installing ?

    Cheers
    Nacef

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    That is how you are supposed to have your hosts file.
    Here's what you should do:
    -Ditch the virtual domain.
    -Just create a new/2nd domain.com in the admin console gui > domains section.
    -Don't delete the host.domain.com yet, as there are admin reports/alerts slated to be delivered there.

    Though you can certainly delete it if you'd like after you move the admin/spam/ham and update all the references.
    You'll see what I mean if you:
    su zimbra
    zmprov gacf
    Most just leave spam/ham alone and just create an alias of admin@domain.com in admin@host.domain.com.
    You can also rename the spam/ham accounts (like if you wanted to remove the random numbers) - again be sure to update your zmlocalconfig.
    Last edited by mmorse; 10-31-2007 at 04:02 PM. Reason: yes your hostsfile is correct

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    Quote Originally Posted by Nacef View Post
    Is there any way to get this done normally when installing ?
    When you did the first clean install of ZImbra you would have been asked if you wanted to set the Domain Name, you must have hit enter without checking that option. That will give you the default that we found, the FQDN of your server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 10-05-2007, 03:14 PM
  2. [SOLVED] Remove main domain!
    By zibra in forum Administrators
    Replies: 11
    Last Post: 09-27-2007, 08:50 AM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. domain coexistence
    By marcmac in forum Administrators
    Replies: 14
    Last Post: 06-30-2006, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •