Results 1 to 10 of 10

Thread: mutli-serverzcs 5.0 RC1 network install hangs at Setting up CA

  1. #1
    morgan is offline Member
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    14
    Rep Power
    8

    Default mutli-serverzcs 5.0 RC1 network install hangs at Setting up CA

    I'm doing a clean install in our RHEL4 freshly kickstarted dev environment
    1 ldap master
    1 mta
    2 stores

    The ldap master installs fine. I only installed zimbra-ldap

    I got to the first store, select packages as follows:
    Select the packages to install
    Install zimbra-ldap [Y]
    Install zimbra-logger [Y]
    Install zimbra-mta [Y] n
    Install zimbra-snmp [Y] n
    Install zimbra-store [Y]
    Install zimbra-spell [Y]
    Install zimbra-proxy [N] y



    Once I set ldap master, admin pass, smtp host, license filename and ldap pass chose apply:
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.30447]
    Saving config in /opt/zimbra/config.30447...done.
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.log.30447
    Setting local config values...done.
    Updating ldap_root_password and zimbra_ldap_passwd...done.
    Setting up CA...

    It hans here indefinitely.


    Additional hints:
    at the bottom of /tmp/zmsetup.log.:
    Setting up CA...
    *** Running as root user: /opt/zimbra/bin/zmcertmgr createca
    ** Creating directory /opt/zimbra/ssl/zimbra
    ** Creating directory /opt/zimbra/ssl/zimbra/ca
    ** Creating directory /opt/zimbra/ssl/zimbra/server
    ** Creating directory /opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp
    ** Retrieving CA private key from ldap...



    If I follow the ps tree from install.sh I find this running:
    /opt/zimbra/java/bin/java -client -Xmx256m -Dzimbra.home=/opt/zimbra -Djava.library.path=/opt/zimbra/lib -Djava.ext.dirs=/opt/zimbra/java/jre/lib/ext:/opt/zimbra/lib/jars:/opt/zimbra/lib/ext:/opt/zimbra/lib/ext/backup:/opt/zimbra/lib/ext/clamscanner:/opt/zimbra/lib/ext/network:/opt/zimbra/lib/ext/zimbra-license:/opt/zimbra/lib/ext/zimbrahsm:/opt/zimbra/lib/ext/zimbrasync com.zimbra.cs.account.ProvUtil -l -- gacf zimbraCertAuthorityKeySelfSigned

    If I run a zmprov gacf it hangs. An strace doesn't provide any clear clues.

    Any ideas?

    thanks

  2. #2
    morgan is offline Member
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    14
    Rep Power
    8

    Default finally fixed

    After much testing by us and Zimbra support the problem turned out to be the Version of Linux.

    Final result: we were able to install multi server with RC2 + RHEL4 Update 4.

    We were on Update 6. Apparently Zimbra is testing on Update 5.

  3. #3
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    717
    Rep Power
    9

    Default

    Any more details on what packages are the problem? I've got ZCS 4.5.10 on RHEL 4 Update 6.

  4. #4
    morgan is offline Member
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    14
    Rep Power
    8

    Default

    Rich,

    We didn't identify individual packages, we are only using Zimbra 5.0 RC2 in development. We re-kickstarted our our hosts down to RHEL 4 update 4 and re-install.

    Feel free to contact me on or off forum for more details.

  5. #5
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    9

    Default

    A report has been filed to track this issue.
    Bug 23237 - ZCS 5.0 doesn't install on RHEL4_64bit update 6 multi node

    Morgan, it would be a great help if you could append a list of your installed RPM's to the bug.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    9

    Default

    Morgan, can you confirm your install was RHEL4 32 or RHEL4 64bit Update 6?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    morgan is offline Member
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    14
    Rep Power
    8

    Default

    do you want the current list (update 4)? Or the list in Update 6?

  8. #8
    morgan is offline Member
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    14
    Rep Power
    8

    Default

    Brian,

    We're on RHEL4 update 4 64 bit:

    $ cat /etc/redhat-release
    Red Hat Enterprise Linux ES release 4 (Nahant Update 4)
    $ uname -a
    Linux host.domain.org 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux
    $

  9. #9
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    9

    Default

    Quote Originally Posted by morgan View Post
    do you want the current list (update 4)? Or the list in Update 6?
    We'll need the list from Update 6.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  10. #10
    morgan is offline Member
    Join Date
    Feb 2007
    Location
    Philadelphia, PA
    Posts
    14
    Rep Power
    8

    Default

    Quote Originally Posted by brian View Post
    We'll need the list from Update 6.
    I've uploaded the list.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ZCS 5.0 Network Edition RC1
    By link915 in forum Administrators
    Replies: 5
    Last Post: 10-25-2007, 11:37 AM
  2. Zimbra 5.0 RC1 MAC OS X - Server crash after install !!
    By MiddleBrooker in forum Installation
    Replies: 7
    Last Post: 10-18-2007, 09:49 AM
  3. Trying to install Zimbra Network Edition on REH 4.4
    By intekular in forum Installation
    Replies: 4
    Last Post: 12-18-2006, 09:51 PM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Network edition - strange behavior
    By goetzi in forum Installation
    Replies: 6
    Last Post: 11-16-2005, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •