Results 1 to 5 of 5

Thread: Redhat hangs on reboot after Zimbra install

  1. #1
    pecotodd is offline Starter Member
    Join Date
    May 2007
    Rep Power

    Default Redhat hangs on reboot after Zimbra install

    I got Zimbra installed on a RH4 server. I thought everything was ok, I did a reboot and my console would never return a login screen. If I telnet in, I can see these running processes:
    1808 /bin/bach /etc/rc.d/rc 5
    3439 initlog -q -c /etc/rc5.d/S99zimbra start
    3440 /bin/bash /etc/rc5.d/S99zimbra start
    3442 su -zimbra -c zmcontrol startup >/opt/zimbra/startup.log 2>&1

    If I kill process 3442, I immediatley get my console login and the server is ok again.
    Then I went in and started zimbra manually (zmcontrol) the antispam and antivirus show as not running. Then when I get to the zimbra console, it shows antivirus/antispam/stats with a big red X

    Where do I start with this one?

  2. #2
    pecotodd is offline Starter Member
    Join Date
    May 2007
    Rep Power


    I've still got this issue. I thought maybe it was because the antispam/antivirus wasn't working correctly, so I disabled those 2 from the zimbra admin control panel.

    The next reboot, it still hangs. Now I don't plan on rebooting this thing very often, but its really bugging me! Something isn't right. What logs should I be looking at to give me an idea?
    Last edited by pecotodd; 10-11-2007 at 11:41 AM. Reason: spellin'

  3. #3
    imarks001's Avatar
    imarks001 is offline Active Member
    Join Date
    May 2006
    Reston, VA
    Rep Power

    Default Possible Fix

    I had the same or similar issue which was caused by Selinux trying to change the context of a user from the zimbra init startup script. I fixed it by changing all instances of "su - zimbra" in the startup script to "/sbin/runuser - zimbra".

  4. #4
    fernandoflorez is offline Project Contributor
    Join Date
    Sep 2006
    Rep Power


    I'm pretty sure zimbra recommends disabling selinux. Actually i see everywhere that disabling it is recommended.

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    We're working to enable SELinux, but currently it is not a support config:
    Bug 16407 - Support SE Linux (selinux)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  2. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts