Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: SMTP send relay problem

  1. #1
    Billy is offline Active Member
    Join Date
    Oct 2005
    Posts
    33
    Rep Power
    9

    Default SMTP send relay problem

    From the web client, all is well.

    From Thunderbird or Outlook Express, receiving mail via pop3 or IMAP is fine. Also sending to local addresses (domains defined in Zimbra) is fine. Outbound email to outside addresses, like hotmail, etc. fail with 'relay denied'.

    Because the outbound mail works fine out of the web client, I know the receiving party is accepting mail - no reverse look up problems at their end, etc.

    I've tried many combinations of Zimbra settings with no luck. I've read everything I can find in the forums, but can't get it to work.

    Anyone have a similar problem they've been able to solve?

  2. #2
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default Turn on smtp authentication on your server

    and configure your pop/imap client to use smtp authentication when sending.

  3. #3
    Billy is offline Active Member
    Join Date
    Oct 2005
    Posts
    33
    Rep Power
    9

    Default more info

    Oh, forgot to say:

    Fedora Core 4

    zcs-3.0.0_M2_746.FC4.tgz

  4. #4
    Billy is offline Active Member
    Join Date
    Oct 2005
    Posts
    33
    Rep Power
    9

    Default SMTP auth

    When I do that, I have a never ending user/password auth loop.

  5. #5
    Billy is offline Active Member
    Join Date
    Oct 2005
    Posts
    33
    Rep Power
    9

    Default -

    Unless I'm not turning on SMTP auth on the server correctly. How do you do that?

  6. #6
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default saslauthd.conf


  7. #7
    Billy is offline Active Member
    Join Date
    Oct 2005
    Posts
    33
    Rep Power
    9

    Default Appears to be the opposite of the other post

    [zimbra@mail ~]$ cat /opt/zimbra/cyrus-sasl/etc/saslauthd.conf
    zimbra_url: https://mail.ixxxb.net/service/soap/
    zimbra_cert_file: /opt/zimbra/conf/smtpd.crt
    zimbra_cert_check: off


    I've changed it to http://

    Now it works! I'll test more, but all looks good.

    Thanks a million!

  8. #8
    jgao is offline Senior Member
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Still relay problem

    I tried the same thing, but no luck. Keeping getting the relay errors. I changed https to http, in saslauthd.conf and saslauthd.conf.in.

    If I don't make the change, it does not work either.

    What else am I missing?

    Thanks a lot.

  9. #9
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by jgao
    What else am I missing?
    Did you restart saslauthd?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  10. #10
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default sasl auth

    Restart saslauthd, but make sure you've got it enabled, too, in the admin UI.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 06-18-2008, 01:50 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. Replies: 0
    Last Post: 03-26-2007, 03:12 AM
  4. strange MTA Relay Problem
    By pfuschi in forum Installation
    Replies: 0
    Last Post: 10-31-2006, 11:51 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •