Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: SMTP send relay problem

  1. #11
    jgao is offline Senior Member
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Outlook

    Quote Originally Posted by marcmac
    Restart saslauthd, but make sure you've got it enabled, too, in the admin UI.
    Could you be specific about the setting of admin UI? Do you mean "Relay MTA for external delivery:"?

    Thanks.

  2. #12
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default smtp auth

    No, I mean enable smtp authentication.

  3. #13
    jgao is offline Senior Member
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Still Relay access denied error

    my test results are pretty weird:

    If the zimbra server and email clients are on the same network(s)(such as networks in the same ISP), the outlook works fine on sending outbound emails.

    But if the email clients and zimbra server are on the different networks(like one network in my home, and another network in the work place), outlook still can't send outbound email, and I got the error message "Relay access denied".

    Any thought?

    Thanks.

  4. #14
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default smtp auth

    TUrn on smtp authentication (search the forums, this has been covered extensively.)

  5. #15
    jgao is offline Senior Member
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Still Relay access denied error

    If turn https on, outlook will enter an endless user/password loop, as Billy addressed in this tread.

    ???

  6. #16
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default username/password loop

    This has been covered, too.

    Your smtp auth setup is misconfigured. THere's a thread about fixing a bug in saslauthd.conf.in (search on that) that should get you going.

  7. #17
    jgao is offline Senior Member
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Still Relay access denied error

    Thanks for the quick response, but problems still there.

    My saslauthd.conf.in is the same as saslauthd.conf now. Any of both says:

    zimbra_url: https://qa.cirrata.net/service/soap/
    zimbra_cert_file: /opt/zimbra/conf/smtpd.crt
    zimbra_cert_check: off

    MTA settings are: Authentication Enabled, and TLS authentication only, for Global level and Server level.

    In one test of outlook, I turned the SSL on for SMTP. Then I got the user/password loop. Can't go further.

    In the another test of outlook, I turned the SSL off for SMTP. Then I don't get the loop. It works (sending outbound email) on the networks of the same ISP, but does not work on the networks of different ISPs.

    In the third test of outlook, I turned the SSL off for SMTP. In the zimbra, I changed the https to http for saslauth files. It works (sending outbound email) on the networks of the same ISP, but does not work on the networks of different ISPs.

  8. #18
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default smtp auth

    smtp auth doesn't apply when you're sending from a local network, so you can stop testing that.

    What mode is your we server running in? Do you access via http, or https? Make sure saslauthd.conf.in reflects that.

    After you enabled smtp auth, with TLS auth, did you restart postfix?

    is the host qa.cirrata.net hosting your web server, or just the MTA? If it's not hosting the web server, change the file to reflect the URL of the webmail host.

    Are you receiving a certificate from the smtpd server when you connect, with TLS turned on?

    How is your client configured to send? You want user/pass auth enabled, with TLS (not SSL) turned on.

  9. #19
    jgao is offline Senior Member
    Join Date
    Dec 2005
    Posts
    74
    Rep Power
    9

    Default Still Relay access denied error

    I disabled TLS authentication, used plain SMTP authentication, and changed saslauth files to http, Outlook worked pretty well on sending outbound message.

    If I want to turn the secure layer on, what I need to do to
    1.MTA settings,
    2. saslauth files,
    3. Outlook settings

    Thanks.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 06-18-2008, 01:50 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. Replies: 0
    Last Post: 03-26-2007, 03:12 AM
  4. strange MTA Relay Problem
    By pfuschi in forum Installation
    Replies: 0
    Last Post: 10-31-2006, 11:51 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •