I have a read timeout error for some outbound email. Appreciate any help.

My Zimbra install is open source 4.5.6 on Ubuntu 6.06 server with a public IP residing in a local ISP datacenter. Therefore my setup is without split dns. I have checked my domain at dnsstuff.com and all are OK.

Users are able to receive emails from anywhere. Some outbound mails however could not be delivered while some others are successfully delivered as per extract from the logs below.

Code:
Oct  3 11:09:04 mail postfix/smtp[17597]: B8FDDCB153: to=<***@turcomp.***>, relay=127.0.0.1[127.0.0.1], delay=3, status=sent (250 2.6.0 Ok, id=04146-02, from MTA([127.0.0.1]:10025): 250 Ok: queued as 312FBCB154)
Oct  3 11:09:04 mail postfix/qmgr[4099]: B8FDDCB153: removed

Oct  3 11:09:21 mail postfix/smtp[17597]: E4331CB153: to=<***@gmail.com>, relay=127.0.0.1[127.0.0.1], delay=4, status=sent (250 2.6.0 Ok, id=04150-02, from MTA([127.0.0.1]:10025): 250 Ok: queued as 0BC31CB155)
Oct  3 11:09:21 mail postfix/qmgr[4099]: E4331CB153: removed

Oct  3 11:09:33 mail postfix/smtp[17597]: 7C75DCB153: to=<***@tmnet.com.my>, relay=127.0.0.1[127.0.0.1], delay=3, status=sent (250 2.6.0 Ok, id=04151-02, from MTA([127.0.0.1]:10025): 250 Ok: queued as D9157CB156)
Oct  3 11:09:33 mail postfix/qmgr[4099]: 7C75DCB153: removed
Oct  3 11:09:38 mail postfix/smtp[17605]: D9157CB156: to=<***@tmnet.com.my>, relay=mx1.tmnet.com.my[203.106.249.218], delay=5, status=sent (250 +OK message queued for delivery.)
Oct  3 11:09:38 mail postfix/qmgr[4099]: D9157CB156: removed

Oct  3 11:16:36 mail postfix/smtp[21419]: 32E5ECB14F: to=<***@turcomp.***>, relay=none, delay=119924, status=deferred (connect to mail.turcomp.com[202.71.108.24]: read timeout)

Oct  3 11:18:20 mail postfix/smtp[14517]: 8D7DACB144: to=<***@gmail.com>, relay=none, delay=136581, status=deferred (connect to gsmtp183.google.com[64.233.183.27]: read timeout)

Oct  3 11:25:53 mail postfix/smtp[22787]: 18375CB145: to=<***@streamyx.com>, relay=127.0.0.1[127.0.0.1], delay=4, status=sent (250 2.6.0 Ok, id=04152-02, from MTA([127.0.0.1]:10025): 250 Ok: queued as E4C9F3FA03)
Oct  3 11:25:53 mail postfix/qmgr[4099]: 18375CB145: removed
Oct  3 11:25:58 mail postfix/smtp[22794]: E4C9F3FA03: to=<***@streamyx.com>, relay=mx.tm.net.my[202.188.0.213], delay=7, status=sent (250 2.0.0 vfS11X01r5MGKcy0000000 mail accepted for delivery)
Oct  3 11:25:58 mail postfix/qmgr[4099]: E4C9F3FA03: removed
The domains of the mails which are successfully delivered is related to the local ISP.

Please help. Thanks!