Results 1 to 6 of 6

Thread: smtp table lookup problem

  1. #1
    s_c_johnson is offline Junior Member
    Join Date
    Sep 2007
    Posts
    6
    Rep Power
    7

    Default smtp table lookup problem

    Hi.

    My smtp do not work correctly, when i try send mail from webmail, or by mail client i got following error ::

    Sep 18 17:27:03 5-MeO-DMT postfix/trivial-rewrite[7534]: warning: dict_ldap_lookup: Search error -1: Can't contact LDAP server
    Sep 18 17:27:03 5-MeO-DMT last message repeated 2 times
    Sep 18 17:27:03 5-MeO-DMT postfix/trivial-rewrite[7534]: fatal: ldap:/opt/zimbra/conf/ldap-vad.cf(0,100): table lookup problem
    Sep 18 17:27:03 5-MeO-DMT postfix/trivial-rewrite[7535]: warning: dict_ldap_lookup: Search error -1: Can't contact LDAP server
    Sep 18 17:27:03 5-MeO-DMT last message repeated 2 times
    Sep 18 17:27:03 5-MeO-DMT postfix/trivial-rewrite[7535]: fatal: ldap:/opt/zimbra/conf/ldap-vad.cf(0,100): table lookup problem
    Sep 18 17:27:04 5-MeO-DMT postfix/smtpd[6615]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
    Sep 18 17:27:04 5-MeO-DMT postfix/smtpd[6615]: warning: problem talking to service rewrite: Success
    Sep 18 17:27:04 5-MeO-DMT postfix/master[6205]: warning: process /opt/zimbra/postfix-2.2.9/libexec/trivial-rewrite pid 7534 exit status 1
    Sep 18 17:27:04 5-MeO-DMT postfix/smtpd[7121]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
    Sep 18 17:27:04 5-MeO-DMT postfix/master[6205]: warning: /opt/zimbra/postfix-2.2.9/libexec/trivial-rewrite: bad command startup -- throttling
    Sep 18 17:27:04 5-MeO-DMT postfix/smtpd[7121]: warning: problem talking to service rewrite: Connection reset by peer
    Sep 18 17:27:04 5-MeO-DMT postfix/smtpd[7478]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
    Sep 18 17:27:04 5-MeO-DMT postfix/smtpd[7478]: warning: problem talking to service rewrite: Success

    Interesting is when mail client is possible to auth (so smtp must commnucate with ldap), but message is not sent. So when i use swaks, the mail is delivered.

    Need additional information? Ask me.

    I' hanging on this.

    Thanks for help.

    scj

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,502
    Rep Power
    57

    Default

    Quote Originally Posted by s_c_johnson View Post
    Sep 18 17:27:03 5-MeO-DMT postfix/trivial-rewrite[7534]: warning: dict_ldap_lookup: Search error -1: Can't contact LDAP server
    Sep 18 17:27:03 5-MeO-DMT last message repeated 2 times
    Silly question, perhaps, but do you actually have LDAP installed and is it running if you do? What does a 'zmcontrol status' show? Which version/release of Zimbra and which operating system?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    s_c_johnson is offline Junior Member
    Join Date
    Sep 2007
    Posts
    6
    Rep Power
    7

    Default

    LDAP running, my other services using zimbra LDAP, and as i was write, webmail authentification working too.

    ~$ ldap status
    slapd running pid: 5671

    ~$ zmcontrol status
    Host zimbra.somwhere.tld
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running

    actualy

    ~$ ldapsearch uid=steweg
    # extended LDIF
    #
    # LDAPv3
    # base <> with scope subtree
    # filter: uid=steweg
    # requesting: ALL
    #

    # steweg, People, ....

    so ldap isn't problem.
    problem is somwhere in MTA, but i dont know where.

    scj

  4. #4
    s_c_johnson is offline Junior Member
    Join Date
    Sep 2007
    Posts
    6
    Rep Power
    7

    Default

    and i forgot, i'm using opensource zcs-4.5.6 on ubuntu 6.06.

    scj

  5. #5
    s_c_johnson is offline Junior Member
    Join Date
    Sep 2007
    Posts
    6
    Rep Power
    7

    Default

    enybody help? i'm freezed on this.

    scj

  6. #6
    s_c_johnson is offline Junior Member
    Join Date
    Sep 2007
    Posts
    6
    Rep Power
    7

    Default

    one interesting commnad ::

    ~$ postmap -q s_c_johnson@mydomain.tld ldap:/opt/zimbra/conf/ldap-vad.cf
    s_c_johnson@mydomain.tld

    and with -v
    ...
    postmap: dict_open: ldap:/opt/zimbra/conf/ldap-vad.cf
    postmap: dict_ldap_lookup: In dict_ldap_lookup
    postmap: dict_ldap_lookup: No existing connection for LDAP source /opt/zimbra/conf/ldap-vad.cf, reopening
    postmap: dict_ldap_connect: Connecting to server ldaps://ldap.mydomain.tld:636
    postmap: dict_ldap_connect: Actual Protocol version used is 3.
    ...

    so i realy dont know wehere is problem now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Amavisd-Postfix RCPT TO Takes a long time
    By samuraii in forum Administrators
    Replies: 8
    Last Post: 02-11-2009, 03:34 PM
  2. Problem with zmdbintegrityreport
    By glitch23 in forum Administrators
    Replies: 12
    Last Post: 07-16-2007, 09:56 PM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. multi domain / multi IP / SMTP HELO problem
    By fisch09 in forum Administrators
    Replies: 3
    Last Post: 04-04-2007, 05:22 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •