Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: [SOLVED] i am tired.. going to sleep.. help with installation

  1. #1
    drdre is offline Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    415
    Rep Power
    7

    Default [SOLVED] i am tired.. going to sleep.. help with installation

    ok guys here is my system.

    CeEntosOS5 .. 64bit AMD processor and 2 gbs ram..

    I followed the steps listed out here Centos 5 Install Guide ..

    I downloaded the 64bit version of zimbra for redhat4..

    after i do ./install.sh ..

    it starts up.. ask me a few questions.. then it does this :

    "Installing packages

    Zimbra -core...... zimbra-core-4.5..rpm..

    failed #error#

    Installation Cancelled."

    and just goes back to the prompt.. no other error messages at all...

    Am i totally lost HELP me please..

    Also it said soemthing about modifying the system because my platform isnt redhat 4 ...

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    do you have a zmsetup.log.#### file you could post?

    (often /tmp/zmsetup.log.####)
    Last edited by mmorse; 09-12-2007 at 01:29 PM.

  3. #3
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by drdre View Post
    ok guys here is my system.

    CeEntosOS5 .. 64bit AMD processor and 2 gbs ram..

    I followed the steps listed out here Centos 5 Install Guide ..

    I downloaded the 64bit version of zimbra for redhat4..

    after i do ./install.sh ..

    it starts up.. ask me a few questions.. then it does this :

    "Installing packages

    Zimbra -core...... zimbra-core-4.5..rpm..

    failed #error#

    Installation Cancelled."

    and just goes back to the prompt.. no other error messages at all...

    Am i totally lost HELP me please..

    Also it said soemthing about modifying the system because my platform isnt redhat 4 ...
    Also, are you using Cent 64 or 32?

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Also, did you try installing the RHEL 5 version as opposed to the RHEL 4 version.

    SourceForge.net: Files

    john

  5. #5
    drdre is offline Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    415
    Rep Power
    7

    Default

    i used both 4 and 5...

    and i am running centos5 64bit

    and yes i am using the 64bit zimbra.. because the 32bit tells u that a 64bit Os has been detected..

    i am not seeing any log file for it.

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    So what os are you using, 32 bit or 64?

  7. #7
    drdre is offline Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    415
    Rep Power
    7

    Default

    i am using the 64bit OS.

  8. #8
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Okay, then can you post the logs?
    look in /tmp/install.log.xxxx
    where xxx is the pid of the installer.

    Also, it might help if you ran:
    sh -x ./install.sh

    and posted the output.

    Best,
    john

  9. #9
    drdre is offline Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    415
    Rep Power
    7

    Default

    here we go....

    + echo Installing:
    Installing:
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-core'
    zimbra-core
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-ldap'
    zimbra-ldap
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-logger'
    zimbra-logger
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-mta'
    zimbra-mta
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-snmp'
    zimbra-snmp
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-store'
    zimbra-store
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-apache'
    zimbra-apache
    + for i in '$INSTALL_PACKAGES'
    + echo ' zimbra-spell'
    zimbra-spell
    + findLatestPackage zimbra-core
    + package=zimbra-core
    + latest=
    + himajor=0
    + himinor=0
    + histamp=0
    ++ ls ./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + files=./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + for q in '$files'
    ++ basename ./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + f=zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + '[' rpm = rpm ']'
    ++ echo zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    ++ awk -F- '{print $3}'
    + id=4.5.6_GA_1044.RHEL4_64
    ++ echo 4.5.6_GA_1044.RHEL4_64
    ++ awk -F_ '{print $1}'
    + version=4.5.6
    ++ echo 4.5.6
    ++ awk -F. '{print $1}'
    + major=4
    ++ echo 4.5.6
    ++ awk -F. '{print $2}'
    + minor=5
    ++ echo 4.5.6
    ++ awk -F. '{print $3}'
    + micro=6
    ++ echo zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    ++ awk -F_ '{print $3}'
    ++ awk -F. '{print $1}'
    + stamp=1044
    + '[' 4 -gt 0 ']'
    + himajor=4
    + himinor=5
    + histamp=1044
    + latest=./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + continue
    + file=./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    ++ basename ./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + f=zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    ++ bin/get_plat_tag.sh
    + p='CentOS5{i}'
    + echo zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + grep -q 'CentOS5{i}'
    + '[' 1 -ne 0 ']'
    + echo 'You appear to be installing packages on a platform different'
    You appear to be installing packages on a platform different
    + echo 'than the platform for which they were built'
    than the platform for which they were built
    + echo ''

    + echo 'This platform is CentOS5{i}'
    This platform is CentOS5{i}
    + echo 'Packages found: zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm'
    Packages found: zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + echo 'This may or may not work'
    This may or may not work
    + echo ''

    + askYN 'Install anyway?' N
    + PROMPT='Install anyway?'
    + DEFAULT=N
    + '[' xN = xyes -o xN = xYes -o xN = xy -o xN = xY ']'
    + DEFAULT=N
    + '[' 1 ']'
    + ask 'Install anyway?' N
    + PROMPT='Install anyway?'
    + DEFAULT=N
    + echo ''

    + echo -n 'Install anyway? [N] '
    Install anyway? [N] + read response
    y
    + '[' -z y ']'
    + '[' -z y ']'
    + '[' y = yes -o y = YES -o y = y -o y = Y ']'
    + response=yes
    + break
    + '[' yes = no ']'
    + verifyExecute
    + :
    + askYN 'The system will be modified. Continue?' N
    + PROMPT='The system will be modified. Continue?'
    + DEFAULT=N
    + '[' xN = xyes -o xN = xYes -o xN = xy -o xN = xY ']'
    + DEFAULT=N
    + '[' 1 ']'
    + ask 'The system will be modified. Continue?' N
    + PROMPT='The system will be modified. Continue?'
    + DEFAULT=N
    + echo ''

    + echo -n 'The system will be modified. Continue? [N] '
    The system will be modified. Continue? [N] + read response
    y
    + '[' -z y ']'
    + '[' -z y ']'
    + '[' y = yes -o y = YES -o y = y -o y = Y ']'
    + response=yes
    + break
    + '[' yes = no ']'
    + break
    + removeExistingInstall
    + '[' yes = yes ']'
    + echo ''

    + echo 'Shutting down zimbra mail'
    Shutting down zimbra mail
    + shutDownSystem
    + runAsZimbra 'zmcontrol shutdown'
    + echo 'COMMAND: zmcontrol shutdown'
    + su - zimbra -c 'zmcontrol shutdown'
    + '[' -f /opt/zimbra/bin/zmiptables ']'
    + isInstalled zimbra-ldap
    + pkg=zimbra-ldap
    + PKGINSTALLED=
    + '[' rpm = rpm ']'
    + rpm -q zimbra-ldap
    + '[' 1 = 0 ']'
    + '[' x '!=' x ']'
    + echo ''

    + echo 'Removing existing packages'
    Removing existing packages
    + echo ''

    + for p in '$INSTALLED_PACKAGES'
    + '[' zimbra-core = zimbra-core ']'
    + MOREPACKAGES=' zimbra-core'
    + continue
    + for p in '$MOREPACKAGES'
    + echo -n ' zimbra-core...'
    zimbra-core...+ rpm -ev --nodeps --noscripts --allmatches zimbra-core
    + echo done
    done
    + rm -f /etc/ld.so.conf.d/zimbra.ld.conf
    + '[' -f /etc/sudoers ']'
    + cat /etc/sudoers
    + grep -v zimbra
    + cat /tmp/sudoers
    + '[' 'CentOS5{i}' = SuSEES9 -o 'CentOS5{i}' = SuSEES10 -o 'CentOS5{i}' = SuSE10 -o 'CentOS5{i}' = openSUSE_10.2 -o 'CentOS5{i}' = openSUSE_10.1 ']'
    + chmod 440 /etc/sudoers
    + rm -f /tmp/sudoers
    + echo ''

    + echo 'Removing deployed webapp directories'
    Removing deployed webapp directories
    + /bin/rm -rf /opt/zimbra/tomcat/webapps/zimbra
    + /bin/rm -rf /opt/zimbra/tomcat/webapps/zimbra.war
    + /bin/rm -rf /opt/zimbra/tomcat/webapps/zimbraAdmin
    + /bin/rm -rf /opt/zimbra/tomcat/webapps/zimbraAdmin.war
    + /bin/rm -rf /opt/zimbra/tomcat/webapps/service
    + /bin/rm -rf /opt/zimbra/tomcat/webapps/service.war
    + /bin/rm -rf /opt/zimbra/tomcat/work
    + '[' no = yes ']'
    + '[' -d /opt/zimbra/openldap/var/openldap-data/ ']'
    + echo 'Installing packages'
    Installing packages
    + echo ''

    ++ date +%s
    + D=1189635040
    + echo '1189635040: INSTALL SESSION START'
    + for i in '$INSTALL_PACKAGES'
    + installPackage zimbra-core
    + PKG=zimbra-core
    + echo -n ' zimbra-core...'
    zimbra-core...+ findLatestPackage zimbra-core
    + package=zimbra-core
    + latest=
    + himajor=0
    + himinor=0
    + histamp=0
    ++ ls ./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + files=./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + for q in '$files'
    ++ basename ./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + f=zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + '[' rpm = rpm ']'
    ++ echo zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    ++ awk -F- '{print $3}'
    + id=4.5.6_GA_1044.RHEL4_64
    ++ echo 4.5.6_GA_1044.RHEL4_64
    ++ awk -F_ '{print $1}'
    + version=4.5.6
    ++ echo 4.5.6
    ++ awk -F. '{print $1}'
    + major=4
    ++ echo 4.5.6
    ++ awk -F. '{print $2}'
    + minor=5
    ++ echo 4.5.6
    ++ awk -F. '{print $3}'
    + micro=6
    ++ echo zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    ++ awk -F_ '{print $3}'
    ++ awk -F. '{print $1}'
    + stamp=1044
    + '[' 4 -gt 0 ']'
    + himajor=4
    + himinor=5
    + histamp=1044
    + latest=./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + continue
    + file=./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    ++ basename ./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + f=zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + echo -n ...zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm...
    ...zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm...+ rpm -iv ./packages/zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm
    + INSTRESULT=1
    + '[' yes = yes ']'
    + ST=UPGRADED
    ++ date +%s
    + D=1189635052
    + '[' 1 = 0 ']'
    + echo -n FAILED
    FAILED+ echo ''

    + echo '###ERROR###'
    ###ERROR###
    + echo ''

    + echo 'zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm installation failed'
    zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm installation failed
    + echo ''

    + echo 'Installation cancelled'
    Installation cancelled
    + echo ''

    + exit 1


    its got no LOG file what so ever ... also i see it saying upgrading... i believe that is from my previous attempt to install.. any ideas guys ?

  10. #10
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    + echo 'This platform is CentOS5{i}'
    This platform is CentOS5{i}
    + echo 'Packages found: zimbra-core-4.5.6_GA_1044.RHEL4_64-20070706134444.x86_64.rpm'
    This is the RHEL 4 version. Please try again with the RHEL 5 edition.

    I know you said it occurs with both, but let's stick with supported Zimbra installs.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-17-2006, 11:38 PM
  2. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 08:19 AM
  3. Replies: 16
    Last Post: 01-05-2006, 09:55 AM
  4. Installation on FC3 under Xen
    By andreground in forum Installation
    Replies: 9
    Last Post: 11-14-2005, 10:29 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •