Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Zimbra 5.0b3 Error

  1. #11
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Quote Originally Posted by quanah View Post
    Typo on my part

    /opt/zimbra/conf/ca

    --Quanah
    In 5.0b2 (I backed it out) the directory has:
    /opt/zimbra/conf/ca
    total 0
    drwxr-xr-x 2 zimbra zimbra 32 Aug 27 21:21 backup
    lrwxrwxrwx 1 zimbra zimbra 12 Aug 27 21:21 ca.key -> ../smtpd.key
    lrwxrwxrwx 1 zimbra zimbra 12 Aug 27 21:21 ca.pem -> ../smtpd.crt

  2. #12
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Quote Originally Posted by JoshuaPrismon View Post
    In 5.0b2 (I backed it out) the directory has:
    /opt/zimbra/conf/ca
    total 0
    drwxr-xr-x 2 zimbra zimbra 32 Aug 27 21:21 backup
    lrwxrwxrwx 1 zimbra zimbra 12 Aug 27 21:21 ca.key -> ../smtpd.key
    lrwxrwxrwx 1 zimbra zimbra 12 Aug 27 21:21 ca.pem -> ../smtpd.crt
    I did try to regenerate the keys as well.

  3. #13
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,185
    Rep Power
    9

    Default

    Well, that is definately wrong. It should contain ca.pem and ca.key, which are their own files. See what is in /opt/zimbra/ssl/ssl/ca

    There should be a ca.pem and ca.key in there. Remove the symlinks in /opt/zimbra/conf/ca and copy the files from /opt/zimbra/ssl/ssl/ca to there.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #14
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Quote Originally Posted by quanah View Post
    Well, that is definately wrong. It should contain ca.pem and ca.key, which are their own files. See what is in /opt/zimbra/ssl/ssl/ca

    There should be a ca.pem and ca.key in there. Remove the symlinks in /opt/zimbra/conf/ca and copy the files from /opt/zimbra/ssl/ssl/ca to there.

    --Quanah
    [root@technicaldetails zimbra]# ls -lA /opt/zimbra/ssl/ssl/ca
    total 20
    -rwx------ 1 zimbra zimbra 660 Aug 27 21:21 ca.csr
    -rwx------ 1 zimbra zimbra 887 Aug 27 21:21 ca.key
    -rwx------ 1 zimbra zimbra 879 Aug 27 21:21 ca.pem
    -rwx------ 1 zimbra zimbra 3 Aug 27 21:21 ca.srl
    -rwx------ 1 zimbra zimbra 3 Aug 27 21:21 ca.srl.old

    I will go ahead and copy the files over.

  5. #15
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Quote Originally Posted by JoshuaPrismon View Post
    [root@technicaldetails zimbra]# ls -lA /opt/zimbra/ssl/ssl/ca
    total 20
    -rwx------ 1 zimbra zimbra 660 Aug 27 21:21 ca.csr
    -rwx------ 1 zimbra zimbra 887 Aug 27 21:21 ca.key
    -rwx------ 1 zimbra zimbra 879 Aug 27 21:21 ca.pem
    -rwx------ 1 zimbra zimbra 3 Aug 27 21:21 ca.srl
    -rwx------ 1 zimbra zimbra 3 Aug 27 21:21 ca.srl.old

    I will go ahead and copy the files over.
    I am re-installing right now, but here is a interesting error that popped up when I started to install:
    Code:
    Removing deployed webapp directories
    mv: target `/opt/zimbra/openldap-data/' is not a directory: No such file or directory
    Installing packages
    
        zimbra-core......zimbra-core-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
        zimbra-ldap......zimbra-ldap-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
        zimbra-logger......zimbra-logger-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
        zimbra-mta......zimbra-mta-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
        zimbra-snmp......zimbra-snmp-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
        zimbra-store......zimbra-store-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
    zimbra-apache......zimbra-apache-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
    zimbra-spell......zimbra-spell-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done
    zimbra-proxy......zimbra-proxy-5.0.0_BETA3_1276.FC5-20070822121151.i386.rpm...done

  6. #16
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,185
    Rep Power
    9

    Default

    [QUOTE=JoshuaPrismon;58161]I am re-installing right now, but here is a interesting error that popped up when I started to install:
    Code:
    Removing deployed webapp directories
    mv: target `/opt/zimbra/openldap-data/' is not a directory: No such file or directory
    Installing packages
    If you've wiped and reinstalled, you can ignore the error.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #17
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    [QUOTE=quanah;58162]
    Quote Originally Posted by JoshuaPrismon View Post
    I am re-installing right now, but here is a interesting error that popped up when I started to install:
    Code:
    Removing deployed webapp directories
    mv: target `/opt/zimbra/openldap-data/' is not a directory: No such file or directory
    Installing packages
    If you've wiped and reinstalled, you can ignore the error.

    --Quanah
    I haven't. I am doing a upgrade.

    I confirmed that the directory existed before the upgrade, and was not a symlink. I am about to back this out a second time.
    Last edited by JoshuaPrismon; 08-31-2007 at 11:55 AM.

  8. #18
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Still working on this. Here si the zmsetup.log that corresponds to the error:

    more /tmp/zmsetup.log.7906
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Getting local config zimbra_server_hostname
    Getting local config ldap_url
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap
    *** Running as zimbra user: /opt/zimbra/openldap/sbin/slapindex -b '' -q -f /opt
    /zimbra/conf/slapd.conf
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    Started slapd: pid 8514
    ldap_add: Already exists (68)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    adding new entry "cn=zimbra"

    adding new entry "cn=admins,cn=zimbra"
    [josh@eponine ~/zcs-5.0.0_BETA3_1276.RHEL5_64.20070822122306]$ cat /tmp/zmsetup.log.7906
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Getting local config zimbra_server_hostname
    Getting local config ldap_url
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap
    *** Running as zimbra user: /opt/zimbra/openldap/sbin/slapindex -b '' -q -f /opt/zimbra/conf/slapd.conf
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    Started slapd: pid 8514
    ldap_add: Already exists (68)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    ldap_add: No such object (32)
    adding new entry "cn=zimbra"

    adding new entry "cn=admins,cn=zimbra"

    adding new entry "uid=zimbra,cn=admins,cn=zimbra"

    adding new entry "cn=zimlets,cn=zimbra"

    adding new entry "cn=cos,cn=zimbra"

    adding new entry "cn=servers,cn=zimbra"

    ldap_add: No such object (32)
    adding new entry "cn=config,cn=zimbra"

    ldap_add: No such object (32)
    adding new entry "cn=default,cn=cos,cn=zimbra"

    ldapmodify: modify operation type is missing at line 2, entry "cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 9, entry "cn=message/rfc822,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 17, entry "cn=text/html,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 27, entry "cn=text/enriched,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 36, entry "cn=text/plain,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 46, entry "cn=text/calendar,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 56, entry "cn=all,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 2, entry "cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 9, entry "cn=message/rfc822,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 17, entry "cn=text/html,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 27, entry "cn=text/enriched,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 36, entry "cn=text/plain,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 46, entry "cn=text/calendar,cn=mime,cn=config,cn=zimbra"
    ldapmodify: modify operation type is missing at line 56, entry "cn=all,cn=mime,cn=config,cn=zimbra"
    ls: /opt/zimbra/lib/conf/*ldif: No such file or directory
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    slapd running pid: 8514
    Getting enabled services from ldap
    Marking zimbra-ldap as disabled
    Marking zimbra-store as disabled
    Marking zimbra-mta as disabled
    Marking zimbra-snmp as disabled
    Marking zimbra-logger as disabled
    Marking zimbra-apache as disabled
    Marking zimbra-spell as disabled
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java'
    checking isEnabled zimbra-store
    zimbra-store is not enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is not enabled
    checking isEnabled zimbra-store
    zimbra-store is not enabled
    Done
    Setting defaults from existing config...
    Getting local config ldap_master_url
    Getting local config ldap_port
    Getting local config ldap_root_password
    Getting local config mysql_root_password
    Getting local config mysql_logger_root_password
    Getting local config zimbra_mysql_password
    Getting local config zimbra_logger_mysql_password
    Getting local config mailboxd_java_heap_memory_percent
    Getting local config mysql_memory_percent
    Getting local config mailboxd_directory
    Getting local config mailboxd_keystore
    checking isEnabled zimbra-snmp
    zimbra-snmp is not enabled
    checking isEnabled zimbra-logger
    zimbra-logger is not enabled
    checking isEnabled zimbra-snmp
    zimbra-snmp is not enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is not enabled
    checking isEnabled zimbra-store
    zimbra-store is not enabled
    checking isEnabled zimbra-mta
    zimbra-mta is not enabled
    checking isEnabled zimbra-spell
    zimbra-spell is not enabled
    Checking for port conflicts
    checking isEnabled zimbra-ldap
    zimbra-ldap is not enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is not enabled
    checking isEnabled zimbra-store
    zimbra-store is not enabled
    checking isEnabled zimbra-logger
    zimbra-logger is not enabled
    checking isEnabled zimbra-mta
    zimbra-mta is not enabled
    ldap configuration not complete
    checking isEnabled zimbra-ldap
    zimbra-ldap is not enabled
    checking isEnabled zimbra-store
    zimbra-store is not enabled
    checking isEnabled zimbra-mta
    zimbra-mta is not enabled
    checking isEnabled zimbra-snmp
    zimbra-snmp is not enabled
    checking isEnabled zimbra-spell
    zimbra-spell is not enabled
    ldap configuration not complete
    checking isEnabled zimbra-ldap
    zimbra-ldap is not enabled
    checking isEnabled zimbra-store
    zimbra-store is not enabled
    checking isEnabled zimbra-mta
    zimbra-mta is not enabled
    checking isEnabled zimbra-snmp
    zimbra-snmp is not enabled
    checking isEnabled zimbra-spell
    zimbra-spell is not enabled
    ldap configuration not complete

  9. #19
    JoshuaPrismon is offline Zimlet Guru & Moderator
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    9

    Default

    Still no luck on this. This box has been updated since the initial M1 release. I think it might be time to do a migration to a fresh install.

    Has anyone used imapsync to sync up two zimbra servers? Is there a better way to do it?

  10. #20
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Started with fc4 back in 2005? Through all your OS upgrades & what not too-nice. -or did you built from source?

    Well seeing as you want no old ldap or db data...Not till someone makes the zcs>zcs tool Bug 19630 - Migration Tool zimbra to zimbra

    script some account provisioning + imapsync + all the calendar data exports/imports & what not...

    How many users?

    Then again the hold off on a migration tool is because of zmbackup>zmrestore available in the NE...
    Last edited by mmorse; 09-13-2007 at 12:39 PM.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 12:11 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  4. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •