Results 1 to 6 of 6

Thread: Moving Zimbra installation to different server - Failing.

  1. #1
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default Moving Zimbra installation to different server - Failing.

    Problem moving from Suse10 to Debian 4.

    I build a new server, same host name, install Zimbra OSS 5beta 2 on it. Then I move the /opt/zimbra folder to /opt/zimbra_raw to keep it out of the way.

    Rsynced the /opt/zimbra folder from the Suse server to the new Debian one. Now I run the installer again and this is what happens:
    Code:
    zimbra:/usr/src/zcs-5.0.0_BETA2_1092.UBUNTU6.20070718133449# ./install.sh
    
    Operations logged to /tmp/install.log.4150
    Checking for existing installation...
        zimbra-ldap...FOUND zimbra-ldap-5.0.0_BETA2_1092.UBUNTU6
        zimbra-logger...FOUND zimbra-logger-5.0.0_BETA2_1092.UBUNTU6
        zimbra-mta...FOUND zimbra-mta-5.0.0_BETA2_1092.UBUNTU6
        zimbra-snmp...FOUND zimbra-snmp-5.0.0_BETA2_1092.UBUNTU6
        zimbra-store...FOUND zimbra-store-5.0.0_BETA2_1092.UBUNTU6
        zimbra-apache...FOUND zimbra-apache-5.0.0_BETA2_1092.UBUNTU6
        zimbra-spell...FOUND zimbra-spell-5.0.0_BETA2_1092.UBUNTU6
        zimbra-proxy...FOUND zimbra-proxy-5.0.0_BETA2_1092.UBUNTU6
        zimbra-core...FOUND zimbra-core-5.0.0_BETA2_1092.UBUNTU6
    
    Saving existing configuration file to /opt/zimbra/.saveconfig
    
    
    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.
    
    License Terms for the Zimbra Collaboration Suite:
            http://www.zimbra.com/license/collaboration_suite_collective_license_1.0.html
    
    
    Press Return to continue
    
    Checking for prerequisites...
        NPTL...FOUND
        sudo...FOUND sudo-1.6.8p12-4
        libidn11...FOUND libidn11-0.6.5-1
        curl...FOUND curl-7.15.5-1etch1
        fetchmail...FOUND fetchmail-6.3.6-1
        libpcre3...FOUND libpcre3-6.7-1
        libgmp3c2...FOUND libgmp3c2-2:4.2.1+dfsg-4
        libexpat1...FOUND libexpat1-1.95.8-3.4
        libxml2...FOUND libxml2-2.6.27.dfsg-1
        libstdc++6...FOUND libstdc++6-4.1.1-21
        libstdc++5...FOUND libstdc++5-1:3.3.6-15
        openssl...FOUND openssl-0.9.8c-4
    
    Checking for installable packages
    
    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    Found zimbra-proxy
    
    
    The Zimbra Collaboration Suite appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.
    
    Do you wish to upgrade? [Y] y
    
    Select the packages to install
        Upgrading zimbra-core
        Upgrading zimbra-ldap
        Upgrading zimbra-logger
        Upgrading zimbra-mta
        Upgrading zimbra-snmp
        Upgrading zimbra-store
        Upgrading zimbra-apache
        Upgrading zimbra-spell
        Upgrading zimbra-proxy
    Checking required space for zimbra-core
    checking space for zimbra-store
    
    Installing:
        zimbra-core
        zimbra-ldap
        zimbra-logger
        zimbra-mta
        zimbra-snmp
        zimbra-store
        zimbra-apache
        zimbra-spell
        zimbra-proxy
    You appear to be installing packages on a platform different
    than the platform for which they were built
    
    This platform is DEBIAN3.1
    Packages found: zimbra-core_5.0.0_BETA2_1092.UBUNTU6_i386.deb
    This may or may not work
    
    
    Install anyway? [N] y
    
    The system will be modified.  Continue? [N] y
    
    Shutting down zimbra mail
    
    Backing up ldap
    
    could not stat config file "/opt/zimbra/conf/slapd.conf": No such file or directory (2)
    slapcat: bad configuration file!
    
    Removing existing packages
    
       zimbra-ldap...done
       zimbra-logger...done
       zimbra-mta...done
       zimbra-snmp...done
       zimbra-store...done
       zimbra-spell...done
       zimbra-proxy...done
       zimbra-apache...done
       zimbra-core...done
    
    Removing deployed webapp directories
    Installing packages
    
        zimbra-core......zimbra-core_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-ldap......zimbra-ldap_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-logger......zimbra-logger_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-mta......zimbra-mta_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-snmp......zimbra-snmp_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-store......zimbra-store_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-apache......zimbra-apache_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-spell......zimbra-spell_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
        zimbra-proxy......zimbra-proxy_5.0.0_BETA2_1092.UBUNTU6_i386.deb...done
    
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
       HOSTNAME=zimbra.domain.tld
       LDAPHOST=
       LDAPPORT=
       SNMPTRAPHOST=
       SMTPSOURCE=
       SMTPDEST=
       SNMPNOTIFY=0
       SMTPNOTIFY=0
       LDAPROOTPW=zimbra
       LDAPZIMBRAPW=zimbra
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    chown: cannot access `/opt/zimbra/conf/smtpd.key': No such file or directory
    chown: cannot access `/opt/zimbra/conf/smtpd.crt': No such file or directory
    chown: cannot access `/opt/zimbra/conf/slapd.crt': No such file or directory
    chown: cannot access `/opt/zimbra/conf/perdition.pem': No such file or directory
    chown: cannot access `/opt/zimbra/conf/perdition.key': No such file or directory
    chown: cannot access `/opt/zimbra/conf/nginx.key': No such file or directory
    chown: cannot access `/opt/zimbra/conf/nginx.crt': No such file or directory
    Operations logged to /tmp/zmsetup.log.8406
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Setting defaults...Done
    Setting defaults from existing config...Warning: null valued key 'mysql_logger_root_password'
    Upgrading from  to 5.0.0_BETA2_1092
    Stopping zimbra services
    Stop failed - exiting
    UPGRADE FAILED - exiting
    Any ideas?
    Last edited by Dirk; 07-29-2008 at 02:38 PM.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    Quote Originally Posted by Dirk View Post
    Problem moving from Suse10 to Debian 4.
    Perhaps I'm being a bit dense here but might this version:
    Code:
     Packages found: zimbra-core_5.0.0_BETA2_1092.UBUNTU6_i386.deb
    you're trying to install be the problem?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    You mean the 'beta so, tough' part or the 'Ubuntu is not Debian' part !

    Looking at the posts on the forum so far it seems that the installer for Ubuntu6 works fine with Debian 4 (after two minor changes) so I installed that and it seemed to go on just fine.

    I'll nuke it and try again as it's possible I stuffed something up along the way.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    No, I meant Ubuntu is not Debian - you didn't say you'd made the changes. It would also appear you've had a failed upgrade in the becase the restore of LDAP is corrupt. If you've made the required changes and a correct DNS & hosts file set-up the it should work. Try an './install.sh -u' to remove it completely and try again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Thanks Bill.

    I've uninstalled and nwo cant get the fresh install to complete! *pull's out hair*

    It's erroring about ldap:

    daemon: bind(7) failed errno-99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://zimbra.domain.tld:389
    ERROR - failed to start slapd

    I may just nuke the entire server and start again from scratch.

  6. #6
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    -- Long post, sorry --

    Well, I tried again. Nuked the install and put a fresh 5.0beta 1 version on the debian server, then I rsync'ed the suse /opt/zimbra on top of it and then ran the installer again to refresh the binaries.

    It failed.
    The installed crashed out with:
    Code:
    ...
    Starting mysql
    Starting logger msql
    Thu Aug  2 20:55:18 2007: SELECT value FROM config WHERE name = 'db.version'
    I can't upgrade version 5.0.0_BETA1_856
    
    UPGRADE FAILED - exiting
    Feeling brave, I launched zimbra anyway with zmcontrol start, hoping that the installer had done enough to allow the system to launch, and I could then run the upgrade to beta 2.
    It should come as no surprise that this didnt work. The zmcontrol start command showed everything as ok, but there was no response when I tried to log in. zmcontrol status showed that the mailbox service was not running, so I issed the zmcontrol start command again. This time, zmcontrol status shows everything as running, but I still cant login, page cannot be displayed error in the browser.

    So I try to telnet to localhost 389 to see if anything happens, connection refused. Gah!

    Fine, reboot. I'm getting fed up now. This is my home server hosting a mere two accounts. I am doing this as a trial run for the work system holding 40 accounts and I'm starting to worry.

    So, the reboot completes and I try to login.... no luck. So I check the services again and the mailbox is not starting. Ok... to hell with it I think, lets try the install of beta 2 over the top and see what happens. Ok, install in progress, time to read some blogs and pour a glass of wine while I wait......

    This seems to go a little better, errors are show during the install, but it continues to the end.

    And I can log in!

    Ok, so it seems I've moved from suse to debian, it seems to be working I need to test, but first I need to sleep.

    The end of a long post is this.... There has to be a better way!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Replies: 8
    Last Post: 02-27-2007, 04:10 AM
  3. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 11:59 AM
  4. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •