Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: FQ Hostname Not Set

  1. #11
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Sorry, a typing mistake in the earlier post - it's a Split DNS you need. The problem is caused by the fact that your IP is resolving to the public IP address when it should be the local LAN IP.

    Your hosts file should be in this format:
    Code:
    127.0.0.1 localhost.localdomain localhost
    10.10.10.18 mail-01.emerson-school.org mail-01
    remove any other entries.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    swu
    swu is offline Special Member
    Join Date
    Apr 2007
    Location
    Ann Arbor, MI
    Posts
    108
    Rep Power
    8

    Cool

    Thanks Bill, I read up on split DNS and give it a whirl. Thx!

  3. #13
    swu
    swu is offline Special Member
    Join Date
    Apr 2007
    Location
    Ann Arbor, MI
    Posts
    108
    Rep Power
    8

    Question

    My host file now contains only:

    127.0.0.1 localhost.emerson-school.org localhost
    10.10.10.18 mail-01.emerson-school.org mail-01

    I've rebooted, when I do:

    zimbra@mail-01:~/postfix/conf$ zmlocalconfig | grep host

    I get:

    ldap_host = mail-01
    logger_mysql_bind_address = localhost
    mysql_bind_address = localhost
    snmp_trap_host = mail-01
    zimbra_server_hostname = mail-01
    zimbra_zmprov_default_soap_server = localhost

    Then if I do:

    zimbra@mail-01:~/postfix/conf$ host `hostname`

    mail-01.emerson-school.org has address 10.10.10.18

    In my /opt/zimbra/postfix/conf/main.cf

    I still see $myhostname = mail-01

    I can change it manually to mail.emerson-school.org by using the postconf -e command, but when I reboot it's getting set back to mail-01. So I'm still bouncing mail to a few folks.

    Any help would be greatly appreciated. Thx!

  4. #14
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Your hosts file is still incorrect, it doesn't match the example I gave above. Enter the details as I've typed them, 'localdomain' doesn't mean you should enter your domain name.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #15
    swu
    swu is offline Special Member
    Join Date
    Apr 2007
    Location
    Ann Arbor, MI
    Posts
    108
    Rep Power
    8

    Question

    I made the change to the hosts file and then restarted the server. I still get:

    mailman@mail-01:~$ host `hostname`
    mail-01.emerson-school.org has address 10.10.10.18

    mailman@mail-01:~$ sudo su zimbra
    Password:
    zimbra@mail-01:/home/mailman$ zmlocalconfig | grep host
    ldap_host = mail-01
    logger_mysql_bind_address = localhost
    mysql_bind_address = localhost
    snmp_trap_host = mail-01
    zimbra_server_hostname = mail-01
    zimbra_zmprov_default_soap_server = localhost

    zimbra@mail-01:/etc$ vi hosts
    127.0.0.1 localhost.localdomain localhost
    10.10.10.18 mail-01.emerson-school.org mail-01

    Thx for any help!

  6. #16
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    First, you should make sure that your local DNS is correct by running the dig commands I gave you in an earlier post. You should also set the ldap entries to be the following:

    Code:
    ldap_host = mail-01.emerson-school.org
    snmp_trap_host = mail-01.emerson-school.org
    zimbra_server_hostname = mail-01.emerson-school.org
    you can do that with the zmlocalconfig command using the '-e' option (have a look in the wiki).

    Just an FYI, when you want to run as the zimbra user do an 'su - zimbra' note the hyphen it is important.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #17
    swu
    swu is offline Special Member
    Join Date
    Apr 2007
    Location
    Ann Arbor, MI
    Posts
    108
    Rep Power
    8

    Red face

    After I make the ldap changes should I reboot the system, or will they "take" right away? I'm just trying to minimize any downtime.

    Thx!

  8. #18
    swu
    swu is offline Special Member
    Join Date
    Apr 2007
    Location
    Ann Arbor, MI
    Posts
    108
    Rep Power
    8

    Red face

    I made the changes above, rebooted the system and when it came back up I checked mail.log and could see the shutdown completed, but the mail system did not come back up.

    Aug 12 07:16:44 mail-01 zmtomcatmgr[14624]: manager process 4498 died, shutdown completed
    Aug 12 07:20:02 mail-01 postfix/postqueue[3931]: fatal: Queue report unavailable - mail system is down

    After about five minutes and nothing changing in mail.log:

    zimbra@mail-01:~$ zmcontrol status
    Cannot determine services - exiting
    zimbra@mail-01:~$

    I put the system back by reversing the commands and rebooting and I'm ok, but I still don't have the correct server host name.

    Any help would be appreciated.

  9. #19
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    I asked you to also check your DNS configuration by running the commands I gave you earlier, please post the output of those commands.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #20
    swu
    swu is offline Special Member
    Join Date
    Apr 2007
    Location
    Ann Arbor, MI
    Posts
    108
    Rep Power
    8

    Default

    Here you go:

    mailman@mail-01:~$ dig emerson-school.org any

    ; <<>> DiG 9.3.2 <<>> emerson-school.org any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23258
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 0, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;emerson-school.org. IN ANY

    ;; ANSWER SECTION:
    emerson-school.org. 600 IN A 10.10.10.252
    emerson-school.org. 600 IN A 10.10.10.247
    emerson-school.org. 600 IN A 10.10.10.12
    emerson-school.org. 3600 IN NS blackbeauty.emerson-school.org.
    emerson-school.org. 3600 IN NS es-ad-02.emerson-school.org.
    emerson-school.org. 3600 IN SOA blackbeauty.emerson-school.org. swu.emerson-school.org. 1944 900 600 86400 3600
    emerson-school.org. 3600 IN MX 10 mail.emerson-school.org.

    ;; ADDITIONAL SECTION:
    blackbeauty.emerson-school.org. 3600 IN A 10.10.10.252
    es-ad-02.emerson-school.org. 3600 IN A 10.10.10.12

    ;; Query time: 1 msec
    ;; SERVER: 10.10.10.12#53(10.10.10.12)
    ;; WHEN: Sun Aug 12 08:04:44 2007
    ;; MSG SIZE rcvd: 226

    mailman@mail-01:~$


    mailman@mail-01:~$ dig emerson-school.org mx

    ; <<>> DiG 9.3.2 <<>> emerson-school.org mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53994
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;emerson-school.org. IN MX

    ;; ANSWER SECTION:
    emerson-school.org. 3600 IN MX 10 mail.emerson-school.org.

    ;; Query time: 0 msec
    ;; SERVER: 10.10.10.12#53(10.10.10.12)
    ;; WHEN: Sun Aug 12 08:05:20 2007
    ;; MSG SIZE rcvd: 57

    mailman@mail-01:~$

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Changing Your Hostname
    By manthrax3 in forum Administrators
    Replies: 2
    Last Post: 12-27-2007, 06:15 PM
  2. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM
  3. Web mail MTA Hostname
    By melody in forum Administrators
    Replies: 16
    Last Post: 04-19-2007, 10:11 AM
  4. One domain set up in two different locations
    By sunshineknox in forum Administrators
    Replies: 1
    Last Post: 04-04-2007, 08:13 PM
  5. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 02:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •