Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Manage Mail Queues problem

  1. #11
    jshute is offline Starter Member
    Join Date
    Oct 2007
    Posts
    1
    Rep Power
    7

    Default

    Is there any update on this issue?

    Having the same issue on my install. It is a fresh install on a dedicated VM running on Ubuntu 6.06 LTS fully patched and Release 5.0.0_RC1_1538.

    2007-10-24 13:19:39,936 ERROR [{RemoteManager: mail.shute.us->zimbra@mail.shute.us:22}-zmqstat deferred] [] rmgmt - error when scanning mail queue deferred on host mail.shute.us
    java.io.IOException: Cannot create directory: /opt/zimbra/jetty-6.1.5/work/zimbra/27fd8d26-e516-435a-9bfe-fb8e1220c073-deferred
    at org.apache.lucene.store.FSDirectory.getDirectory(F SDirectory.java:175)
    at org.apache.lucene.store.FSDirectory.getDirectory(F SDirectory.java:157)
    at org.apache.lucene.index.IndexWriter.init(IndexWrit er.java:352)
    at org.apache.lucene.index.IndexWriter.(IndexWriter.java:256)
    at com.zimbra.cs.rmgmt.RemoteMailQueue.clearIndexInte rnal(RemoteMailQueue.java:223)
    at com.zimbra.cs.rmgmt.RemoteMailQueue$QueueHandler.r ead(RemoteMailQueue.java:178)
    at com.zimbra.cs.rmgmt.RemoteManager.executeBackgroun d0(RemoteManager.java:98)
    at com.zimbra.cs.rmgmt.RemoteManager.access$000(Remot eManager.java:35)
    at com.zimbra.cs.rmgmt.RemoteManager$1.run(RemoteMana ger.java:111)
    at java.lang.Thread.run(Thread.java:619)

  2. #12
    peedub is offline New Member
    Join Date
    Jun 2012
    Posts
    4
    Rep Power
    2

    Default

    Bump as I just ran into this same situation with zcs 7.2.0 on ubuntu 10.04. Everything else is in working status, mail is being delivored, and the other mail queues can be read fine except the defered as can be seen in my screenshot. Has anyone found the cause of this yet?

    2012-06-21-101601_1440x900_scrot.jpg

    All zimbra services report as up and functional:
    zimbra@myhost:~$ zmcontrol status
    Host myhost.my.domain
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    memcached Running
    mta Running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running
    Found this in the logs:
    2012-06-21 10:24:04,975 ERROR [{RemoteManager: zimbra@myhostname.my.domain:22}-zmqstat deferred] [] rmgmt - error when scanning mail queue deferred on host myhostname.my.domain
    org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: NativeFSLock@/opt/zimbra/data/tmp/6b...red/write.lock
    at org.apache.lucene.store.Lock.obtain(Lock.java:84)
    at org.apache.lucene.index.IndexWriter.init(IndexWrit er.java:1066)
    at org.apache.lucene.index.IndexWriter.(IndexWriter.java:888)
    at com.zimbra.cs.rmgmt.RemoteMailQueue.clearIndexInte rnal(RemoteMailQueue.java:235)
    at com.zimbra.cs.rmgmt.RemoteMailQueue$QueueHandler.r ead(RemoteMailQueue.java:187)
    at com.zimbra.cs.rmgmt.RemoteManager.executeBackgroun d0(RemoteManager.java:103)
    at com.zimbra.cs.rmgmt.RemoteManager.access$000(Remot eManager.java:36)
    at com.zimbra.cs.rmgmt.RemoteManager$1.run(RemoteMana ger.java:118)
    at java.lang.Thread.run(Thread.java:662)
    anoyone have a fix for this? for the time being I can just work with the postfix cli queue but would love to get this fixed asap

  3. #13
    peedub is offline New Member
    Join Date
    Jun 2012
    Posts
    4
    Rep Power
    2

    Default

    any update on this? Im thinking that I need to republish this in a new thread as i feel that I have just been ignored by trying not to spam the forum and attach this to a ticket that i thought might be relevant... I will wait a few hours and if I still have not heard anything back then I will move this to its own thread and maybe it will get a reply there.

  4. #14
    peedub is offline New Member
    Join Date
    Jun 2012
    Posts
    4
    Rep Power
    2

    Default

    Being as I was unable to get _ANY_ help (not even a reply saying it was already on the site somewhere) on this through the support forums here on the Zimbra site, I took the liberty to setup an entire separate server that was a clone of our production server for testing purposes. I have found the solution to this issue, and no its not a problem with the server date being incorrect. On the other hand, I do have to admit that during the install, the person that did the install did get a little hasty and did the install before reading the instructions. This problem arise from having Zimbra setup in a single server config _AND_ having the bundled version of the memcached plugin installed at the same time. As soon as I ran the following configs as the Zimbra user, all issues that we were fighting have dissolved into thin air. The solution is simply to disable the component as follows:

    zmmemcachedctl stop
    zmprov ms -zimbraServiceEnabled memcached
    zmcontrol stop
    zmcontrol start

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •