Results 1 to 5 of 5

Thread: install zimbra with PHP and Apache Mysql

  1. #1
    mingswitch is offline Active Member
    Join Date
    Jul 2007
    Posts
    36
    Rep Power
    7

    Default install zimbra with PHP and Apache Mysql

    hello

    My system is debian 3.1
    I installed Zimbra.
    I would like to now if i need to install apache + PHP Mysql
    Or i don't need that beacause is aleady include with Zibra

    I have this error .

    ks300959:/home/soft/php/php-5.2.0# apache2ctl graceful
    /usr/sbin/apache2: /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2: no version information available (required by /usr/lib/libldap_r.so.2)
    [Tue Jul 10 16:14:49 2007] [warn] module php5_module is already loaded, skipping
    [Tue Jul 10 16:14:49 2007] [crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP.


    thank you

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    My system is debian 3.1
    I installed Zimbra.
    I would like to now if i need to install apache + PHP Mysql
    Or i don't need that beacause is aleady include with Zibra
    Zimbra installs it's own apache/php/mysql but you should not use these, install your own.

    I have this error .
    ks300959:/home/soft/php/php-5.2.0# apache2ctl graceful
    /usr/sbin/apache2: /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2: no version information available (required by /usr/lib/libldap_r.so.2)
    Search recent threads on this forum for answer to this - it's just a warning.

    [Tue Jul 10 16:14:49 2007] [warn] module php5_module is already loaded, skipping
    I would guess this is probably due to having multiple LoadModule directives in your httpd.conf (or conf.d/php.conf, wherever this is loaded in Debian).

    [Tue Jul 10 16:14:49 2007] [crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP.
    Ouch, this is where apache is failing. Are you installing both apache and php from apt-get?

  3. #3
    mingswitch is offline Active Member
    Join Date
    Jul 2007
    Posts
    36
    Rep Power
    7

    Default

    thank you for your answer, can i use apache 1.3 and PHP4 mysql 4.0 with Zimbra or no??

    Or i need another version

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    You can use whatever version you like, it doesn't affect zimbra.

  5. #5
    mrdini is offline Active Member
    Join Date
    Mar 2007
    Posts
    33
    Rep Power
    8

    Default

    Quote Originally Posted by dijichi2 View Post
    Quote Originally Posted by mingswitch View Post
    thank you for your answer, can i use apache 1.3 and PHP4 mysql 4.0 with Zimbra or no??

    Or i need another version
    You can use whatever version you like, it doesn't affect zimbra.
    Correct. However, as a web programmer, I'd have to query whether you really need to (or even if you should) install such old versions of PHP & Apache.

    Go with PHP 5, & Apache 2.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Debian Zimbra VServer
    By scottp in forum Installation
    Replies: 2
    Last Post: 10-01-2007, 12:58 PM
  2. Replies: 2
    Last Post: 01-17-2007, 10:18 PM
  3. Mac OS X + Zimbra + Apache 2
    By abetam in forum Installation
    Replies: 1
    Last Post: 10-06-2006, 10:16 PM
  4. Zimbra AND Apache
    By fredo in forum Installation
    Replies: 4
    Last Post: 08-31-2006, 11:58 AM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •