Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: Installation Problem

  1. #31
    nwatson is offline Member
    Join Date
    Feb 2007
    Posts
    10
    Rep Power
    8

    Default

    ah, typo. Nothing in there either.

  2. #32
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    OK, sounds like zdesktop was never run. Could you try cd into <install> and run this:

    ./zdesktop start

  3. #33
    nwatson is offline Member
    Join Date
    Feb 2007
    Posts
    10
    Rep Power
    8

    Default

    that produces nohup.out:

    Code:
    1 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog
    259 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7633
    262 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7634
    262 [main] INFO org.mortbay.log - jetty-6.1.2rc1
    454 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.
    log4j:WARN No appenders could be found for logger (zimbra.misc).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server process is running as root, changing to user=zimbra uid=-1 gid=-1
    Zimbra server process, after change, is running with uid=-1 euid=-1 gid=-1 egid=-1
    log4j:ERROR setFile(null,true) call failed.
    java.io.FileNotFoundException: mailbox.log (Permission denied)
            at java.io.FileOutputStream.openAppend(Native Method)
            at java.io.FileOutputStream.<init>(Unknown Source)
            at java.io.FileOutputStream.<init>(Unknown Source)
            at org.apache.log4j.FileAppender.setFile(FileAppender.java:272)
            at org.apache.log4j.FileAppender.activateOptions(FileAppender.java:151)
            at org.apache.log4j.DailyRollingFileAppender.activateOptions(DailyRollingFileAppender.java:206)
            at org.apache.log4j.config.PropertySetter.activate(PropertySetter.java:247)
            at org.apache.log4j.config.PropertySetter.setProperties(PropertySetter.java:123)
            at org.apache.log4j.config.PropertySetter.setProperties(PropertySetter.java:87)
            at org.apache.log4j.PropertyConfigurator.parseAppender(PropertyConfigurator.java:645)
            at org.apache.log4j.PropertyConfigurator.parseCategory(PropertyConfigurator.java:603)
            at org.apache.log4j.PropertyConfigurator.configureRootCategory(PropertyConfigurator.java:500)
            at org.apache.log4j.PropertyConfigurator.doConfigure(PropertyConfigurator.java:406)
            at org.apache.log4j.PropertyConfigurator.doConfigure(PropertyConfigurator.java:307)
            at org.apache.log4j.PropertyWatchdog.doOnChange(PropertyConfigurator.java:673)
            at org.apache.log4j.helpers.FileWatchdog.checkAndConfigure(FileWatchdog.java:80)
            at org.apache.log4j.helpers.FileWatchdog.<init>(FileWatchdog.java:49)
            at org.apache.log4j.PropertyWatchdog.<init>(PropertyConfigurator.java:665)
            at org.apache.log4j.PropertyConfigurator.configureAndWatch(PropertyConfigurator.java:373)
            at org.apache.log4j.PropertyConfigurator.configureAndWatch(PropertyConfigurator.java:355)
            at com.zimbra.soap.SoapServlet.init(SoapServlet.java:87)
            at javax.servlet.GenericServlet.init(GenericServlet.java:241)
            at org.mortbay.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:449)
            at org.mortbay.jetty.servlet.ServletHolder.doStart(ServletHolder.java:259)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.servlet.ServletHandler.initialize(ServletHandler.java:593)
            at org.mortbay.jetty.servlet.Context.startContext(Context.java:139)
            at org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1174)
            at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:503)
            at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:444)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:147)
            at org.mortbay.jetty.handler.ContextHandlerCollection.doStart(ContextHandlerCollection.java:141)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:147)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:117)
            at org.mortbay.jetty.Server.doStart(Server.java:210)
            at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)
            at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:929)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at org.mortbay.start.Main.invokeMain(Main.java:183)
            at org.mortbay.start.Main.start(Main.java:497)
            at org.mortbay.start.Main.main(Main.java:115)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
            at com.install4j.runtime.Launcher.main(Unknown Source)
    log4j:ERROR Either File or DatePattern options are not set for appender [LOGFILE].

  4. #34
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Did you run installer as root? And are you running zdesktop as root? It seems that you are running into some kind of file permission issue. You should run the installer as regular user account and also run zdesktop as regular user. Make sure the location you are installing to is writable by your user account.

  5. #35
    nwatson is offline Member
    Join Date
    Feb 2007
    Posts
    10
    Rep Power
    8

    Default

    OK, I installed it in my home directory. It loads up now, however, there is no text on the buttons in the web-based installer, and afterward it hangs at the Loading... screen. It stops using any cpu or network. mailbox.log includes this:

    Code:
    2007-05-13 15:17:44,865 ERROR [Timer-Offline-Main] [] offline - unexpected exception during sync for account nwatson@nwatson.org
    java.lang.NullPointerException
            at com.zimbra.cs.service.UserServlet.getRemoteResource(UserServlet.java:1045)
            at com.zimbra.cs.mailbox.InitialSync.syncMessage(InitialSync.java:567)
            at com.zimbra.cs.mailbox.InitialSync.initialFolderSync(InitialSync.java:176)
            at com.zimbra.cs.mailbox.InitialSync.initialFolderSync(InitialSync.java:216)
            at com.zimbra.cs.mailbox.InitialSync.initialFolderSync(InitialSync.java:223)
            at com.zimbra.cs.mailbox.InitialSync.sync(InitialSync.java:115)
            at com.zimbra.cs.mailbox.InitialSync.sync(InitialSync.java:105)
            at com.zimbra.cs.mailbox.OfflineMailboxManager$SyncTask.sync(OfflineMailboxManager.java:121)
            at com.zimbra.cs.mailbox.OfflineMailboxManager$SyncTask.run(OfflineMailboxManager.java:94)
            at java.util.TimerThread.mainLoop(Unknown Source)
            at java.util.TimerThread.run(Unknown Source)

  6. #36
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    OK the NPE you see in the log is already fixed but after 0.38 was built.

    In terms of the loading issue, could you try doing a browser shift+reload? Also it may help if you clear all cache and cookies in the browser.

  7. #37
    nwatson is offline Member
    Join Date
    Feb 2007
    Posts
    10
    Rep Power
    8

    Default

    Didn't help anything. Here's from nohup.out:

    Code:
    1 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog
    359 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7633
    361 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7634
    361 [main] INFO org.mortbay.log - jetty-6.1.2rc1
    601 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.
    log4j:WARN No appenders could be found for logger (zimbra.misc).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server process is not running as root
    9196 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.
    9998 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.
    unable to load resource bundle: /msgs/com_zimbra_date
    unable to load resource bundle: /msgs/com_zimbra_email
    unable to load resource bundle: /msgs/com_zimbra_phone
    unable to load resource bundle: /msgs/com_zimbra_url
    unable to load resource bundle: /msgs/ZaMsg
    I don't see anything that looks like something died horribly in the other logs...

  8. #38
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Which browser are you using? Is it Firefox? If you have firebug installed, you can enabled firebug to see if there are any javascript errors. Typically UI not responding are due to javascript errors. It will be very helpful if you can see what javascript errors there are. Thanks!

  9. #39
    nwatson is offline Member
    Join Date
    Feb 2007
    Posts
    10
    Rep Power
    8

    Default

    It returns this error with Firebug:

    Code:
    _4a[i].toLowerCase is not a function
    (no name)(ZmIdentity _appCtxt=ZmAppCtxt name=nathan@tjbash.org)Boot_all.js.zgz (line 1106)
    (no name)(ZmIdentity _appCtxt=ZmAppCtxt name=nathan@tjbash.org)Boot_all.js.zgz (line 1089)
    (no name)(Object identity=[3])Boot_all.js.zgz (line 1182)
    startup(ZmCsfeResult _data=Object _isException=false)ZimbraCore_all.js... (line 16397)
    runAppFunction("startup")ZimbraCore_all.js... (line 15393)
    _handleResponseStartup(Object, ZmCsfeResult _data=Object _isException=false)ZimbraCore_all.js... (line 15265)
    run()Boot_all.js.zgz (line 541)
    _handleResponseLoadUserSettings(AjxCallback obj=ZmZimbraMail args=Object, ZmCsfeResult _data=Object _isException=false)ZimbraCore_all.js... (line 1919)
    run()Boot_all.js.zgz (line 541)
    _handleResponseSendRequest(Object soapDoc=AjxSoapDoc asyncMode=true, ZmCsfeResult _data=Object _isException=false)ZimbraCore_all.js... (line 14747)
    run()Boot_all.js.zgz (line 541)
    _runCallback(AjxCallback obj=ZmRequestMgr args=[1], Object)ZimbraLogin_all.j... (line 386)
    run()Boot_all.js.zgz (line 541)
    __handleResponse(AjxRpcRequest id=__RpcCtxt_0 __httpReq=XMLHttpRequest, AjxCallback obj=Object args=AjxCallback)AjaxLogin_all.js.... (line 3849)
    onreadystatechange(undefined)

  10. #40
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Perfect. Could you open a bug in bugzilla please with this information? Also mention that this is zdesktop 0.38 in the bug. That way you will receive email updates from the bug you open. Thanks!

Page 4 of 4 FirstFirst ... 234

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. INSTALLATION PROBLEM ON Centos 4.3 x_86-64Bit.
    By jawad@cogilent.com in forum Installation
    Replies: 11
    Last Post: 07-09-2007, 08:09 AM
  2. Problem with Ubuntu installation
    By Max Ma in forum Installation
    Replies: 3
    Last Post: 04-13-2007, 10:25 AM
  3. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM
  4. Installation problem
    By charlie in forum Administrators
    Replies: 1
    Last Post: 10-14-2005, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •