Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Compatability with Ubuntu 14.04 x64

  1. #11
    guen is offline Starter Member
    Join Date
    Jun 2014
    Posts
    1
    Rep Power
    1

    Default

    Hi Jim,

    I tried your solution on my newly installed 14.04, but I get this error : "Couldn't load XPCOM".

    I spent two hours (really) trying everything I could find, to no result. Or more exactly, I made progress, step by step, until stumbling on that one.

    The error is linked to XULrunner, so I wonder what you mean exactly when you write "including... adding an entry in my /etc/ld.so.conf.d area for /opt/zimbra/zdesktop/linux/prism/xulrunner". Can you tell me what you did? I mean, the exact command(s)... because my Linux skills are limited.

    Thank you in advance!

    Guénaël

  2. #12
    JDunphy is offline Junior Member
    Join Date
    Jan 2008
    Posts
    7
    Rep Power
    7

    Default

    You are close. By the way, I am now running this on 14.04 as I recently did an upgrade from 13.10.

    In the /etc/ld.so.conf.d directory, I placed the pathname /opt/zimbra/zdesktop/linux/prism/xulrunner into one of the existing files so that those libraries in the xulrnner directory are found. I doubt you need to do this as I was trying everything before I stopped and remembered the strace sommand. Have you tried running the command from the shell will strace in front of it so you can see where it aborts?

    # strace /opt/zimbra/zdesktop/linux/prism/zdclient -webapp "/home/YOURUSER/zdesktop/zdesktop.webapp" -override "/home/YOURUSER/zdesktop/zdesktop.webapp/override.ini" -profile "/home/YOURUSER/zdesktop/profile"

    When it blows up then add those libraries that are missing. Because my machine is used for development, my guess is you are missing libraries that I had installed for something else.

    The other command worth knowing is 'ldd' ... try this on your zimbra binary and it will tell you the missing libraries.. for example:

    # ldd /opt/zimbra/zdesktop/linux/prism/zdclient

    Hope this helps.

    Jim

  3. #13
    maxxer's Avatar
    maxxer is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    552
    Rep Power
    7

    Default

    Quote Originally Posted by JDunphy View Post
    I did this on my 64 bit ubuntu 13.10 install and ZD works well. The ia32-libs was a no go so try the following given the new direction of using multi arch.

    # apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386 libasound:i386
    # apt-get install libgtk2.0-0:i386 libxtst6:i386
    this worked for me. I just adjusted a bit for 14.04:
    Code:
    apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386 libasound2:i386 libgtk2.0-0:i386 libxtst6:i386
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  4. #14
    itmltd is offline Member
    Join Date
    Apr 2010
    Posts
    13
    Rep Power
    5

    Default

    Following command worked for me too,

    sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386 libasound2:i386 libgtk2.0-0:i386 libxtst6:i386

    Thanks everyone for help.

    OS : Kubuntu 14.04 x64

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Compatability with Microsoft Unified Communications?
    By lindsey in forum Administrators
    Replies: 4
    Last Post: 11-15-2011, 10:37 AM
  2. AstraSync Compatability
    By Guenther983 in forum Zimbra Mobile
    Replies: 19
    Last Post: 01-30-2010, 07:47 AM
  3. [SOLVED] Forwards Compatability 4.5.10 > 5.0.2
    By Nutz in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 02-15-2008, 06:53 PM
  4. connector versioning and compatability
    By shawnlhood in forum CalDAV / CardDAV / iSync
    Replies: 11
    Last Post: 01-02-2008, 05:45 PM
  5. Known Zimlet compatability issues with Zimbra 5?
    By Vimm in forum Administrators
    Replies: 3
    Last Post: 12-12-2007, 08:16 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •