Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Unable to Unmarshal

  1. #1
    akintemel is offline Active Member
    Join Date
    Aug 2010
    Location
    Turkey
    Posts
    42
    Rep Power
    4

    Question Unable to Unmarshal

    Hi ,

    I install Zdesktop7 beta1 on snow leopard 10.6.6 version.When i add new account i get this error :

    service.FAILURE: system failure: Unable to unmarshal response for AuthResponse

    and i try to add some others acount this time work good.But just one account i get this error.

    What is the problem.Colud you help me please.

    PS: Acount Type is Zimbra

  2. #2
    jflanigan is offline Zimbra Employee
    Join Date
    Jul 2010
    Posts
    106
    Rep Power
    4

    Default

    What version of ZCS are you connecting to? Does it work for you with other ZCS accounts; or is this the only one you have tried?

    If you take a look at zdesktop.log there might be more details. If you can post the entries surrounding your error it may help.

  3. #3
    akintemel is offline Active Member
    Join Date
    Aug 2010
    Location
    Turkey
    Posts
    42
    Rep Power
    4

    Default

    Quote Originally Posted by jflanigan View Post
    What version of ZCS are you connecting to? Does it work for you with other ZCS accounts; or is this the only one you have tried?

    If you take a look at zdesktop.log there might be more details. If you can post the entries surrounding your error it may help.

    i got nothing in log file ..just one account i can not add on zdesktop 7 beta .

  4. #4
    tfylling is offline Member
    Join Date
    Feb 2011
    Posts
    12
    Rep Power
    4

    Default

    I have experienced exactly the same thing trying to add an account from ZCS 7.0 in Zimbra Desktop 7.0 beta on two different windows machines (64 bit windows 7 Enterprise & Premium). It connects fine on the linux version. Also a few of my colleagues have set it up on windows (same versions) with no problem at all. One of my computers has had ZD 2.0.1 installed previously, but the other has not.

    Log entry since last shutdown from my AppData log (name and email has been replaced):
    2011-02-09 08:35:42,037 DEBUG [main] [] offline - DB migration check started...
    2011-02-09 08:35:42,039 DEBUG [main] [] offline - DB migration done
    2011-02-09 08:35:42,039 DEBUG [main] [] offline - zimbra db optimize started...
    2011-02-09 08:35:42,049 DEBUG [main] [] offline - zimbra db optimize done
    2011-02-09 08:35:42,522 INFO [main] [] extensions - Loading extensions from C:\Program Files (x86)\Zimbra\Zimbra Desktop\lib\ext
    2011-02-09 08:35:42,522 INFO [main] [] extensions - Initializing extensions
    2011-02-09 08:35:42,546 DEBUG [main] [] offline - Deploying new zimlets...
    2011-02-09 08:35:42,546 DEBUG [main] [] offline - Zimlets deployment done.
    2011-02-09 08:35:42,583 INFO [main] [] extensions - Post-Initializing extensions
    2011-02-09 08:35:42,795 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2011-02-09 08:35:42,965 INFO [main] [] log - No Transaction manager found - if your webapp requires one, please configure one.
    2011-02-09 08:35:43,020 INFO [main] [] log - Started SelectChannelConnector@127.0.0.1:55681
    2011-02-09 08:35:43,069 INFO [sync-manager-init] [] offline - service port is ready.
    2011-02-09 08:35:43,358 INFO [btpool0-1] [] extensions - Loading extensions from C:\Program Files (x86)\Zimbra\Zimbra Desktop\lib\ext
    2011-02-09 08:35:47,709 INFO [backup-timer] [] offline - Auto-Backup Disabled
    2011-02-09 08:36:03,101 DEBUG [btpool0-3] [] request - <AuthRequest xmlns="urn:zimbraAccount"><account by="name">something@domain.com</account><password>*</password><prefs/><attrs/></AuthRequest>
    2011-02-09 08:36:03,323 DEBUG [btpool0-3] [] response - <AuthResponse xmlns="urn:zimbraAccount"><authToken>0_a0c48239009 56874e9c8dba5a09930dd43c497c9_69643d33363a65346662 636235612d373633652d343932622d383833332d6363353262 666534366530333b6578703d31333a31323937343133323037 3433343b747970653d363a7a696d6272613b</authToken><lifetime>172800000</lifetime><prefs><pref name="zimbraPrefMailFlashTitle">FALSE</pref><pref name="zimbraPrefIMToasterEnabled">FALSE</pref><pref name="zimbraPrefCalendarApptAllowAtendeeEdit">TRUE </pref><pref name="zimbraPrefCalendarReminderYMessenger">FALSE</pref><pref name="zimbraPrefReadingPaneEnabled">TRUE</pref><pref name="zimbraPrefDeleteInviteOnReply">TRUE</pref><pref name="zimbraPrefSharedAddrBookAutoCompleteEnabled" >TRUE</pref><pref name="zimbraPrefForwardIncludeOriginalText">includ eBody</pref><pref name="zimbraPrefShowFragments">TRUE</pref><pref name="zimbraPrefHtmlEditorDefaultFontFamily">Times New Roman</pref><pref name="zimbraPrefAutoAddAddressEnabled">TRUE</pref><pref name="zimbraPrefIMFlashTitle">TRUE</pref><pref name="zimbraPrefComposeFormat">text</pref><pref name="zimbraPrefAutoSaveDraftInterval">30s</pref><pref name="zimbraPrefCalendarReminderSendEmail">TRUE</pref><pref name="zimbraPrefCalendarReminderFlashTitle">TRUE</pref><pref name="zimbraPrefContactsInitialView">list</pref><pref name="zimbraPrefCalendarAlwaysShowMiniCal">TRUE</pref><pref name="zimbraPrefAutocompleteAddressBubblesEnabled" >TRUE</pref><pref name="zimbraPrefSearchTreeOpen">TRUE</pref><pref name="zimbraPrefCalendarReminderDuration1">-PT15M</pref><pref name="zimbraPrefCalendarReminderMobile">FALSE</pref><pref name="zimbraPrefIMReportIdle">TRUE</pref><pref name="zimbraPrefCalendarApptReminderWarningTime">5 </pref><pref name="zimbraPrefContactsPerPage">25</pref><pref name="zimbraPrefWarnOnExit">TRUE</pref><pref name="zimbraPrefGetMailAction">default</pref><pref name="zimbraPrefIMInstantNotify">TRUE</pref><pref name="zimbraPrefOutOfOfficeCacheDuration">7d</pref><pref name="zimbraPrefConversationOrder">dateDesc</pref><pref name="zimbraPrefIMHideBlockedBuddies">FALSE</pref><pref name="zimbraPrefIMIdleTimeout">10</pref><pref name="zimbraPrefAccountTreeOpen">FALSE</pref><pref name="zimbraPrefShowCalendarWeek">FALSE</pref><pref name="zimbraPrefIncludeTrashInSearch">FALSE</pref><pref name="zimbraPrefGalSearchEnabled">TRUE</pref><pref name="zimbraPrefIMHideOfflineBuddies">FALSE</pref><pref name="zimbraPrefZimletTreeOpen">FALSE</pref><pref name="zimbraPrefComposeInNewWindow">FALSE</pref><pref name="zimbraPrefCalendarAllowPublishMethodInvite"> FALSE</pref><pref name="zimbraPrefFolderTreeOpen">TRUE</pref><pref name="zimbraPrefCalendarDayHourStart">8</pref><pref name="zimbraPrefUseKeyboardShortcuts">TRUE</pref><pref name="zimbraPrefUseRfc2231">FALSE</pref><pref name="zimbraPrefMailSelectAfterDelete">next</pref><pref name="zimbraPrefDedupeMessagesSentToSelf">dedupeNo ne</pref><pref name="zimbraPrefSaveToSent">TRUE</pref><pref name="zimbraPrefFromDisplay">My Name</pref><pref name="zimbraPrefIMLogChatsEnabled">TRUE</pref><pref name="zimbraPrefCalendarInitialView">workWeek</pref><pref name="zimbraPrefUseTimeZoneListInCalendar">TRUE</pref><pref name="zimbraPrefJunkLifetime">0</pref><pref name="zimbraPrefForwardReplyPrefixChar">></pref><pref name="zimbraPrefCalendarNotifyDelegatedChanges">FA LSE</pref><pref name="zimbraPrefMailSignatureStyle">outlook</pref><pref name="zimbraPrefFolderColorEnabled">TRUE</pref><pref name="zimbraPrefAdminConsoleWarnOnExit">TRUE</pref><pref name="zimbraPrefMessageViewHtmlPreferred">TRUE</pref><pref name="zimbraPrefCalendarSendInviteDeniedAutoReply" >FALSE</pref><pref name="zimbraPrefConvReadingPaneLocation">bottom</pref><pref name="zimbraPrefSentLifetime">0</pref><pref name="zimbraPrefShowSelectionCheckbox">TRUE</pref><pref name="zimbraPrefItemsPerVirtualPage">50</pref><pref name="zimbraPrefGroupMailBy">conversation</pref><pref name="zimbraPrefContactsExpandAppleContactGroups"> FALSE</pref><pref name="zimbraPrefSentMailFolder">sent</pref><pref name="zimbraPrefGalAutoCompleteEnabled">TRUE</pref><pref name="zimbraPrefAdvancedClientEnforceMinDisplay">T RUE</pref><pref name="zimbraPrefImapSearchFoldersEnabled">TRUE</pref><pref name="zimbraPrefContactsDisableAutocompleteOnConta ctGroupMembers">FALSE</pref><pref name="zimbraPrefIMLogChats">TRUE</pref><pref name="zimbraPrefCalendarAutoAddInvites">TRUE</pref><pref name="zimbraPrefInboxReadLifetime">0</pref><pref name="zimbraPrefVoiceItemsPerPage">25</pref><pref name="zimbraPrefShowSearchString">FALSE</pref><pref name="zimbraPrefForwardReplyInOriginalFormat">FALS E</pref><pref name="zimbraPrefDefaultPrintFontSize">12pt</pref><pref name="zimbraPrefIMNotifyPresence">TRUE</pref><pref name="zimbraPrefOpenMailInNewWindow">FALSE</pref><pref name="zimbraPrefHtmlEditorDefaultFontColor">#00000 0</pref><pref name="zimbraPrefReplyToEnabled">FALSE</pref><pref name="zimbraPrefClientType">advanced</pref><pref name="zimbraPrefTimeZoneId">Europe/Berlin</pref><pref name="zimbraPrefReadingPaneLocation">right</pref><pref name="zimbraPrefStandardClientAccessibilityMode">F ALSE</pref><pref name="zimbraPrefMailFlashIcon">FALSE</pref><pref name="zimbraPrefMailToasterEnabled">FALSE</pref><pref name="zimbraPrefInboxUnreadLifetime">0</pref><pref name="zimbraPrefMailSendReadReceipts">never</pref><pref name="zimbraPrefAutoCompleteQuickCompletionOnComma ">TRUE</pref><pref name="zimbraPrefTagTreeOpen">TRUE</pref><pref name="zimbraPrefMailSoundsEnabled">FALSE</pref><pref name="zimbraPrefHtmlEditorDefaultFontSize">12pt</pref><pref name="zimbraPrefCalendarAllowForwardedInvite">TRUE </pref><pref name="zimbraPrefBriefcaseReadingPaneLocation">bott om</pref><pref name="zimbraPrefIncludeSpamInSearch">FALSE</pref><pref name="zimbraPrefMailItemsPerPage">25</pref><pref name="zimbraPrefMarkMsgRead">0</pref><pref name="zimbraPrefReplyIncludeOriginalText">includeB ody</pref><pref name="zimbraPrefSkin">carbon</pref><pref name="zimbraPrefCalendarFirstDayOfWeek">1</pref><pref name="zimbraPrefMailInitialSearch">in:inbox</pref><pref name="zimbraPrefCalendarAllowCancelEmailToSelf">TR UE</pref><pref name="zimbraPrefCalendarReminderSoundsEnabled">TRU E</pref><pref name="zimbraPrefMailPollingInterval">5m</pref><pref name="zimbraPrefIMNotifyStatus">TRUE</pref><pref name="zimbraPrefTrashLifetime">0</pref><pref name="zimbraPrefDisplayExternalImages">FALSE</pref><pref name="zimbraPrefCalendarWorkingHours">1:N:0800:170 0,2:Y:0800:1700,3:Y:0800:1700,4:Y:0800:1700,5:Y:08 00:1700,6:Y:0800:1700,7:N:0800:1700</pref><pref name="zimbraPrefTasksReadingPaneLocation">bottom</pref><pref name="zimbraPrefCalendarDayHourEnd">18</pref><pref name="zimbraPrefIMSoundsEnabled">TRUE</pref><pref name="zimbraPrefCalendarShowPastDueReminders">FALS E</pref><pref name="zimbraPrefMandatorySpellCheckEnabled">FALSE</pref><pref name="zimbraPrefIMIdleStatus">away</pref><pref name="zimbraPrefIMAutoLogin">FALSE</pref><pref name="zimbraPrefIMFlashIcon">TRUE</pref><pref name="zimbraPrefFromAddress">something@domain.com</pref><pref name="zimbraPrefCalendarToasterEnabled">FALSE</pref><pref name="zimbraPrefCalendarApptVisibility">public</pref><pref name="zimbraPrefCalendarUseQuickAdd">TRUE</pref></prefs><attrs/><skin>carbon</skin></AuthResponse>

  5. #5
    jflanigan is offline Zimbra Employee
    Join Date
    Jul 2010
    Posts
    106
    Rep Power
    4

    Default

    If your signature or any of your other account settings in ZWC contain UTF-8 characters you will get this error. You can get around the problem for now by removing those characters from your signature.

    Bug 56547 - Unable to sync account if signature contains UTF-8 content

    That said, I don't notice any such characters in the last post so there may be more than one cause.

  6. #6
    tfylling is offline Member
    Join Date
    Feb 2011
    Posts
    12
    Rep Power
    4

    Default

    Yes. I actually found the problem a while after that note and spent the rest of the day being too busy to follow it up here. The problem, for me at least, seems to be that I have the norwegian letter in my name. When I changed my name in the account I could add it just fine. I then changed it back after adding the account and it seems to work fine thus far. It's still not a workable solution for us though if we need to manually change their names every time some of our users have to reinstall or want to set up mail on different machines, then wait for them to make the inital connection to change it back. , and are not uncommon in norwegian names, so this really needs to work prior to launch. (Seems to work just fine on Linux, as I said).

  7. #7
    akintemel is offline Active Member
    Join Date
    Aug 2010
    Location
    Turkey
    Posts
    42
    Rep Power
    4

    Default

    Quote Originally Posted by jflanigan View Post
    If your signature or any of your other account settings in ZWC contain UTF-8 characters you will get this error. You can get around the problem for now by removing those characters from your signature.

    Bug 56547 - Unable to sync account if signature contains UTF-8 content

    That said, I don't notice any such characters in the last post so there may be more than one cause.
    ok i try to edit my account i use english letter in my account and delete signature and i add zdekstop success my account. after add my account i edit my account back to normal and its work again zdesktop7.
    Last edited by akintemel; 02-10-2011 at 05:09 AM.

  8. #8
    krabina is offline Special Member
    Join Date
    Nov 2008
    Location
    Vienna, Austria
    Posts
    174
    Rep Power
    6

    Default Same problem here - not related to UTF

    Hi,
    I'm having the same problem here. When I try to add my account to ZimbraDesktop, I get the message

    service.FAILURE: system failure: Unable to unmarshal response for AuthResponse

    I removed the signatures, but it didn't help. I was able to add the account with Zimbra 6.0.10, but now, in 6.0.11 or 6.0.12 I get this error message...

    -Bernhard

  9. #9
    tfylling is offline Member
    Join Date
    Feb 2011
    Posts
    12
    Rep Power
    4

    Default

    There are several more places it could be. For my self I have to change both my name, display name, signature, mail alias (I think) and the From-field in preferences->mail->account. If you look at the log entry I posted above, that should indicate the amount of fields that are sent from the server to ZD when you try to create an account. It seems that if there are non-english characters anywhere in that large blob it will fail. I do hope this gets fixed soon!

  10. #10
    krabina is offline Special Member
    Join Date
    Nov 2008
    Location
    Vienna, Austria
    Posts
    174
    Rep Power
    6

    Default

    I don't really believe it's an UTF-8 issue.

    It works in Ubuntu 10.10, but doesn't work in Windows 7. (both 64bit versions). So the same account can be set up in ubuntu but not in W7...

    regards,
    Bernhard

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 03-04-2011, 01:55 PM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. AntiVirus unable to connect to localhost
    By net4home in forum Administrators
    Replies: 15
    Last Post: 07-25-2007, 05:55 PM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  5. Unable to Move Users to a Domain or Delete Domain
    By Justin Rock in forum Administrators
    Replies: 2
    Last Post: 10-06-2005, 12:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •