Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: [SOLVED] Installation fails on Ubuntu 10.10

  1. #1
    krabina is offline Special Member
    Join Date
    Nov 2008
    Location
    Vienna, Austria
    Posts
    174
    Rep Power
    6

    Default [SOLVED] Installation fails on Ubuntu 10.10

    Hello,

    I tried to install ZD 2.0 on Ubuntu 10.10 with the following commands:
    Code:
    sudo perl install.pl
    quit at the question on installing data files for root
    then install the user files with the command
    Code:
    perl  /opt/zimbra/zdesktop/linux/user-install.pl
    everything worked up to here, but ZD can't be started.
    Initially, the desktop-Icon had no Zimbra-Logo, just someting called zd.desktop leads to a message something like "the starter ist not marked as trustworthy".
    After clickin on properties on the zd.desktiop and selecting "run as application" the ZD-icon is shown, but clicking on in results in
    "child process /opt/zimbra/zdesktop/linux/prism/zdclient could not be executed (Permission denied)"

    What now?

    -Bernhard
    Last edited by krabina; 11-03-2010 at 01:04 PM.

  2. #2
    jflanigan is offline Zimbra Employee
    Join Date
    Jul 2010
    Posts
    113
    Rep Power
    5

    Default

    The first thing to check is if the user has rx access to the file in question. For example, if you installed it as root to the path /opt/zimbra, but your user does not have required permissions on /opt you might get this sort of error. You can try running zdclient from a shell and see what happens.

  3. #3
    krabina is offline Special Member
    Join Date
    Nov 2008
    Location
    Vienna, Austria
    Posts
    174
    Rep Power
    6

    Default

    Hmm. It finally worked, but I have to critisize the installation process:

    1. first error on running install.pl with as regular user (after running it as root and skipping data file install):

    Can't exec "/opt/zimbra/zdesktop/linux/user-install.pl": Permission denied at install.pl line 154, <STDIN> line 4.
    To install data files for additional users, please login as the user and run this command:
    /opt/zimbra/zdesktop/linux/user-install.pl

    2. after running user-install.pl I have to manually edit the desktop icon and select "open file as program"

    3. it still doesn't work. Have to manually set chmod 755 on the zdclient file

    ZD is such a great product, can't you make a smoother install procedure for ubunut?

    -bernhard

  4. #4
    krabina is offline Special Member
    Join Date
    Nov 2008
    Location
    Vienna, Austria
    Posts
    174
    Rep Power
    6

    Default

    correction: still doesn't work. now the start screen is shown, and this message appears:
    "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

    Script: file:///opt/zimbra/zdesktop/linux/prism/modules/WebAppProperties.jsm:232"

    after hitting "continue" this message appears:
    "Couldn't access Zimbra Desktop server. If issue persists after reinstall, please check logs for errors and report to http://www.zimbra.com/forums/zimbra-desktop."

  5. #5
    mhehnen is offline New Member
    Join Date
    Oct 2010
    Posts
    3
    Rep Power
    4

    Default

    Same with me.

    I've tried out various tests and the issue might be caused by the 64-bit environment (I am using Ubuntu 64-bit).

    Just starting "./zdclient" on the command line creates a number of
    "LoadPlugin: failed to initialize shared library" error messages for
    - /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so
    - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so
    - /usr/lib/mozilla/plugins/libtotem-cone-plugin.so
    - /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so
    - /usr/lib/mozilla/plugins/libtotem-mully-plugin.so
    - /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so
    - /var/lib/flashplugin-installer/npwrapper.libflashplayer.so

    The common error for all those shared libraries is: "wrong ELF class: ELFCLASS64", which seems to indicate some compatibility issues with my 64-bit environment.

    There are more messages:
    - Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

    and also some GTK warnings:
    (zdclient:3675): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64
    (zdclient:3675): Gtk-WARNING **: Loading IM context type 'ibus' failed
    (zdclient:3675): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64
    (zdclient:3675): Gtk-WARNING **: Loading IM context type 'ibus' failed
    (zdclient:3675): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64
    (zdclient:3675): Gtk-WARNING **: Loading IM context type 'ibus' failed


    Changing from "java-6-openjdk" to "java-6-sun-1.6.0.22" did not help.
    Calling "./zdclient" causes same messages with one exeption:
    Instead of "IcedTeaPlugin.so" the waring is issued for "libnpjp2.so"

    Any suggestions?

  6. #6
    krabina is offline Special Member
    Join Date
    Nov 2008
    Location
    Vienna, Austria
    Posts
    174
    Rep Power
    6

    Default

    I am using 64bit Ubuntu as well. But I have been running the release candidates without problems....

  7. #7
    chartness is offline Starter Member
    Join Date
    Oct 2010
    Posts
    1
    Rep Power
    4

    Default Same Issues

    I have the same issues with my Unbuntu 10.10 64 BIT Workstation.

    Seems to work fine on Centos 5.5 I386 Workstation.

  8. #8
    jflanigan is offline Zimbra Employee
    Join Date
    Jul 2010
    Posts
    113
    Rep Power
    5

    Default

    This may be related to problems with ia32-libs package. It sounds like many 32 bit applications are having trouble with this package on Ubuntu 10.10 64 bit.

    https://bugs.launchpad.net/ubuntu/+s...bs/+bug/646954
    https://bugs.launchpad.net/ubuntu/+s...bs/+bug/641056

    You might be able to either upgrade or downgrade ia32-libs depending on what version you are currently running.

  9. #9
    mhehnen is offline New Member
    Join Date
    Oct 2010
    Posts
    3
    Rep Power
    4

    Default

    I found a solution for my installation.
    The issue is related to the rights of the files, which needs to be extracted from the installation tar file.
    I have done the extraction on a NTFS volume and copied the extracted files to a EXT4 volume, added then the X (execution flag) and started the install.pl script.
    This way caused that all files were installed without execution rights.

    Solution:
    Extract the installation files as superuser directly into a Linux file system (EXT4 i.e.). Only this way ensures, that the execution flag is set and that the installation creates also executable files.
    Change to a normal user, if you start the script creating a user account.
    This creates then a executable desktop icon (on my first installation I needed to manually make the desktop icon executable) and this should launch ZD 2.0 without any problems anymore

  10. #10
    mdur is offline Starter Member
    Join Date
    Nov 2010
    Posts
    2
    Rep Power
    4

    Default Can't be that complicated to install ZD.2 on Ubuntu 10.10 32bit?

    I have followed this thread as I get the same error message, but on a 32 bit Ubuntu trying to install ZD 2.0 on a netbook Samsung NC10. The former ZD version worked fine, this one I cannot even install and I do not really understand the blogs above about how to do it properly by modifying all sorts of things. Sounds like one needs to be a Linux wizard to be able to get ZD installed? This way people (i.e. me :-) )get discuraged from trying Zimbra. Is there a simple step by step installation guide for ZD on Ubuntu 10.10 for Linux beginners?? Thanks!
    Marcel

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. installation fails on ubuntu 7.10
    By josevis in forum Installation
    Replies: 16
    Last Post: 11-22-2007, 03:44 PM
  2. Problem with Ubuntu installation
    By Max Ma in forum Installation
    Replies: 3
    Last Post: 04-13-2007, 10:25 AM
  3. Replies: 4
    Last Post: 11-07-2006, 07:12 AM
  4. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 08:19 AM
  5. Installation fault - getDirectContext fails
    By gregjohnson1024 in forum Administrators
    Replies: 3
    Last Post: 11-07-2005, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •