Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: fed 11 fix /etc/hosts

  1. #11
    ZenMasta is offline Senior Member
    Join Date
    Aug 2009
    Posts
    51
    Rep Power
    5

    Default

    Thanks, this gives me a lot to go on and should probably be the final piece. I just setup a new mx record for this subdomain (my hosting is with server beach). It should be working by tomorrow morning I'm sure so I can dig the mx

    in the meantime

    [zimbra@ZCS /]$ dig xyz.mydomain.com

    ; <<>> DiG 9.6.1-P2-RedHat-9.6.1-7.P2.fc11 <<>> xyz.mydomain.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4901
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;xyz.mydomain.com. IN A

    ;; ANSWER SECTION:
    xyz.mydomain.com. 86070 IN A my.wan.ip

    ;; Query time: 31 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Tue Dec 1 23:33:58 2009
    ;; MSG SIZE rcvd: 54
    [zimbra@xyz /]$ host `hostname`
    xyz.mydomain.com has address my.wan.ip
    [zimbra@xyz /]$ cat /etc/resolv.conf
    # Generated by NetworkManager
    domain mydomain.com (should these say xyz.mydomain.com?)
    search mydomain.com
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    How is this looking? I'll dig the mx in the morning after it has had time to propagate.

  2. #12
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Those results are incorrect, if you're behind a NAT router then you need to set-up a Split DNS and the IP address points to the LAN IP of your Zimbra server.

    You should also post the output of the following command:

    Code:
    cat /etc/hosts
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    ZenMasta is offline Senior Member
    Join Date
    Aug 2009
    Posts
    51
    Rep Power
    5

    Default

    Here is the latest output of those commands again.
    [zimbra@xyz mydomain]$ dig xyz.mydomain.com MX

    ; <<>> DiG 9.6.1-P2-RedHat-9.6.1-7.P2.fc11 <<>> xyz.mydomain.com MX
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30138
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;xyz.mydomain.com. IN MX

    ;; ANSWER SECTION:
    xyz.mydomain.com. 86400 IN MX 20 xyz.mydomain.com.

    ;; Query time: 110 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Wed Dec 2 11:01:46 2009
    ;; MSG SIZE rcvd: 54
    [zimbra@xyz mydomain]$ dig xyz.mydomain.com A

    ; <<>> DiG 9.6.1-P2-RedHat-9.6.1-7.P2.fc11 <<>> xyz.mydomain.com A
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55410
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;xyz.mydomain.com. IN A

    ;; ANSWER SECTION:
    xyz.mydomain.com. 86378 IN A my.wan.ip

    ;; Query time: 32 msec
    ;; SERVER: 208.67.222.222#53(208.67.222.222)
    ;; WHEN: Wed Dec 2 11:02:08 2009
    ;; MSG SIZE rcvd: 54
    [zimbra@xyz mydomain]$ host `hostname`
    xyz.mydomain.com has address my.wan.ip
    xyz.mydomain.com mail is handled by 20 xyz.mydomain.com.
    [zimbra@xyz mydomain]$ cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    [zimbra@xyz mydomain]$ cat /etc/resolv.conf
    # Generated by NetworkManager
    domain mydomain.com
    search mydomain.com
    nameserver 208.67.222.222
    nameserver 208.67.220.220

  4. #14
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    First of all... in your original post you were talking about a private LAN address of 192.168.13.175, but it looks like you are configuring this for a public IP address. If the machine is on a LAN of some sort you need to configure SplitDNS, or have a DNS server on the LAN that can give out internal IP address responses to one set of clients, and the public addresses to external clients (which is how my network is setup).

    So again, if this machine is on a LAN everywhere that you have "my.wan.ip" it needs to say 192.168.13.175.

    Also your /etc/hosts file needs to have a line like this in it:
    Code:
    192.168.13.175 xyz.mydomain.com xyz
    Also if it is on a LAN you need to change the /etc/resolv.conf, but i think setting up SplitDNS tells you to do this anyway.

  5. #15
    ZenMasta is offline Senior Member
    Join Date
    Aug 2009
    Posts
    51
    Rep Power
    5

    Default

    Yes this is on a private LAN, the only reason it says wan ip is because that's where the subdomain resolves to. I thought I had to have a real working subdomain in order to do this.

    Yes I will change my /etc/hosts file but remember how I said when I do that, I can't connect to the internet (or other computers can't connect to it on the LAN, ie over ssh/vnc)

    So, now that you see my /etc/resolv.conf , what do I have to change that to so I wont lose network connectivity?

    In your example your name servers are private.... which I don't have. I only have access to server beaches dns which is where I configured the new mx record and the subdomain.
    zimbra@email:~$ cat /etc/resolv.conf
    search xyz.mydomain.com
    nameserver 192.168.1.2
    nameserver 192.168.1.3
    So it seems there is absolutely no way of getting out of using splitdns...

  6. #16
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Yes if this is on a private LAN you MUST have a DNS server to respond with the private IP addresses, in my case I have 2 other servers on the network that act as internal DNS servers. What you need to do is setup SplitDNS so that your server queries itself for DNS, and will forward requests to the OpenDNS servers for domains it doesn't know about.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please fix your /etc/hosts file...
    By ipguru99 in forum Administrators
    Replies: 24
    Last Post: 07-02-2012, 08:34 PM
  2. ERROR: Please fix your /etc/hosts file
    By fsloke in forum Installation
    Replies: 1
    Last Post: 07-28-2008, 11:05 PM
  3. Replies: 11
    Last Post: 02-09-2008, 08:00 AM
  4. Broken /etc/hosts
    By mevets in forum Installation
    Replies: 1
    Last Post: 06-26-2007, 11:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •